LibreOffice Writer/Nozioni Generali

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

Scrivere libri è una scienza complessa, darle forma un'arte complessa. Questo libro tenta di parlare dell'«arte dell'edizione» indicando gli strumenti (e i trucchi) disponibili per creare un documento «perfetto» in Writer.

Prima però di iniziare questo lavoro alcuni concetti sono necessari, concetti che saranno presentati in questo capitolo. Due considerazioni:

1. Per i lettori con una minima base di conoscenza di sistemi quali LaTeX è possibile che le cose commentate in questo capitolo vi siano familiari, comunque vi raccomando di leggere quello che segue in modo tale che la nomenclatura specifica di Writer sia chiara dall'inizio.

2. Per i lettori con una forte base di conoscenza di sistemi quali LaTeX o che conoscano gente in quelle condizioni: LaTeX è un sistema magnifico, lo uso regolarmente, ho scritto con esso la mia tesi di dottorato e nel mio blog ci sono decine di articoli su come funziona, lo adoro, ma anche se insistete LaTeX non è per tutti.

Detto questo, andiamo avanti con l'introduzione.

Testo contro parola: una questione di stile[modifica]

Credo non sia sbagliato assumere che la maggior parte dei miei lettori si sia iniziata all'informatica in un sistema Windows scrivendo in un programma dove una piccola clip animata si comportava come se conoscesse meglio di noi cosa stavamo facendo («sembrava che lei stesse scrivendo una lettera»), un correttore grammaticale segnalava frasi giuste e lasciava passare quelle sbagliate e, più importante, un'interfaccia grafica carica di bottoni ci spingeva ad applicare il formato (font, dimensioni, allineamento…) direttamente.

Semplificando enormemente (in questa sezione le cose saranno semplificate sistematicamente) potremmo dire che questo tipo di programma nel quale l'operatore deve occuparsi quasi parola per parola della presentazione di quello che scrive merita il nome di processore di parole. In un certo senso i processori di parole hanno portato nell'era elettronica il concetto di «macchina da scrivere»: offrono certamente un numero maggiore di opzioni, però il concetto di base del funzionamento rimane invariato.

Allontanandoci da questo arcaico concetto di «macchina da scrivere», però comunque lasciando all'utente quasi tutto il lavoro di decidere dove va ogni elemento e come si presenta il tutto, ci sono i sistemi di autoedizione, quelli che in inglese vengono chiamati Desktop Publishing Tool o DPT. Questi sistemi servono a creare documenti dove diversi elementi quali immagini, grafici, quadri di chiarimento, eccetera devono alternarsi in forma dinamica (libri di fotografia, cataloghi…). In un programma DPT il testo è soltanto un elemento del tutto e non necessariamente il più importante.

Pertanto, qual è l'opzione che rimane se vogliamo creare un documento dove regna il testo, un documento con strutture che, anche se mostrano diverso contenuto, devono ripetersi nella forma un numero enorme di volte come per esempio i titoli che indicano l'inizio di ogni nuovo capitolo in un romanzo? Ripetere questo formato manualmente ogni volta può rivelarsi, in documenti con centinaia di pagine, in un vero incubo.

Bene, proviamo a immaginare l'esistenza di un sistema nel quale ogni parte di nostro testo può ricevere un'«etichetta», qualcosa che possiamo chiamare stile. Questo stile potrebbe avere diversi valori, quali «titolo del capitolo», «corpo del testo», «codice», «istruzione»… Durante la stesura del testo invece di dare un determinato (e dettagliato) formato semplicemente diamo il valore «corpo del testo» per il testo principale, o «Capitolo» ai titoli dei nostri capitoli… e così via. Dopo, in qualche parte del nostro programma ideale diciamo, per esempio, «corpo del testo equivale alla tipografia Liberation Serif, 12 punti, normale e con rientro di prima riga di cinque millimetri».

Il vantaggio di un tale sistema risulta chiaro: se a un certo punto dobbiamo cambiare il font (o un suo attributo) semplicemente dobbiamo andare alla definizione del nostro stile, cambiare Liberation Serif per Libertinus Serif, 12 punti per 11 e il testo «marcato» con l'etichetta «corpo del testo» aggiornerà il suo formato automaticamente e senza sforzi per l'utente. Ma soprattutto, questo aggiornamento avverrà senza disturbare le altre parti del documento.

Però i vantaggi di un tale sistema non finiscono qui. Se definiamo lo stile «Titolo di capitolo» (o «Titolo 1» o il nome che si vuole), possiamo dire «tutto il testo con lo stile "Titolo di capitolo" dev'essere listato nell'indice generale». Possiamo anche dire «allo stile "Titolo di capitolo" viene associato una numerazione automaticame». Possiamo anche dire «lo stile "Titolo di capitolo" dev'essere seguito dallo stile "Sezione" e questo dallo stile "Corpo del testo"». Possiamo anche dire «lo stile "Titolo di capitolo" va all'inizio di una pagina con ben precise caratteristiche, la quale dev'essere seguita da pagine con caratteristiche diverse ma anche quelle ben definite»… cioè, molto di più di quanto si può dire applicando la formattazione direttamente.

È vero, quei processori di parole dei quali parlavamo all'inizio hanno acquisito nelle successive versioni l'abilità di definire titoli, indici e numerazioni e i sistemi DPT hanno anche degli strumenti di automatizzazione del formato, però la gestione di queste caratteristiche generalmente non risulta così semplice.

Ma, esistono dei programmi come quello appena descritto che ci permettano di diventare liberi dalla tirannia di premere tasti predefiniti? La risposta è sì: infatti esistono da prima di quel famoso processore di parole e la sua molesta clip.

Nel 1977 Donald E. Knuth creò le basi di uno dei sistemi tipografici più potenti. Mi riferisco certamente al sistema TeX che qualche anno dopo fu ampliato da Leslie Lamport in quello che oggi è conosciuto come LaTeX, il quale a sua volta riceve supporto Unicode grazie a varianti quali XeTeX.

Non entrerò nei dettagli di cos'è e cosa non è LaTeX perché questo libro è su Writer.[1] Soltanto dirò che ha un importante problema: nella sua forma più semplice somiglia di più a un linguaggio di programmazione che a un sistema di composizione di testi. Questo fa sì che «l'utente normale» (quello che non ha bisogno di formule matematiche complesse) di solito s'intimorisca con la sua struttura, perché anche se le istruzioni LaTeX di base sono semplici, continuano a essere istruzioni

È vero, ci sono programmi grafici che semplificano la vita dell'utente LaTeX. Alcuni, come il fantastico LyX sono di grande aiuto per l'utente novello, ma come dicevo al principio, non è per tutti.

Cioè? Writer rappresenta un'alternativa che ha molte cose in comune con LaTeX (più di quante sembrano al primo colpo d'occhio) ma risolvendo alcuni dei suoi problemi… e introducendo, certamente, altri problemi dei quali parleremo nei seguenti capitoli.

Non esiste il sistema perfetto. Per alcuni compiti (scrivere una tesi in fisica o matematica) LaTeX è semplicemente imbattibile, per altri compiti invece Writer sarà imbattibile.

Se Writer serve o meno per il lavoro è qualcosa che solo potrà dire chi deve realizzare quel lavoro: in questo libro vedremo gli strumenti e i «trucchi» necessari per risolvere i problemi presenti in Writer per decidere se serve o meno per i nostri propositi.

Però prima di cominciare, un paio di consigli generali che non dipendono del sistema utilizzato per scrivere:

  • Il formato in cui si presenta il libro è meno importante che il suo contenuto e perciò dovremmo lasciarlo alla fine. Questo però può realizzarsi soltanto se la struttura del libro risulta ben costruita.
  • Il formato del libro dovrebbe preoccupare lo scrittore soltanto se sarà anche l'editore. Infatti, se il lavoro di edizione sarà realizzato da una casa editrice nulla di quanto l'autore possa creare in termini di formattazione rimarrà in piedi. Ancora una volta l'autore dovrà preoccuparsi soltanto da dare al documento la struttura giusta per facilitare il lavoro degli editori.

In sintesi, dovremo solo preoccuparci (oltre al contenuto, certamente) di organizzare il documento perché tutto il resto sono soltanto dei dettagli secondari… e Writer è un magnifico strumento tanto per creare documenti strutturati che per i dettagli secondari.

La struttura del libro[modifica]

Per struttura s'intende la chiara separazione di ogni parte del libro tramite una «gerarchia» di stili. Per esempio:

  1. Parte (raggruppa capitoli)
  2. Capitolo (raggruppa sezioni)
  3. Sezione (separa frammenti di testo normale)
  4. Testo normale (il corpo principale del documento)
  5. Paragrafi speciali (commenti, eccetera)
  6. ...

Con Writer costruire una struttura di questo genere risulta veramente semplice: si devono soltanto utilizzare nella forma giusta una serie di stili di paragrafo appropriati e assegnare a ognuno di loro un «livello». Mi permetto d'insistere in questo concetto: la configurazione particolare di ognuno di questi stili non è importante durante la stesura del testo, soltanto alla fine del processo.

Quando lo scrittore è anche editore[modifica]

Finito il contenuto del nostro magnifico libro arriva l'ora di «mettere tutto in ordine».

Nei seguenti capitoli ci occuperemo di definire quest'«ordine» e di capire come realizzarlo. Avanzando a partire dagli strumenti di base arriveremo a dominare gli stili, la gestione dei grafici, dei riferimenti incrociati, dei campi… di tutto quello che serve per far sì che il nostro documento si presenti nel modo desiderato con il minor sforzo possibile.

I pericoli della formattazione diretta[modifica]

Figura 1: Un mondo di carateri speciali

Voglio sottolineare qui il fatto che applicare direttamente il formato non è una buona idea.

Il problema principale è che la formattazione diretta ha la precedenza sugli stili: se selezioniamo una porzione di un paragrafo e cambiamo qualcosa tramite formattazione diretta potrebbe accadere che al momento di modificare lo stile di paragrafo di base quella parte del testo non si aggiorni correttamente, portando a risultati strani.

Per esempio, un errore molto diffuso è quello d'includere simboli (caratteri greci, simboli matematici) utilizzando un font diverso da quello del paragrafo di base. Questo dovrebbe essere evitato e infatti non è necessario: i font unicode possiedono un ampio range di simboli che inoltre sono stati sviluppati per mantenere un'identità con il font di base. Libertinus Serif (vedere Figura 1), per esempio, include tutto l'alfabeto greco, quello cirillico, quello ebraico, numerosi simboli matematici, frecce, simboli fonetici… per quale motivo dobbiamo complicarci l'esistenza usando il font symbol per inserire un semplice α?

L'unico caso in cui si potrebbe perdonare l'uso del formato diretto è l'applicazione casuale di corsivo, del grassetto o degli apici e pedici: per tutto il resto (ma a volte e come vedremo nel capitolo D.11, anche lì) è meglio mantenere la consistenza del documento tramite l'uso degli stili.

IMPORTANTE: il modo migliore (e anche quello più semplice) per «disativare» il formato diretto una volta applicato è l'utilizzo dei tasti di scelta rapida Ctrl+M che realizzano la medesima funzione del menù Formato → Cancella formattazione diretta. In questo modo saremo sicuri che il testo che venga dopo sarà formatato dallo stile di paragrafo e non ci saranno inconvenienti.

Altre pratiche comuni che si dovrebbero a ogni modo evitare sono l'utilizzo dei tabulatori per creare rientri di prima linea nei paragrafi e inserire linee vuote per generare spazi tra paragrafi: come vedremo, entrambi le cose si gestiscono in modo molto più conveniente con la definizione degli stili di paragrafo.

Il documento durante la scrittura[modifica]

In generale, Writer fa vedere durante la scrittura del documento qualcosa di quasi identico a quello che sarà stampato o esportato in PDF: la posizione degli oggetti, la loro dimensione, i font… La «piccola differenza» si trova negli elementi generati automaticamente: l'indice generale, i campi, i riferimenti incrociati. Tutti questi elementi si presentano con un fondo grigio. Questo fondo non viene né stampato né esportato in PDF ed è lì soltanto per dire che l'elemento o il testo sono stati creati in modo automatico.

Lo stesso succede con i limiti delle cornici o con i limiti dell'area di testo di ogni pagina che si possono far vedere sia con degli «angolini» sia con una linea continua (quando i caratteri non stampabili sono attivi). È possibile togliere queste linee e questi sfondi anche se lo sconsiglio: risultano di grande aiuto durante la scrittura del documento.

Nel capitolo B.1 torneremo su questo.

Sulle tabulazioni[modifica]

Il famoso tasto «tab» ha cambiato funzione dalla sua creazione nelle antiche macchine da scrivere meccaniche: oggi viene utilizzato per cambiare finestre (in combinazione con Alt), per saltare da un campo all'altro in un formulario, da un tasto prescelto ad altro… e per generare fastidiosi problemi di formattazione.

Nella maggioranza dei processori di testo WYSIWYG (What You See is What You Get: quello che vedi è quello che ottieni), e in questo Writer non è un'eccezione, questo tasto conserva in parte la funzione di saltare tra «colonne immaginarie» nel testo, ma con l'aggravante di essere rappresentato da un carattere di formatta- zione che può muoversi insieme al testo generando non poche confusioni negli utenti.

Sotto Strumenti → Opzioni → LibreOffice Writer → Generale si trova un'opzione chiamata Tabulazioni, normalmente fissata in 1,25 cm. Molti utenti pensano che questo significhi che se in un paragrafo si preme TAB più volte il cursore «salterà» da 1,25 cm ogni volta, ma quello che in realtà accade è che questa configurazione divide la larghezza dell'area di testo in colonne fisse di 1,25 cm, perciò quello che il tasto TAB fa veramente è portate il cursore alla colonna più vicina a destra del punto d'inserimento.

Questa differenza risulta importante per utilizzare le tabulazioni correttamente: chiedo al lettore di provare a inserire un TAB in mezzo a due parole per dopo aggiungere lentamente del testo davanti alla prima parola… adesso dovrebbe essere chiaro il perché il testo dopo il TAB «salta» in quel modo.

Data questa «mobilità» i TAB risultano un mezzo di formattazione «pericoloso»: la distribuzione del paragrafo potrebbe cambiare di molto anche con l'aggiunta di un unico carattere.

Se si desidera utilizzare i TAB correttamente è necessario conoscere dove vengono collocati e controllare perfettamente le loro proprietà.

Fortunatamente entrambe le cose sono semplici da ottenere: la prima attivando i caratteri non stampabili (l'icona con il simbolo ¶ nella barra degli strumenti standard), la seconda configurando queste «colonne immaginarie», non come qualcosa generale di Writer, ma nello stile di paragrafo utilizzato. Torneremo su questo nella pagina Gli strumenti di base.

Avvertimento sui formati di file[modifica]

Il formato in cui MSOffice salva i suoi documenti era fino a poco tempo fa un segreto ben custodito, perciò gli attuali filtri di conversione furono originalmente creati tramite «ingegneria inversa», processo difficile e dai risultati non sempre certi. La situazione dei filtri di conversione migliora a ogni nuova versione del programma ma piccole differenze nel formato sono quasi inevitabili, perciò per massima sicurezza (e per essere sicuri che tutto ciò che si racconta in questo libro funzioni correttamente) mi permetterò d'insistere nel seguente concetto:

Bisogna utilizzare sempre i formati nativi per salvare i documenti. Per Writer, utilizzare sempre il formato odt.

Anche se Writer permette d'esportare nel formato doc(x) non è buona idea utilizzare questo formato per immagazzinare i file. Soltanto nel caso di dover inviare una copia del documento a qualcuno che per qualche motivo non riesce a utilizzare Writer (e soltanto nel caso la persona debba modificarlo e pertanto non gli serva un PDF) si può esportare nel formato doc(x) una copia del documento.

Esportare da e reimportare in un formato estraneo al programma da noi utilizzato può comportare enormi e gravi problemi con la definizione degli stili: Writer e MSWord sono programmi distinti che lavorano in modo diverso. Concetti fondamentali in Writer come gli stili di pagina non esistono in MSWord e pertanto la «traduzione» darà sempre problemi che saranno tanto più gravi quanto più complessi saranno i documenti importati.

L'unico modo di ottenere una compatibilità al 100% con MSOffice è utilizzare MSOffice… e a volte neanche quello risulta sufficiente.

Se si desidera utilizzare Writer si deve fare in modo completo e questo certamente comprende l'utilizzo dei formati nativi.

Dati utenti[modifica]

Writer ha un metodo molto ingegnoso di decidere se all'apertura di un documento deve andare all'ultimo punto modificato oppure all'inizio: se l'informazione dell'utente del programma coincide con l'informazione dell'autore del documento si va all'ultimo punto editato, altrimenti all'inizio del documento.

La logica qui è semplice: l'autore del documento vuole certamente continuare a lavorare nel punto dove lo ha lasciato mentre una persona diversa vorrà leggerlo e pertanto l'inizio del file è il punto più logico. Comunque, per muoversi all'ultimo punto modificato la combinazione MAIUS+F5 sarà sufficiente mentre Ctrl+HOME ci porterà all'inizio del documento.

Ma, da dove prende Writer quest'informazione? Tutto si trova in Strumenti → Opzioni → LibreOffice → Dati utente: non è necessario compilare tutti i campi, uno solo sarà sufficiente per dare un'identità all'utente. Alla creazione di un nuovo documento, Writer automaticamente include l'informazione necessaria e il sistema funziona perfettamente.

E per i documenti vecchi? Come si fa a dire loro che siamo i suoi «proprietari»? Semplice: dopo aver aperto un documento senza informazione o con l'informazione sbagliata dobbiamo andare al menù File → Proprietà → scheda Generale dov'è sufficiente mettere la spunta su Usa i dati utente per poi premere Azzera le proprietà.[2]

Note[modifica]

  1. Se volete potete consultare gli articoli su LyX nel mio blog: [1]
  2. Questo stesso procedimento ma togliendo la spunta può essere utilizzato per cancellare l'informazione utente di un file.