Differenze tra le versioni di "Blender/Blender VSE"

Jump to navigation Jump to search
nessun oggetto della modifica
==Apertura progetto==
Per generare un nuovo progetto in Blender clicchiamo su un'area vuota (non scegliere nessuna opzione) alla comparsa della finestra di benvenuto
[[File:BlenderVSE1.png|nessuno|miniatura|440x440px]]
Se si sono seguite le istruzioni riportate nei paragrafi precedenti dovremmo essere accolti dall'interfaccia personalizzata che avevamo salvato con lo shortcut Ctrl+U .
 
La prima cosa da fare è quella di salvare il progetto con Ctrl+S oppure da File>Save.... e dare un nome opportuno. Di default nei sistemi Gnu/Linux il file verrà salvato nella propria home, il mio consiglio sarebbe quello di creare una cartella e nominarla con un nome adeguato e riconoscibile al cui interno verranno create altre directory contenenti files di vario tipo. In tale cartella salvare il file del progetto.
 
Una volta terminato il lavoro sarà semplice archiviare la directory (leggere il capitolo Generare un' archivio compresso di backup). Lo schema consigliato potrebbe essere di questo tipo:
[[File:BlenderVSE7.png|nessuno|miniatura|440x440px]]
 
== Aggiungere clip ==
Per aggiungere clip (audio, video e immagini) premiamo Shift+A (il puntatore del mouse deve risiedere all'interno della finestra sequencer) o dal menù del Sequencer Add e scegliamo Movie, Image o Sound per accedere al file browser. Una volta identificato cliccare su Add xxxx Strip.
 
Prima di aggiungere la clip è consigliabile posizionare il cursore della Timeline nel punto preciso di ingresso.
 
Le prime operazioni da effettuare risultano il corretto posizionamento della clip (leggere Posizionamento clip) e l'analisi relativa ai parametri fps e risoluzione video (leggere Proprietà clip).
 
== Posizionamento clip ==
Possiamo spostare le clip inserite selezionandole con il tasto destro del mouse quindi premendo G (Grab), la clip ora sarà vincolata al puntatore e sarà possibile spostarla lungo l'asse orizzontale (temporale) e verticale (numero traccia o canale). La stessa operazione la possiamo eseguire, una volta selezionata la clip con il tasto destro, tenendolo premuto e trascinando. Per confermare la nuova posizione premere il tasto sinistro.
 
Per vincolare lo spostamento al solo asse orizzontale o verticale selezionare la clip (tasto destro), premere G quindi X (orizzontale) o Y (verticale).
 
Un' altro metodo consiste nel far comparire la Properties Windows premendo il tasto N con il puntatore del mouse nella finestra Sequencer e modificando i valori dei campi Start Frame: (posizione di ingresso clip) e Lenght: (durata o lunghezza) per l'asse temporale ed il valore Channel: per spostare la clip su una traccia superiore o inferiore. In entrambi i casi si rende necessario avere precedentemente selezionato la clip da editare con il tasto destro.
 
Le clip sono fornite di due maniglie poste una nel margine destro e una in quello sinistro (riconoscibili da una freccia) che se selezionate (tasto destro) consentono un accorciamento della durata (trascinare verso l'interno) o un allungamento (trascinare verso l'esterno). Nel caso di clip audio l'allungamento non è consentito, allungando invece una clip video si otterrà l'effetto di visualizzare un'immagine statica dell'ultimo frame.
 
Nessun problema invece per clip immagine.
 
== Proprietà clip ==
E' necessario controllare le proprietà delle clip video inserite in un progetto relativamente al freme rate (fps, frame rate per second) e alla sua dimensione (risoluzione video). Blender, a differenza dei normali editor video, non effettua nessun aggiustamento relativo al fps, si rende quindi necessario effettuare la corretta impostazione di tale parametro manualmente. Nella seguente ipotesi supponiamo di avere un file video da editare con queste caratteristiche (le possiamo recuperare mandandolo in play su VLC e premendo Ctrl+J):
 
fps 25
 
risoluzione 1920 x 1080
 
Per settare correttamente la dimensione del nostro progetto possiamo modificare manualmente i valori nel campo Resolution presenti nella Properties Windows oppure automaticamente dal menù Strip>Set Render Size della finestra del Sequencer all'esatta dimensione della clip. Nel caso fosse nostra intenzione realizzare un progetto di dimensioni superiori (upscaling) o inferiori (downscaling) procedere solo manualmente sui parametri di cui sopra facendo attenzione al corretto rapporto larghezza/altezza della clip. Per non sfalsare tale rapporto è necessario spuntare l'opzione Image Offset nella Properties Windows della finestra Sequencer.
 
Nel caso di un fps di progetto diverso da quello presente nella clip si noterà la mancanza di sincronia audio/video e una lunghezza diversa tra la clip audio e video. Nei casi di editing con clip video di fps diversi leggere Clip con fps diversi.
 
== Durata del progetto da renderizzare ==
Di default Blender imposta la dimensione in frame del progetto a 250, arrivato a tale frame la riproduzione riprende da capo. Se volessimo renderizzare il progetto il frame 250 sarebbe l'ultimo elaborato. Abbiamo quindi la necessità di allungare la durata del progetto per poter vedere l'anteprima del nostro lavoro. Ci sono principalmente due modi:
 
modificando il campo End Frame: nella scheda Dimension della Properies Windows ad un valore pari a:
 
fps x 60 x minuti
 
Se vogliamo che il nostro progetto duri 10 minuti esatti ed il frame rate è 25
 
impostiamo:
 
25 x 60 x 10 = 15000
 
Se non conosciamo la durata precisa portiamo il cursore del Sequencer in un punto a piacere, spostiamo il puntatore del mouse nella finestra Timeline e premiamo E (end).
 
Terminato il lavoro posizioneremo con precisione tale punto. Con lo stesso procedimento possiamo posizionare anche l'inizio del progetto; posizioniamo quindi il cursore del Sequencer nel punto desiderato, spostiamo il cursore del mouse nella finestra Timeline e premiamo S (start). Ora il nostro progetto inizierà da quel punto.
 
Se abbiamo necessità di riprodurre per un breve periodo una limitata zona del Sequencer possiamo premere P con il cursore del mouse nel Sequencer, trascinare creando una finestra di selezione e rilasciare il tasto sinistro. Per ripristinare la selezione alla situazione impostata nella Properties Windows premere Alt+P.
 
== Taglio clip ==
Ci sono due modi per tagliare le clip, il primo consiste nel posizionare il cursore del Sequencer nella zona interessata, selezionare la clip quindi premere K (knife, taglio) effettuando così un Cut (Soft) at Frame ovvero un taglio ripristinabile agendo sulle maniglie della clip. Il secondo di differisce dall'usare Shift+K Cut (hard) at Frame, la lunghezza in questo caso non è ripristinabile.
 
== Applicare una dissolvenza dal/al nero ==
Per applicare una dissolvenza dal nero ad una traccia video dobbiamo per prima cosa posizionare il cursore del Sequencer nel punto esatto di inizio, aggiungere una clip colore (nero) con Shift+A>Effect Strip...>Color, selzionare prima la clip color e poi, tenendo premuto il tasto Shift, la clip video ed aggiungere una transizione con Shift+A>Effect Strip...>Cross
 
La stessa procedura è valida per applicare una dissolvenza al nero, dobbiamo però avere cura di selezionare prima la clip video, poi quella colore ed applicare una transizione di tipo Cross.
 
Da notare che per modificare la durata di tale transizione è sufficiente agire sulla durata della clip colore modificandone i valori o dalla Properties Windows o trascinandone le maniglie.
 
Possiamo ottenere lo stesso risultato inserendo la clip colore prima della clip video (dissolvenza dal nero) e dopo (dissolvenza al nero) lasciando una spazio tra le due. Rimane invariata la regola di selezionare prima la clip di entrata e poi quella di uscita per non ottenere un effetto indesiderato. In questo caso la durata della transizione dipende da quanto spazio lasciamo tra le clip.
 
== Dissolvenzetra clip ==
Come visto nel paragrafo precedente possiamo dissolvere clip di ogni tipo con lo stesso procedimento. Oltre alla dissolvenza di tipo Cross possiamo usare quella di tipo Wipe. Modificandone le proprietà nella Properties Windows possiamo scegliere, nella scheda Effect Strip>Transition Type tra Clock, Iris, Double o Single . In Direction cliccando su In o Out invertiamo la clip di entrata. Blur Width: consente di scegliere la quantirà di sfumatura da applicare all'effetto mentre Angle: consente di ruotare la linea di transizione a piacere.
 
== Testo in sovraimpressione ==
Possiamo aggiungere del testo in sovraimpressione con Shift+A>Effect Strip.... Text modifichiamo il campo Text della scheda Effect Strip inserendo tutto il testo, modifichiamo il valore di Size, Color, Location ecc. a piacimento.
 
In alternativa possiamo realizzare del testo con Gimp o Inkscape esportandolo in formato png e lasciando lo sfondo con canale alfa per la trasparenza.
 
Un'ulteriore alternativa potrebbe essere quella di creare in Blender del testo 3D ed aggiungerlo nel Sequencer con Shift+A >Scene...>Nome Scene.
 
Proxy Render Size
 
Se l'anteprima del video da montare non dovesse essere sufficientemente fluida è possibile creare una clip proxy con qualità variabile (25%, 50%, 75%, 100%) per migliorare nettamente le prestazioni del pc. Possiamo realizzarla selezionando la clip da convertire, spuntando Proxy/Timecode nella Properties Windows e cliccando su Set Selected Strip Proxies.
 
Le opzioni presentate sono:
 
­ Proxy Storage: Strip per convertire la sola clip o Project convertendo tutto il progetto
 
­ Proxy Custom Directory per impostare una directory a piacere dove salvare il file
 
­ Proxy Custom File per dare un nome diverso dal predefinito
 
­ 25%, 50%, 75%, 100% la percentuale relativa alla qualità del file, 25% sarà più fluido di 75%
 
­ Quality un ulteriore possibilità di alleggerire la proxy.
 
Fatte le nostre scelte possiamo cliccare su Rebuild Proxy and Timecode Indices (presente anche nel menù Strip).
 
Non resta che aspettare la conclusione della conversione, il tempo dipende dalle risorse del pc e dalla lunghezza del video.
 
Conclusa la conversione portiamoci nella scheda View Setting della Properties Windows del Viewer , espandiamo il menù Proxy Render Size e scegliamo la qualità alla quale abbiamo convertito. Mandando in play noteremo un netto miglioramento sulla fluidità di riproduzione e una peggiore qualità di visualizzazione dell'anteprima.
348

contributi

Menu di navigazione