Blender/Blender VSE

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search

Installazione[modifica]

Per installare Blender in Debian e derivate:

#apt-get install blender

Per installare Blender in Fedora e derivate:

#dnf install blender

In alcune distribuzioni (Fedora e derivate) il software non è pacchettizzato con i codec, se aggiungendo una clip video venisse visualizzato un errore si rende necessario scaricare dal sito il software seguendo questi semplici passaggi: scaricare da questo link [1] la versione adatta al proprio sistema operativo (32 o 64 bit), decomprimere facendo clic destro sul file blenderxxxxx.tar.bz2 e scegliendo dal menù a tendina "Estrai qui" oppure da terminale con la seguente procedura:

1­- spostare il file scaricato nella propria home

2­- aprire il terminale ed incollare:

tar -xfv blender*

verrà creata una nuova cartella, aprirla e fare clic sul file eseguibile blender per avviare il programma

Interfaccia[modifica]

Blender interfaccia.png


Prima apertura[modifica]

Alla prima apertura siamo accolti da una finestra di benvenuto nella quale sono visualizzate alcune informazioni e opzioni:

BlenderVSE1.png

  • versione di Blender in alto

­

  • link utili in basso a sinistra (links)

­

  • progetti recenti (Recenti)

Blender non chiede il salvataggio della sessione al momento della chiusura, è quindi importante salvare il progetto regolarmente e prima di chiudere l'applicativo con la scorciatoia Ctrl+S o dal menù File>Save. In caso di chiusura involontaria è possibile ripristinare il lavoro non salvato scegliendo "Recover Last Session" dalle opzioni di apertura. Alle successive aperture verranno visualizzate le voci dei precedenti progetti. Se nessuna delle suddette opzioni è di nostro gradimento possiamo chiudere la finestra facendo clic sinistro su un'area vuota.

Impostazione interfaccia[modifica]

Blender dispone di varie interfacce predefinite adatte a scopi diversi, scegliamo quindi dal menù a tendina "Choose Screen layout"

BlenderVSE2.png

la voce "Video Editing", ci troveremo così un ambiente adatto per il montaggio video.

BlenderVSE3.png

Il mio consiglio a questo punto è di fare clic sul segno + in "Choose Screen Layout" per generare una copia personalizzata dell'interfaccia, rinominarla a piacimento e apportare qualche piccola modifica:

  • creare una nuova finestra alla destra dell'anteprima video (leggere la guida "Creare nuove finestre")
  • cliccare sul menù dell'header e scegliere Properties, mentre in quella a sinistra del Preview Viewer, File Browser.

Per configurare al meglio il File Browser leggere la guida "Configurare il File Browser".

BlenderVSE4.png

Premere Ctrl+U per salvare la configurazione (vedere Configurazioni e Startup File per una breve descrizione)

Configurazioni e Startup File[modifica]

Alcune configurazioni facoltative ma consigliabili:

  • da File>User Preferences...>Input nel campo di ricerca scrivere Play quindi sostituire la scorciatoia da tastiera Alt+A con Spacebar (barra spaziatrice) per avviare/fermare l'anteprima con la barra spaziatrice
  • da File>User Preferences...>System>General modificare il campo DPI a piacimento, particolarmente utile nei portatili con schermo piccolo
  • da File>User Preferences...>System>General>Sequencer/Clip Editor modificare il valore *Memory Cache Limit in funzione della dimensione della ram disponibile nel pc, maggiore è il valore impostato più fluido sarà il VSE.
BlenderVSE5.png

Per salvare le modifiche cliccare su Save User Settings o Ctrl+U.

p.s. se proprio non potete resistere con il settaggio in lingua inglese è possibile impostare tutto in lingua italiana da: File>User Preferences...>System spuntare la voce International Fonts quindi scegliere Italiano tra le lingue disponibili e premere i tre pulsanti dell'opzione Traslate: Interface, Tooltips e New Data per tradurre tutto. Il lato negativo è la difficoltà poi nel seguire i tutorial in internet.

Per quanto riguarda il settaggio all'interno dell'interfaccia consiglio le seguenti modifiche: ­

  • nella scheda Render della Properties Window modificare il campo Display da Image Editor a KeepUI, questo farà in modo che non venga aperta una nuova finestra durante la fase di rendering.
  • nella scheda Output della Properties Window modificare il percorso di salvataggio del file renderizzato da /tmp ad una cartella di nostra scelta. E' importante considerare lo spazio su tale destinazione per non incappare in un riempimento del disco con relativo blocco del sistema operativo nel caso di rendering di grosse dimensioni e medesima destinazione.
  • nella scheda Output della Properties Window modificare il formato di esportazione da PNG a MPEG , cliccare su RGB ­nella scheda Encoding della Properties Window modificare il campo Format in H.264 e Audio Codec in AAC
  • ­dal menù View della Timeline spuntare la voce Show Second (per visualizzare il tempo in secondi e non in frames)
  • dal menù Playback la voce AVsync (per forzare la sincronia audio/video durante la riproduzione) e Frame Dropping (forza il dropping dei frame video preferendo il rispetto del frame rate) Per salvare le modifiche cliccare su Save User Settings o Ctrl+U

Scorciatoie da tastiera (Shortcut)[modifica]

Dopo aver configurato l'interfaccia grafica e le impostazioni basilari è necessario conoscere almeno alcuni degli shortcut più usati per potersi muovere nel programma: Nella finestra Sequencer del Video Sequencer Editor: ­

  • Shift+A per aggiungere una clip
  • Dopo aver selezionato la clip con il tasto destro premere Del (canc) per cancellarla
  • Alt+A (barra spaziatrice se si è seguita la guida "Configurazioni e Startup File") per avviare/fermare l'anteprima
  • Rotella del mouse per Zoom in/Zoom out
  • premere e tenere premuta la Rotella del Mouse e trascinare per spostarsi all'interno del progetto (Pan)
  • Ctrl+Rotella del mouse; se si trascina orizzontalmente Zoom+/Zoom- ­ nella linea temporale
  • Ctrl+Rotella del mouse; se si trascina verticalmente Zoom+/Zoom- ­ della dimensione di visualizzazione delle clip
  • ­Premere il tasto I per aggiungere un keyframe quando il puntatore del mouse è sopra un campo variabile (slider)
  • Freccia Su per saltare al keyframe successivo
  • ­Freccia Giù per saltare al keyframe precedente
  • ­Premere i tasti Alt+I per cancellare un keyframe quando il puntatore del mouse è sopra il campo variabile relativo ed il cursore della Timeline sul keyframe da cancellare (trovarli premendo Freccia Su o Freccia Giù)
  • ­Freccia Destra per saltare al frame successivo
  • ­Freccia Sinistra per saltare al frame precedente
  • ­Shift+Freccia Desta per portare il cursore alla fine del progetto
  • ­Shift+Freccia Sinistra per portare il cursore all'inizio del progetto
  • ­Page Su per spostare il cursore verso destra al prossimo riferimento clip (inizio o fine)
  • ­Page Giù per spostare il cursore verso sinistra al precedente riferimento clip (inizio o fine)
  • ­Home per visualizzare l'intero progetto (nei portatili il tasto è visualizzato con una freccia che punta in alto a sinistra)
  • ­Alt+Freccia Su o Giù per mettere a tutto schermo la finestra sulla quale risiede il puntatore del mouse
  • ­Per allineare l'inizio di una clip al cursore del Sequencer fare clip destro sulla clip quindi premere Shift+S
  • ­Per modificare la lunghezza dall'inizio o dalla fine di una clip (se possibile) al cursore del Sequencer fare clip destro sulla freccia posta all'estremità della clip quindi premere Shift+S

Apertura progetto[modifica]

Per generare un nuovo progetto in Blender clicchiamo su un'area vuota (non scegliere nessuna opzione) alla comparsa della finestra di benvenuto

BlenderVSE1.png

Se si sono seguite le istruzioni riportate nei paragrafi precedenti dovremmo essere accolti dall'interfaccia personalizzata che avevamo salvato con lo shortcut Ctrl+U .

La prima cosa da fare è quella di salvare il progetto con Ctrl+S oppure da File>Save.... e dare un nome opportuno. Di default nei sistemi Gnu/Linux il file verrà salvato nella propria home, il mio consiglio sarebbe quello di creare una cartella e nominarla con un nome adeguato e riconoscibile al cui interno verranno create altre directory contenenti files di vario tipo. In tale cartella salvare il file del progetto.

Una volta terminato il lavoro sarà semplice archiviare la directory (leggere il capitolo Generare un' archivio compresso di backup). Lo schema consigliato potrebbe essere di questo tipo:

BlenderVSE7.png

Aggiungere clip[modifica]

Per aggiungere clip (audio, video e immagini) premiamo Shift+A (il puntatore del mouse deve risiedere all'interno della finestra Sequencer) o dal menù del Sequencer Add e scegliamo Movie, Image o Sound per accedere al File Browser. Una volta identificato cliccare su Add xxxx Strip.

Prima di aggiungere la clip è consigliabile posizionare il cursore della Timeline nel punto preciso di ingresso.

Le prime operazioni da effettuare risultano il corretto posizionamento della clip (leggere "Posizionamento clip") e l'analisi relativa ai parametri fps e risoluzione video (leggere "Proprietà clip").

Posizionamento clip[modifica]

Possiamo spostare le clip inserite selezionandole con il tasto destro del mouse quindi premendo G (Grab), la clip ora sarà vincolata al puntatore e sarà possibile spostarla lungo l'asse orizzontale (temporale) e verticale (numero traccia o canale). La stessa operazione la possiamo eseguire, una volta selezionata la clip con il tasto destro, tenendolo premuto e trascinando. Per confermare la nuova posizione premere il tasto sinistro.

Per vincolare lo spostamento al solo asse orizzontale o verticale selezionare la clip (tasto destro), premere G quindi X (orizzontale) o Y (verticale).

Un' altro metodo consiste nel far comparire la Properties Windows premendo il tasto N con il puntatore del mouse nella finestra Sequencer e modificando i valori dei campi Start Frame: (posizione di ingresso clip) e Lenght: (durata o lunghezza) per l'asse temporale ed il valore Channel: per spostare la clip su una traccia superiore o inferiore. In entrambi i casi si rende necessario avere precedentemente selezionato la clip da editare con il tasto destro.

Le clip sono fornite di due maniglie poste una nel margine destro e una in quello sinistro (riconoscibili da una freccia) che se selezionate (tasto destro) consentono un accorciamento della durata (trascinare verso l'interno) o un allungamento (trascinare verso l'esterno). Nel caso di clip audio l'allungamento non è consentito, allungando invece una clip video si otterrà l'effetto di visualizzare un'immagine statica dell'ultimo frame.

Nessun problema invece per clip immagine.

Proprietà clip[modifica]

E' necessario controllare le proprietà delle clip video inserite in un progetto relativamente al freme rate (fps, frame rate per second) e alla sua dimensione (risoluzione video). Blender, a differenza dei normali editor video, non effettua nessun aggiustamento relativo al fps, si rende quindi necessario effettuare la corretta impostazione di tale parametro manualmente. Nella seguente ipotesi supponiamo di avere un file video da editare con queste caratteristiche (le possiamo recuperare mandandolo in play su VLC e premendo Ctrl+J):

fps 25

risoluzione 1920 x 1080

Per settare correttamente la dimensione del nostro progetto possiamo modificare manualmente i valori nel campo Resolution presenti nella Properties Windows oppure automaticamente dal menù Strip>Set Render Size della finestra del Sequencer all'esatta dimensione della clip. Nel caso fosse nostra intenzione realizzare un progetto di dimensioni superiori (upscaling) o inferiori (downscaling) procedere solo manualmente sui parametri di cui sopra facendo attenzione al corretto rapporto larghezza/altezza della clip. Per non sfalsare tale rapporto è necessario spuntare l'opzione Image Offset nella Properties Windows della finestra Sequencer.

Nel caso di un fps di progetto diverso da quello presente nella clip si noterà la mancanza di sincronia audio/video e una lunghezza diversa tra la clip audio e video. Nei casi di editing con clip video di fps diversi leggere "Clip con fps diversi".

Durata del progetto da renderizzare[modifica]

Di default Blender imposta la dimensione in frame del progetto a 250, arrivato a tale frame la riproduzione riprende da capo. Se volessimo renderizzare il progetto il frame 250 sarebbe l'ultimo elaborato. Abbiamo quindi la necessità di allungare la durata del progetto per poter vedere l'anteprima del nostro lavoro. Ci sono principalmente due modi:

modificando il campo End Frame: nella scheda Dimension della Properies Windows ad un valore pari a:

fps x 60 x minuti

Se vogliamo che il nostro progetto duri 10 minuti esatti ed il frame rate è 25

impostiamo:

25 x 60 x 10 = 15000

Se non conosciamo la durata precisa portiamo il cursore del Sequencer in un punto a piacere, spostiamo il puntatore del mouse nella finestra Timeline e premiamo E (end).

Terminato il lavoro posizioneremo con precisione tale punto. Con lo stesso procedimento possiamo posizionare anche l'inizio del progetto; posizioniamo quindi il cursore del Sequencer nel punto desiderato, spostiamo il cursore del mouse nella finestra Timeline e premiamo S (start). Ora il nostro progetto inizierà da quel punto.

Se abbiamo necessità di riprodurre per un breve periodo una limitata zona del Sequencer possiamo premere P con il cursore del mouse nel Sequencer, trascinare creando una finestra di selezione e rilasciare il tasto sinistro. Per ripristinare la selezione alla situazione impostata nella Properties Windows premere Alt+P.

Taglio clip[modifica]

Ci sono due modi per tagliare le clip, il primo consiste nel posizionare il cursore del Sequencer nella zona interessata, selezionare la clip quindi premere K (knife, taglio) effettuando così un Cut (Soft) at Frame ovvero un taglio ripristinabile agendo sulle maniglie della clip. Il secondo di differisce dall'usare Shift+K Cut (hard) at Frame, la lunghezza in questo caso non è ripristinabile.

Applicare una dissolvenza dal/al nero[modifica]

Per applicare una dissolvenza dal nero ad una traccia video dobbiamo per prima cosa posizionare il cursore del Sequencer nel punto esatto di inizio, aggiungere una clip colore (nero) con Shift+A>Effect Strip...>Color, selezionare prima la clip color e poi, tenendo premuto il tasto Shift, la clip video ed aggiungere una transizione con Shift+A>Effect Strip...>Cross

La stessa procedura è valida per applicare una dissolvenza al nero, dobbiamo però avere cura di selezionare prima la clip video, poi quella colore ed applicare una transizione di tipo Cross.

Da notare che per modificare la durata di tale transizione è sufficiente agire sulla durata della clip colore modificandone i valori o dalla Properties Windows o trascinandone le maniglie.

BlenderVSE9.png

Possiamo ottenere lo stesso risultato inserendo la clip colore prima della clip video (dissolvenza dal nero) e dopo (dissolvenza al nero) lasciando una spazio tra le due. Rimane invariata la regola di selezionare prima la clip di entrata e poi quella di uscita per non ottenere un effetto indesiderato. In questo caso la durata della transizione dipende da quanto spazio lasciamo tra le clip.

BlenderVSE10.png

Dissolvenze tra clip[modifica]

Come visto nel paragrafo precedente possiamo dissolvere clip di ogni tipo con lo stesso procedimento. Oltre alla dissolvenza di tipo Cross possiamo usare quella di tipo Wipe. Modificandone le proprietà nella Properties Windows possiamo scegliere, nella scheda Effect Strip>Transition Type tra Clock, Iris, Double o Single . In Direction cliccando su In o Out invertiamo la clip di entrata. Blur Width: consente di scegliere la quantirà di sfumatura da applicare all'effetto mentre Angle: consente di ruotare la linea di transizione a piacere.

Testo in sovraimpressione[modifica]

Possiamo aggiungere del testo in sovraimpressione con Shift+A>Effect Strip.... Text modifichiamo il campo Text della scheda Effect Strip inserendo tutto il testo, modifichiamo il valore di Size, Color, Location ecc. a piacimento.

In alternativa possiamo realizzare del testo con Gimp o Inkscape esportandolo in formato png e lasciando lo sfondo con canale alfa per la trasparenza.

Un'ulteriore alternativa potrebbe essere quella di creare in Blender del testo 3D ed aggiungerlo nel Sequencer con Shift+A >Scene...>Nome Scene.

Proxy Render Size[modifica]

Se l'anteprima del video da montare non dovesse essere sufficientemente fluida è possibile creare una clip proxy con qualità variabile (25%, 50%, 75%, 100%) per migliorare nettamente le prestazioni del pc. Possiamo realizzarla selezionando la clip da convertire, spuntando Proxy/Timecode nella Properties Windows e cliccando su Set Selected Strip Proxies.

BlenderVSE11.png

Le opzioni presentate sono:

  • Proxy Storage: Strip per convertire la sola clip o Project convertendo tutto il progetto
  • Proxy Custom Directory per impostare una directory a piacere dove salvare il file
  • Proxy Custom File per dare un nome diverso dal predefinito
  • 25%, 50%, 75%, 100% la percentuale relativa alla qualità del file, 25% sarà più fluido di 75%
  • Quality un ulteriore possibilità di alleggerire la proxy

Fatte le nostre scelte possiamo cliccare su Rebuild Proxy and Timecode Indices (presente anche nel menù Strip).

Non resta che aspettare la conclusione della conversione, il tempo dipende dalle risorse del pc e dalla lunghezza del video.

BlenderVSE12.png

Conclusa la conversione portiamoci nella scheda View Setting della Properties Windows del Viewer , espandiamo il menù Proxy Render Size e scegliamo la qualità alla quale abbiamo convertito. Mandando in play noteremo un netto miglioramento sulla fluidità di riproduzione e una peggiore qualità di visualizzazione dell'anteprima.

BlenderVSE14.png

Selezione multipla clip[modifica]

Abbiamo tre modi per selezionare più clip all'interno della finestra Sequencer:

  • taso A (all), seleziona tutte le clip presenti, ripremuto deseleziona tutto
  • Shift+tasto destro per selezionare più clip
  • tasto B quindi fare una finestra di selezione premendo e trascinando il tasto sinistro del mouse

Allineare clip[modifica]

Per allineare due clip nello stesso canale trascinare una clip con il tasto destro, farla sormontare (il suo bordo diventa rosso) quindi confermare la posizione con il clic sinistro. Le clip saranno perfettamente allineate.

Clip con fps diversi[modifica]

Se le clip che importiamo nel nostro progetto hanno fps diversi abbiamo due possibilità: la prima consiste nella conversione ad un unico fps di tutti i files video, la seconda è quella di applicare un effetto con la seguente procedura alle clip con fps diverso da quello impostato nel progetto:

fps del progetto (es.) 25

clip video con fps 24

premere Shift+A>Effect Strip...>Speed Control (viene aggiunta una striscia magenta), selezionare l'effetto Speed Control e nel campo Multiplay Speed cambiare dal valore 1 a 0.96 con la seguente regola:

fps MultiplaySpeed = fps sorgente / fps progetto (24/25=0.96)

Con la stessa regola supponiamo di avere una clip a 15 fps:

premere Shift+A>Effect Strip...>Speed Control (viene aggiunta una striscia magenta), selezionare l'effetto Speed Control e nel campo Multiplay Speed cambiare dal valore 1 a 0.6 con la precedente regola:

fps MultiplaySpeed = fps sorgente / fps progetto (15/25=0.6)

Eseguire la procedura per tutte le clip video con fps diverso da quello impostato nel progetto.

Generare un archivio compresso di backup[modifica]

Per comprimere la directory contenente i files del progetto dare da terminale il comando:

tar cfvz NomeCartella.`date +%Y%m%d`.tgz /PercorsoCartellaDaComprimere

ad esempio:

tar cfvz VideoLugvi.`date +%Y%m%d`.tgz VideoLugvi

così verrà aggiunta anche la data di salvataggio. Per comprimere da interfaccia grafica fare clic destro sulla cartella da comprimere e scegliere l'opzione Comprimi.... (Compress...), le voci possono variare in funzione del file browser usato.