VLC media player

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search

Guida pratica all'uso di VLC Media Player con videoguide

Premessa[modifica]

Vlc.png

Schermata di VLC in Fedora 24 (potrebbe differire su sistema operativo diverso)

Media[modifica]

Apri file...[modifica]

L'operazione più semplice e la funzionalità principale di VLC è quella relativa alla lettura di file multimediali, ecco un semplice esempio:

1-Dal menù Media scegliamo Apri file... oppure Ctrl+O


Apri file multipli...[modifica]

Per riprodurre in sequenza una serie di file

1-Dal menù Media scegliamo Apri file multipli... oppure Ctrl+Shift+O

2-Scegliere Add quindi fare clic sinistro con il tasto Shift premuto per selezionare più file e premere Open

3-Cliccare su Riproduci


Apri cartella...[modifica]

Per riprodurre tutti i file presenti in una cartella

1-Dal menù Media scegliere Apri cartella...

2-Scegliere la cartella con i file da riprodurre quindi cliccare su Choose

3-La riproduzione avverrà automaticamente

Apri disco...[modifica]

Disco - Estrarre una traccia audio da Compact Disc (CD-Audio)[modifica]

1-Dal menù Media selezionare Apri disco... o Ctrl+D

2-Selezionare il bottone Cd audio quindi in Traccia impostare il numero della traccia da estrarre

3-Premere Converti/Salva...

4-In Profilo scegliere il codec (FLAC,MP3 ecc.) e in File di destinazione la directory ed il nome con cui salvare

5-Premere Avvia

Apri flusso di rete...[modifica]

Rete - Riprodurre video da YouTube in streaming[modifica]

1-Dal menù Media scegliere Apri flusso di rete... oppure Ctrl+N

2-Nel campo Please enter a network URL: inserire il link al video preventivamente copiato da YouTube

3-Cliccare su Riproduci

Apri periferica di acquisizione...[modifica]

Dispositivo di acquisiszione - Registrare il desktop[modifica]

1-Dal menù Media selezionare Apri periferica di acquisizione... o Ctrl+C

2-Nel menù a tendina Capture mode scegliere Desktop

3-Nel campo Velocità fotogrammi desiderata per l'acquisizione. impostiamo un valore (consigliato da 15 a 25)

4-Espandendo il menù a tendina Riproduci e scegliamo Converti

5-Nel menù a tendina Profilo scegliamo il codec di esportazione (consigliato MP4, Webm oppure OGG)

6-Nel campo File di destinazione scegliamo una posizione ed un nome

Apri posizione degli appunti[modifica]

Scegliendo dal menù Media la voce Apri posizione degli appunti possiamo accedere alla finestra Apri URL

Apri URL VLC.png

In questo campo possiamo inserire un URL preso ad esempio da YouTube oppure il percorso di un file multimediale presente nel nostro computer. Nel caso avessimo precedentemente copiato l'URL o il percorso negli appunti (Ctrl+C oppure tasto destro> Copia) ritroveremo il path già incollato in questo campo, sarà quindi sufficiente premere Riproduci per avviare la riproduzione.

Apri media recenti[modifica]

Lasciando il puntatore sulla voce Apri media recenti del menù Media visualizziamo una lista di file usati recentemente che ci consente, se selezionati, la riapertura. Le ultime due voci del menù consentono rispettivamente di:

  • Svuota svuotare la lista dei file aperti recentemente
  • Save to Playlist salvare la lista dei file visualizzati in un file con estensione xspf dal nome personalizzabile e successivamente richiamabile.

Salva scaletta su file...[modifica]

Converti/Salva...[modifica]

Una funzione molto comoda di VLC che troviamo dal menù Media>Converti/Salva... consente di convertire file audio e/o video in vari profili come MP4, Webm, TS, OGG, Mp3, FLAC, CD, DivX, iPoad, Android, YouTube con innumerevoli codifiche video come MPEG-1, MPEG-2, MPEG-4, DivX 1, DivX 2, DivX 3, H263, H264, H265, VP8, WMV1, WMV2, M-JPEG, Theora, Dirac e codifiche audio MPEG Audio, MP3, MPEG 4 Audio (AAC), A53-AC3, Vorbis, Flac, Opus, Speex, WAV, WMA2 con la possibilità di personalizzare il bitrate e il frame rate per il video, il bitrate, il numero di canali e il Sample Rate per l'audio. Se sono presenti sottotitoli si possono inserire con le codifiche DVB o T.140. La procedura per converte un file è intuitiva; dal menù Media>Converti/Salva... accediamo alla finestra Apri media

Apri media VLC.png

premendo il bottone Add... e navigando nelle directory scegliamo il file da convertire e confermiamo con Open... quindi premiamo Converti/Salva...

Finestra Media>Converti/Salva....>Converti in VLC

nel campo Sorgente viene visualizzato il percorso del file da convertire mentre in Profilo scegliamo il formato con il quale vogliamo realizzare la conversione. Non resta che dare un nome nel campo File di destinazione (non serve l'estensione come OGG, MP4 ecc.) e una directory di destinazione cliccando sul bottone Sfoglia. Per avviare la conversione premiamo Avvia.

Trasmetti..[modifica]

Esci alla fine della scaletta[modifica]

Esci[modifica]

Scegliendo Esci dal menù Media comandiamo la chiusura immediata dell'applicazione. La scorciatoia da tastiera per ottenere il medesimo risultato è Ctrl+Q.

Riproduzione[modifica]

Audio[modifica]

Traccia audio[modifica]

Dal menù Audio > Traccia audio possiamo sceglierne una di quelle visualizzate, riproducendo ad esempio un DVD potremmo avere selezionabili le tracce in lingua diversa (inglese, francese ecc.)

Traccia audio.png

Dispositivo audio[modifica]

Dal menù Audio > Dispositivo audio possiamo scegliere una tra le schede visualizzate (nell'esempio sotto sarebbe possibile indirizzare il segnale audio al controller HDMI)

Dispositivo audio VLC.png

Modalità stereo[modifica]

Dal menù Audio > Modalità stereo possiamo decidere se usare rispettivamente la traccia:

  • Stereo
  • Sinistra
  • Destra
  • Stereo inverso
Modalità stereo.png

Visualizzazioni[modifica]

Scegliendo dal menù Audio la voce Visualizzazioni possiamo decidere il modo in cui VLC visualizza, da un punto di vista grafico, l' uscita audio del file riprodotto. Le opzioni sono:

  • Disabilita
  • Spettrometro
  • Oscilloscopio
  • Spettro
  • VU meter
  • ProjectM
  • 3D spectrum

Nel video seguente abbiamo un esempio delle prime cinque opzioni dopo aver riprodotto un file audio:

Video[modifica]

Sottotitolo[modifica]

Tools[modifica]

Effetti e filtri[modifica]

Effetti audio[modifica]

Equalizzatore[modifica]
Compressore[modifica]

La compressione della gamma dinamica è quale particolare tipo di manipolazione dell'audio che permette di avere una sorta di "controllo automatico" del volume. In sostanza si tratta di un effetto che prende il vostro flusso audio e lo tratta "regolando" il volume in uscita in maniera non lineare. Immaginate che il valore del volume in ingresso e quello di uscita siano rappresentati rispettivamente sull'asse x e sull'asse y di un piano cartesiano. In condizioni normali questo grafico si potrebbe visualizzare come una retta inclinata a 45° rispetto l'asse x.

grafico di un effetto compressore spento

In condizioni di filtro compressore attivo, il grafico relativa è simile a questo:

grafico di un effetto compressore acceso

In VLC è presente un'intera sezione di filtri audio. Il compressore è attivabile da "strumenti", "regolazioni ed effetti", selezionare "Effetti Audio" e poi "Compressore".

schermata di selezione parametri per la compressione

Ci sono molti parametri che influenzano la maniera e la risposta del filtro di compressione. Rimando in fono alla presente voce alla pagina di wikipedia dove sono spiegati uno ad uno.

Per attivare l'effetto basta spuntare su "abilita".

per maggiori informazioni sulla compressione del livello audio, da un punto di vista teorico su può visitare l'apposita voce di wikipedia: [del livello audio]

Spazializzatore[modifica]

Effetti video[modifica]

Essential[modifica]
Ritaglio[modifica]
Colors[modifica]
Geometria[modifica]
Sovraimpressione[modifica]

Aggiungi logo.

Con VLC è possibile indicare un'immagine (PNG, con canale di trasparenza) da utilizzare come "logo" in sovrimpressione. E' possibile farlo attraverso lo strumento Aggiungi logo attivabile nel menù Strumenti, selezionando il gruppo Effetti video e la scheda Sovrimpressione. Da qui è possibile spuntare Aggiungi logo e selezionare nell'apposito campo il file PNG (o anche JPG) da usare come sovraimpressione. Dalla stessa paletta è possibile indicare la posizione dell'immagine e la relativa trasparenza. Da notare che la posizione dell'immagine (parametri alto e sinistra) sono relative alla posizione scelta nelle preferenze ( Strumenti - Preferenze - Tutto - Video - Sottotitoli /OSD - Sovrapposizione logo - Posizione del logo ). Se scegliete "centro" in questo campo, gli spostamenti "alto" e "sinistra" non avranno alcun effetto sulla posizione dell'immagine di sovraimpressione, in quanto è prioritaria la scelta in Preferenze.

La sovraimpressione rimane impostata anche quando chiuderete VLC, per non visualizzare il logo è sufficiente (de)spuntare l'opzione in Strumenti - Effetti e filtri - Effetti video - Aggiungi logo.

Avanzate[modifica]

Sincronizzazione[modifica]

Audio/Video[modifica]
Sottotitoli/Video[modifica]

Controlli v4l2[modifica]

Sincronizzazione traccia[modifica]

Informazioni media[modifica]

Informazioni codificatore[modifica]

Personalizza interfaccia...[modifica]

Preferenze[modifica]

Sottotitoli / OSD[modifica]

Messaggi in sovraimpressione[modifica]

Non visualizzare il titolo del video ad inizio riproduzione

Per evitare di visualizzare il titolo del video ad inizio riproduzione selezionare Preferenze o Ctrl+P dal menù Tools, spostarsi nella scheda Sottotitoli/OSD . La schermata conterrà due opzioni in Messaggi in sovrimpressione (OSD) . La prima Abilita On Screen Display (OSD) , la seconda Mostra titolo all'avvio del video . E' inoltre possibile scegliere la posizione di visualizzazione del titolo del video dal menu a tendina Posizione . Togliendo la spunta solo sulla seconda opzione disabilitiamo la visualizzazione del titolo all'avvio del video. La prima opzione, invece, permette di visualizzare anche la sovraimpressione dei comandi, tipo play/pausa/avanti veloce/volume, che appaiono in sovraimpressione durante la riproduzione dei video.

Visualizza[modifica]

Scaletta[modifica]

Selezionando Scaletta dal menù Visualizza accediamo ad una serie di opzioni, la prima è Playlist che ci consente di creare una lista di file preferiti da riprodurre. Per aggiungere un file alla lista basta, da qualunque punto di VLC, fare clic destro e scegliere Aggiungi alla scaletta oppure trascinarlo con il drag-and-drop. Per rimuoverlo fare clic destro e Rimuovi selezionati. Da Playlist possiamo aggiungere file anche facendo clic destro e scegliendo le opzioni Aggiungi file..., Aggiungi cartella... e Opzioni d'apertura avanzate....

Raccolta multimediale funziona come 'magazzino multimediale personale' all'interno del quale possiamo inserire tutti i nostri file per un rapido accesso. Possiamo aggiungere file facendo clic destro e scegliendo le opzioni Aggiungi file..., Aggiungi cartella... e Opzioni d'apertura avanzate.... E' inoltre possibile creare una cartella nella quale inserire file scegliendo Crea cartella....

La sostanziale differenza tra Scaletta e Raccolta multimediale sta nel fatto che alla chiusura di VLC la playlist creata in Scaletta verrà cancellata mentre Raccolta multimediale ricorderà le tue preferenze.


Aiuto[modifica]

Tips and tricks[modifica]

VLC non si avvia a seguito di modifiche (skins ecc.)[modifica]

Per ripristinare le impostazioni base di VLC in GNU/Linux a seguito di un malfunzionamento:

1-Chiudere VLC

2-Aprire il file manager e cancellare i file di configurazione presenti in /home/nome_utente/.config/vlc/vlcrc e /home/nome_utente/.config/vlc/vlc.qt-interface.conf

3-Per cancellare eventuali skins installate e non funzionanti eliminare i file .vlt presenti nella directory /home/nome_utente/.local/share/vlc/skins2


Semplici shortcut[modifica]

Possiamo regolare il volume di un file in riproduzione agendo sulla rotella del mouse. Possiamo fermare la riproduzione di un file premendo la barra spaziatrice; allo stesso modo possiamo far riprendere la riproduzione

Questa pagina è uno stub Questo libro è solo un abbozzo. Contribuisci a migliorarlo secondo le convenzioni di Wikibooks

Elenco delle principali scorciatoie da tastiera in VLC:


Tasto speciale Azione
f Schermo intero
Esc Esci dalla modalità a schermo intero
Space... Riproduci/Pausa
+ Più veloce
- Più lento
= Velocità normale
] Più veloce (fine)
[ Più lento (fine)
n Successivo
p Precedente
s Interrompi
t Posizione
Shift+Left Salto molto corto all'indietro
Shift+Right Salto molto corto in avanti
Alt+Left Salto corto all'indietro
Alt+Right Salto corto in avanti
Ctrl+Left Salto medio all'indietro
Ctrl+Right Salto medio in avanti
Ctrl+Alt+Left Salto lungo all'indietro
Ctrl+Alt+Right Salto lungo in avanti
e Fotogramma successivo
Shift+m Vai al menu del DVD
Shift+o Seleziona titolo precedente del DVD
Shift+b Seleziona titolo successivo del DVD
Shift+p Seleziona capitolo precedente del DVD
Shift+n Seleziona capitolo successivo del DVD
Ctrl+q Esci
Ctrl+Up Aumenta il volume
Ctrl+Down Riduci il volume
m Silenzio
o Ridimensionamento automatico
Alt+o Aumenta il fattore di scala
Alt+Shift+o Riduci il fattore di scala
Shift+s Cattura schermata video
Shift+r Registra
z Zoom
Shift+z Riduci zoom
Alt+1 1:4 Quarto
Alt+2 1:2 Metà
Alt+3 1:1 Originale