Blender CAM/Le schede di Blender CAM

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
Indice del libro

Le schede di Blender CAM[modifica]

CAM Operations[modifica]

Bc012.png

La scheda CAM Operations consente di inizializzare un nuovo progetto cam premendo il tasto + presente sulla desra della finestra. Il tasto meno cancella il progetto selezionato nella scheda. Il tasto tra il + e il crea una copia del progetto selezionato nella scheda.

Operation presets[modifica]

Nella parte inferiore è presente un menù a tendina Operation presets che se espanso consente di selezionare numerosi preset definiti dallo sviluppatore o salvati dall’utente. Per creare un nuovo preset premere il tasto + posto a fianco. Il tasto cancella un preset.

Calculate path[modifica]

Il tasto Calculate path consente di calcolare il percorso utensile: se la checkbox Auto export posta poco sotto è selezionata il file verrà scritto (sovrascritto se esiste già con quel nome) nel disco, in caso contrario il file verrà scritto su disco solo quando sarà premuto il tasto Export gcode.

Calculate path in background[modifica]

consente di avviare il calcolo del percorso ma l’operazione non è bloccante (utile per calcoli impegnativi) consentendo all’utente di proseguire con la propria attività.

Simulate this operation[modifica]

genera una skin attorno alla lavorazione effettuata.

Operation name e File name[modifica]

consente di personalizzare il nome del progetto mentre File name di personalizzare il nome del file gcode esportato.

Source of data[modifica]

Espandendo il menù a tendina Source of data si hanno tre opzioni: Object, Group of objects e Image

Object[modifica]

consente la lavorazione di un singolo oggetto, quello che appare nel campo object. Se in tale campo non è selezionato alcun oggetto il calcolo del percorso non è possibile.

Group of object[modifica]

lavora un gruppo di oggetti. Per creare un gruppo di oggetti in Bender è sufficiente selezionarli con il tasto destro tenendo premuto Shift quindi usare lo shortcut Ctrl+G per creare un gruppo. Premendo T si aprirà la Tool Shelf e nella scheda Tools sarà possibile assegnare un nome a piacimento al gruppo creato nel campo Name. Tale nome dovrà essere scelto nella scheda CAM Operations nel campo Group.

Image[modifica]

not found

Ogni operazione crea un nuovo oggetto nella finestra Outliner, da qui è possibile selezionare, cancellare, rinominare, oscurare/rendere visibile, consentire o meno la selezione, inserire o meno l’oggetto nel rendering.

Bc013.png

CAM info e warnings[modifica]

Bc015.png

CAM Operation setup[modifica]

Number of axes[modifica]

In questa scheda si possono impostare il numero di assi per la strategia (il 4° e 5° asse non sono stati ancora sviluppati).

Strategy[modifica]

Il menù a tendina Strategy consente di scegliere tra numerose strategie di lavorazione:

Profile (Cutout)[modifica]

Strategia adatta per contorniture e incisione di scritte.

Con la checkbox Use layers della scheda CAM Operation area abiitata è possibile eseguire una serie di passate a Z costante nel profilo del pezzo.

Se il valore del campo Cut della scheda CAM opration setup è impostato su Outside verrà calcolato un percorso con compensazione utensile esterna secondo il valore impostato in Cutter diameter nella scheda CAM Cutter.

valore Outline del campo Cut


Se il valore del campo Cut della scheda CAM opration setup è impostato su Inside verrà calcolato un percorso con compensazione utensile interna secondo il valore impostato in Cutter diameter nella scheda CAM Cutter.

valore Insile campo Cut


Se il valore del campo Cut della scheda CAM opration setup è impostato su On line verrà calcolato un percorso senza alcuna compensazione indipendentemente dal valore impostato in Cutter diameter nella scheda CAM Cutter.

valore On line campo Cut


Impostare Climb/Down milling nel campo Movement type della scheda CAM Movement per ottenere una lavorazione in concordanza.

Impostare Conventional/Up milling nel campo Movement type della scheda CAM Movement per ottenere una lavorazione in discordanza.

Questa strategia supporta la funzione Ramp in - EXPERIMENTAL e Ramp out - EXPERIMENTAL abilitabili nella scheda CAM Movement

funzione Ramp in- EXPERIMENTAL abilitata


Esempio di incisione di una scritta usando la strategia Profile(Cutout) con valore On line del campo Cut della scheda CAM Operation setup e Use layers disabilitato.

Blendercam069.png


Poket[modifica]
Drill[modifica]
Parallel[modifica]
Cross[modifica]
Block[modifica]
Spiral[modifica]
Circles[modifica]
Outline Fill[modifica]
Carve[modifica]
Waterline-EXPERIMENTAL[modifica]
Curve to path-EXPERIMENTAL[modifica]
Pencil-EXPERIMENTAL[modifica]
Crazy path-EXPERIMENTAL[modifica]
Medial axix-EXPERIMENTAL[modifica]
Projected curve-EXPERIMENTAL[modifica]

In funzione della strategia scelta può apparire un ulteriore menù a tendina sottostante che consente ad esempio di scegliere il punto di partenza, la direzione ecc. e delle checkbox per abilitare/disabilitare specifici parametri relativi alla strategia.

Distance between toolpaths[modifica]

Lo slider Distance between toolpaths permette di impostare la misure di spostamento tra le passate

Distance along toolpaths[modifica]

Lo slider Distance along toolpaths permette di impostare la tolleranza di lavorazione

Angle of paths[modifica]

In certe strategie (Parallel, Block etc.) consente di inclinare l'angolo di lavorazione

Bc050.png
Bc051.png
Bc052.png
Inverse milling[modifica]

La checkbox Inverse milling se selezionata inverte la lavorazione con una specchiatura negli assi X e Y.

Senza Inverse milling
Skin[modifica]

Lo slider Skin permette di impostare un valore di sovrametallo alla lavorazione (adatto principalmente alla sgrossatura).

Cut[modifica]

Nel campo Cut che appare se usiamo la strategia Profile (Cutout), possiamo impostare il percorso in centro al profilo con Online, all'esterno del profilo con Outside (la misura dipende dal raggio utensile impostato in CAM Cutter) e Inside (la misura dipende dal raggio utensile impostato in CAM Cutter)

Outlines count 'EXPERIMENTAL'[modifica]

Genera dei percorsi paralleli (Offset)

Dont merge outlines when cutting[modifica]
Use bridges[modifica]

Funziona con la strategia Profile(Cutout), una volta selezionata la checkbox Use bridges appariranno due slider che andranno a controllare:

whidth of bridges[modifica]

la larghezza dell'oggetto bridge

heght of bridges[modifica]

l'altezzaezza dell'oggetto bridge

e un campo Bridges Group che consente di selezionare un gruppo di Bridges che può anche essere generato premendo il tasto Autogenerare bridges.

Esempio d'uso: inserire nella scena di Blender una curva con Shift+A>Curve>Circle, scegliere la strategia Prifile(Cutout), nel campo Cut impostare On line (a altro) e premere Calculate path da CAM operations.

Bc054.png

abilitare ora la checkbox Use bridges e premere il tasto Autogenerate bridges, nell'albero Outliner appariranno nuovi elementi nominati bridge, bridge_oo1, bridge002 ecc.. Selezioniamo nel campo Bridge Groups il gruppo appena creato bridges_Operation_1 e facciamo ricalcolare il percorso con Calculate path. Si noterà che in corrispondenza degli oggetti bridge il percorso obbligherà l'utensile ad alzarsi del valore impostato in height of bridges

Bc055.png

Gli oggetti bridge una volta selezionati nella scena di Blender si possono spostare, scalare e cancellare a piacimento.

Use array[modifica]

La funzione Use array consente di generare dei cloni del percorso a quote preimpostate; supponendo di dover lavorare dei pezzi identici bloccati nel piano della fresatrice a passi prestabiliti

funzione Use array disabilitata
funzione Use array abilitata

CAM Optimization[modifica]

CAM Operation area[modifica]

La scheda CAM Operation area ha al suo interno i parametri relativi all'area di lavoro dell'utensile.

Use Layers[modifica]

Nella scheda CAM Operation area è possibile abilitare la checkbox Use Layers che consente di eseguire una serie di passate (sgrossatura) fino ad arrivare alla superficie del pezzo con un valore impostabile dallo slider Step down

funzione Use layers disabilitata
funzione Use layers abilitata e Step down impostato ad 1mm
Ambient[modifica]

Il campo Ambient consente di decidere se l'utensile debba coprire l'intera area del blocco impostato nella scheda CAM Material size and position (quando settato su ALL) oppure effettuare la semplice contornitura del pezzo (quando settato su Around)

campo Ambient impostato su ALL
campo Ambient impostato su Around
Ambient radius[modifica]

Il valore Ambient radius determina il raggio al quale è vincolato il percorso utensile come offset del pezzo. Se impostato ad esempio a zero l'utensile non andrà con l'asse utensile oltre il profilo esterno del pezzo

valore Ambient radius impostato a zero
Operation depth start[modifica]

Lo slider Operation depth start imposta il valore dal quale l'utensile inizierà a lavorare il pezzo riferito allo zero origine dell'asse Z. Se la checkbox Depht from object è abilitata il percorso sarà calcolato fino alla profondità massima dell'oggetto selezionato (se il valore Ambient radius lo consente)

Depht from object[modifica]

Se la checkbox Depht from object è disabilitata è possibile impostare nello slider Operation depht end la quota finale massima nell'asse Z alla quale verrà calcolato il percorso riferita allo zero origine.

esempio di lavorazione da Z-10mm a Z-20mm

nell'esempio in figura il percorso verrà calcolato a partire dalla quota Z-10mm fino alla quota Z-20mm

Use limit curve[modifica]

Use limit curve consente di limitare l’area di lavoro ad una curva generata dall’utente a piacimento. Per aggiungere una curva in Blender posizionare il cursore del mouse nello spazio 3D, premere Shift+A e scegliere Curve>Bezier o Circle, scalare eventualmente la curva e posizionarla secondo esigenza. La curva Bezier è possibile allungarla premendo Tab per entrare in Edit Mode, selezionare l’ultimo nodo ed estruderlo premendo il tasto E. Se si dovesse aver necessità di chiudere la curva premere Alt+C quindi uscire dalla modalità Edit Mode con Tab.

Use limit curve disabilitato
Use limit curve abilitato

Selezionare nel campo Limit curve la curva creata in precedenza.

Cutter stay in ambient limit[modifica]

Cutter stay in ambient limit vincola l’utensile a rimanere entro i limiti del blocco impostato nella scheda CAM Material size and position

CAM Movement[modifica]

Nella scheda CAM Movement è possibile impostare la modalità concorde o discorde del movimento dell'utensile.

Nella figura seguente è raffigurato un esempio di lavorazione concorde

Blendercam070.png

Nella figura seguente è raffigurato un esempio di lavorazione discorde

Blendercam071.png

Movement type[modifica]

Nel campo Movement type possiamo scegliere tra:

Conventional/Up milling che imposta una lavorazione con movimento discorde

Climb/Down milling che imposta una lavorazione con movimento concorde

Meander/Zig zag in funzione della strategia imposta o un movimento casuale oppure una lavorazione a zig-zag

Free movement height[modifica]

Lo slider Free movement height consente di impostare una quota di svincolo sull'asse Z per i movimenti spaziali in rapido (G00). E' la quota di sicurezza per non avere collisioni con il pezzo.

Parallel step back[modifica]

Abilitando la checkbox Parallel step back verrà generata una particolare strategia di movimento come evidenziato dall'immagine seguente

Blendercam072.png

Il movimento concorde o discorde deve essere impostato in Movement type nella scheda CAM Movement


CAM Feedrate[modifica]

CAM Cutter[modifica]

Bc057.png

La scheda CAM Cutter consente di scegliere uno dei preset utensile impostato dallo sviluppatore o di creare un proprio database utensile personalizzato. Per scegliere un preset è sufficiente espandere il menù a tendina Cutter presets e selezionarne uno.

Per creare un utensile personalizzato compilare i campi Tool number, scegliere la geometria dell'utensile nel campo Cutter (tra End, Ballnose, V-carve, Sphere, Castom EXPERIMENTAL), impostare il diametro utensile in Cutter diameter, il numero di taglienti in Cutter flutes, opzionalmente una desrizione in Tool description quindi premere il tasto + nel campo Cutter Presets, dare un nome significativo nel campo Name e confermare con OK. I dati salvati saranno disponibili anche ai prossimi riavvii del programma. Per cancellare un preset basta selezionarlo dal menù a tendina Cutter presets e premere il tasto - posto a fianco.

Bc056.png

CAM Machine[modifica]

La scheda CAM Machine contiene i parametri relativi alla macchina utensile (spazio lavoro, postprocessore, velocità avanzamenti ecc.) che si possono richiamare selezionando un preset. In Blender CAM sono preconfigurati due preset, richiamabili dal menù a tendina Machine preset, Emc Test 2 e Kk1000S. Per configurare un proprio preset con i parametri corretti della nostra CNC dobbiamo compilare con i giusti valori i campi della scheda quindi premere il tasto + del campo posto a fianco il tasto Machine preset. Per cancellarne uno invece dobbiamo prima selezionarlo dal menù a tendina e successivamente premere il tasto - .

Post processor[modifica]

Il menù a tendina Post processor consente di selezionare uno dei tanti postprocessori disponibili in Blender CAM:

  • Linx Otter o
  • ShopBot MTC
  • Win-PC
  • Gravos
  • Anilam Crusader M
  • Centroid M40
  • Hafco HM-50
  • Sieg KX1
  • Heidenhain
  • grbl
  • EMC-LinuxCNC
  • Mach3
  • Iso

Cos'è il post processor (tradotto da Wikipedia, l'enciclopedia libera)

"Un Post Processor è un "driver" univoco specifico per una macchina CNC, un robot o un meccanismo; alcune macchine partono da posizioni diverse o richiedono un movimento extra tra ciascuna operazione, il post-processore funziona con il software CAM o il software di programmazione off-line per assicurarsi che l'output o il programma G-Code sia corretto per una specifica build della macchina."

Split files[modifica]

La checkbox Split files consente, se abilitata, di accedere ad uno slider per determinare il numero di operazioni prima di generare un nuovo documento g-code. Se impostato ad esempio a 1000 operazioni sarà generato un file con una decina circa di righe di codice in più oltre quel valore, questo a causa di varie intestazioni del programma che non sono considerate come 'operazioni' (evidenziate nell'immagine seguente)

Blendercam 074.png

I files generati saranno nominati come Operation_1_0.ngc, Operation_1_1.ngc, Operation_1_2.ngc ecc.

Unit System[modifica]

Il menù a tendina Unit System consente di scegliere l'unità di misura tra Metric, Imperial e None.

Metric imposta l'unità di misura metrica

Imperial imposta l'unità di misura imperiale

None imposta l'unità di misura di Blender

Questa scheda è direttamente collegata con Properties>Scene>Units di Blender

Blendercam074.png

Use position definition[modifica]

La checkbox Use position definition se abilitata consente di impostare i valori:

Start position punto di inizio del programma

MTC position punto cambio utensile (da verificare)

End position punto finale del programma (da verificare)

Work area area di lavoro della fresatrice (visibile in grigetto nella scena 3D)

Attenzione!! L'area di lavoro della macchina è uno spazio virtuale che consente all'operatore di capire se le lavorazioni escono da questi limiti. Blender CAM non opera nessuna modifica ai propri percorsi se i valori del blocco pezzo non rientrano in tali limiti (impostabili nella scheda CAM Material size and position)


se la checkbox non è abilitata

Work area area di lavoro della fresatrice (visibile in grigetto nella scena 3D)

Attenzione!! L'area di lavoro della macchina è uno spazio virtuale che consente all'operatore di capire se le lavorazioni escono da questi limiti. Blender CAM non opera nessuna modifica ai propri percorsi se i valori del blocco pezzo non rientrano in tali limiti (impostabili nella scheda CAM Material size and position)


Sono inoltre memorizzabili i valori di feedrate minimo e massimo e i giri del mandrino.

CAM Material size and position[modifica]

Estimate from model[modifica]

La checkbox Estimate from model se abilitata consente di generare un blocco di lavoro del pezzo di dimensioni identiche all'area occupata dei tre assi e con un incremento opzionale radiale impostabile dallo slider radius around model.

Se la checkbox Estimate from model non è abilitata è possibile impostare i valori del blocco di lavoro del pezzo tramite i campi

Material origin[modifica]

misura di inizio del blocco rispetto alle origini macchina negli assi X, Y e Z

Material size[modifica]

misure del blocco di lavoro del pezzo. Il punto di partenza è determinato dai valori impostati in Material origin


Attenzione!! Il percorso utensile sarà sempre vincolato alle dimensioni del blocco di lavoro impostate in Material size. L'area di lavoro macchina (scheda CAM Machine) non influisce sui limiti di percorso utensile. Non è possibile effettuare percorsi utensile sopra la quota Z zero. Anche impostando un blocco Material origin in una posizione sopra lo Z zero non verrà generato alcun percorso utensile

CAM Chains[modifica]

CAM Chains consente all'utente di collegare in un unico file g-code un numero arbitrario di percorsi utensile. Nel caso in cui la fresatrice avesse il cambio utensile è possibile specificarlo nei parametri utensile della scheda CAM Cutter e collegare percorsi con utensili di diametro e geometria differenti. Sarà il CNC che al comando T1, T2, T3 ecc. provvederà a richiamare rispettivamente l'utensile della posizione 1, 2, 3 ecc.

La procedura di concatenazione è la seguente: importare il pezzo come descritto in Prima apertura oppure in Per chi ha fretta… e far calcolare il percorso con il tasto Calculate path, verrà generato il file Operation_1. Aprire la scheda CAM Chains e premere il tasto + (Add new cam chain), nel box sottostante premere il tasto + (Add operation to chain).

Bc058.png


Portarsi ora nella scheda CAM Operations e creare una nuova operazione premendo il tasto + (Add new cam operation) e dopo aver settato tutti i parametri di lavorazione premere Calculate path. Verrà generato il file Operation_2. Premere quindi il pulsante + del secondo box della scheda CAM Chains (Add operation to chain).

Bc059.png

Ora possiamo usare i tasti con la freccia su o freccia giù posti a fianco del box inferiore per spostare in su o giù l'ordine dei percorsi come meglio preferiamo. Possiamo inoltre premere il tasto Simulate this chain per fare in modo che Blender CAM produca una skin attorno al percorso effettuato. Se siamo soddisfatti possiamo modificare a piacere i campi Chain Name per cambiare il nome nel box superiore e File name per il nome da applicare al documento che conterrà il g-code dei due (o più) percorsi collegati.

Pack curve on sheet[modifica]

Slice model to plywood sheet[modifica]

Bas relief[modifica]

Bas relief consente di generare un'immagine con estensione .exr con la quale è possibile deformare un plane in Blender ottenendo così un bassorilievo lavorabile a CAM.

La procedura per ottenere tale immagine è la seguente:

  1. Importare in Blender l'oggetto solido di cui si vuole ricreare il bassorilievo (io aggiungo nella scena Monkey premendo Shift+A>Mesh>Monkey)
  2. Aggiungere un Plane dietro l'oggetto
    Bc040.png
  3. Scegliere il motore di rendering Cycles Render
  4. Impostare una vista con la telecamera a piacimento (è possibile farlo anche con lo shortcut Ctrl+Alt+0)
    Bc041.png
  5. Selezionare Camera e nella Properties>Data>Display abilitare la checkbox Limits
  6. Selezionare Camera e nella Properties>Data>Lens impostare il valore di end in modo tale che la linea arancione della fotocamera copra solo la profondità della scena subito dopo il Plane
    Bc042.png
  7. Nella Properies>Render>Output>File Format scegliere OpenEXR, BW, abilitare la checkbox Z Buffer
  8. Nella Properies>Render>Dimensions>Resolution impostare dei valori abbastanza alti
    Bc043.png
  9. Aprire il Node Editor e selezionare Compositing e Use Nodes
  10. Aggiungere il nodo Normalize con Shift+A fino ad ottenere quanto visibile nell'esempio
    Bc046.png
  11. Da Properies>Render premere Render (Actiive Scene) oppure il tasto F12, alla fine del processo Esc per uscire
  12. Cambiare il motore di rendering in Blender CAM e nella scheda Bas Relief nel campo Image source selezionare Viewer Node, nel campo Image target inserire un nome a piacere (BasRelief) quindi premere Calculate Relief
    Bc047.png
  13. Nella propria home directory (Gnu/Linux) apparirà l'immagine BasRelief.exr

Per generare un bassorilievo da un'immagine .exr dobbiamo aggiungere un Plane alla scena (Shift+A>Mesh>Plane), premere Tab per entrare in Edit Mode e dalla Tool Shelf (tasto T) premere più vole Subdivide.

Ora da Properies>Texture premiamo New (Add new Texture), dalla scheda Image selezioniamo Open e clicchiamo su BasRelief.exr appena creata.

Bc044.png

Con il Plane selezionato premiamo Properies>Modifiers>Add Modifier>Displace, nel campo Texture (Browse Texture to be linked) scegliamo la Texture. Abbassiamo ad un valore tra 0.1 e 0.2 lo slider Strength fino ad ottenere il risultato desiderato.

Bc045.png

Per aumentare la risoluzione del bassorilievo agire sul numero di suddivisioni del Plane (dalla Tool Shelf>Subdivide con il Plane in Edit mode)