Blender CAM/Simulare il percorso con Blender CAM

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search

Possiamo simulare il percorso calcolato in Blender CAM seguendo questi semplici passaggi:

  • convertire in Curve il percorso calcolato
  • creare una mesh con la geometria dell'utensile
  • aggiungere un Constraints all'utensile
  • settare i parametri di simulazione

Convertire in Curve il percorso calcolato[modifica]

Dopo aver fatto calcolare il percorso seguendo le istruzioni dei paragrafi precedenti selezionare dall'Outliner l'oggetto percorso (oppure selezionarlo con il tasto destro nella 3D View), spostare il puntatore del mouse nella finestra 3D View e premere Alt+C quindi scegliere Curve from Mesh/Text per convertire il percorso in curve.

Attenzione!! Certe volte eseguendo questa operazione Blender crasha, è consigliabile salvare il progetto prima di convertire il percorso in curve.

Possiamo assicurarci dell'avvenuta conversione in Curve selezionando il percorso facendoci clic destro sopra e premendo Tab, se appare come nella foto sottostante l'operazione è avvenuta con successo.

Blendercam075.png


Creare una mesh con la geometria dell'utensile[modifica]

Realizziamo ora l'utensile; ci sono fondamentalmente tre tipi di utensili, la fresa piana, la sferica ed il bulino conico.

Bc056.png

Realizzare una fresa piana[modifica]

Per realizzare in Blender la fresa piana spostiamo il puntatore del mouse nella 3D View e premiamo Shift+A>Mesh>Cylinder, apriamo la Properties Windows premendo il tasto N e nella scheda Dimensions inseriamo nel campo X ed Y il diametro della fresa mentre in Z la sua lunghezza.


Realizzare una fresa sferica[modifica]

Per realizzare una fresa sferica spostiamo il puntatore del mouse nella 3D View e premiamo Shift+A>Mesh>UV Sphere, apriamo la Properties Windows premendo il tasto N e nella scheda Dimensions inseriamo nel campo X ed Y e Z il diametro della fresa, premiamo il tasto 1 per ottenere la vista Front Ortho, premiamo il tasto Tab per entrare in Edit Mode, Z per visualizzare in Wireframe, A per deselezionare tutto, premiamo Ctrl+Tab per accedere al menù Mesh Select Mode e scegliamo Vertex quindi B e facciamo una finestra di selezione che comprenda tutti i vertici sopra la mezzeria della sfera, premiamo X quindi Vertices per cancellarli. Premiamo B e facciamo una finestra di selezione che comprenda tutti i vertici che passano per il centro della sfera, premiamo E (di Extrude) quindi Z (per vincolare l'estrusione all'asse Z) ed inseriamo la lunghezza della fresa tolto il raggio (es.: fresa diametro 10mm lunghezza 50mm, inserire 50 - 5=45, inserire 0.045). Premiamo Tab per uscire da Edit Mode, Z per visualizzare in modalità Solid.


Realizzare un bulino conico[modifica]

Per realizzare un bulino conico spostiamo il puntatore del mouse nella 3D View e premiamo Shift+A>Mesh>Cylinder, apriamo la Properties Windows premendo il tasto N e nella scheda Dimensions inseriamo nel campo X ed Y il diametro della fresa mentre in Z la sua lunghezza. Premiamo il tasto 1 per ottenere la vista Front Ortho, Z per visualizzare in Wireframe, Tab per entrare in Edit Mode, A per deselezionare tutto, Ctrl+R per inserire un Loop Cut fino a far apparire una linea magenta orizzontale in centro al cilindro. Facciamo clic sinistro per confermare (o Enter) e spostiamo il Loop Cut in basso fino a farlo scomparire, confermare con clic sinistro (o Enter) quindi premere G (Grab) per spostarlo, Z per vincolare lo spostamento su tale asse e la quota relativa la lunghezza della parte conica del bulino (esempio raggio 5mm, conicità 30° inserire 0.00866). Premiamo A per deselezionare tutto, Ctrl+Tab per accedere al menù Mesh Select Mode e scegliamo Vertex, B e facciamo una finestra di selezione che comprenda tutta la linea di vertici più in basso, premiamo Alt+M e scegliamo Collapse. Premiamo Tab per uscire da Edit Mode, Z per visualizzare in modalità Solid. Per realizzare un bulino con un determinato angolo di inclinazione basterà eseguire un semplice calcolo trigonometrico; per ottenere un'inclinazione di 30° applicare questa semplice formula:

r/tan 30 (raggio bulino diviso tan angolo)

Nell'esempio realizzo un bulino di diametro 10mm, lunghezza 50mm con un angolo radiale di 30°


Scaricare Database_Tools.blend[modifica]

Da questo link https://drive.google.com/file/d/1uI75QYZ5J16hzhrPn2wViTXhbFQaWzu-/view?usp=sharing puoi liberamente scaricare la libreria di utensili base, l'origine di ognuno è già posizionata correttamente (vedi Posizionare l'utensile nel percorso con precisione).


Aggiungere un utensile da Database_Tools.blend[modifica]

Per aggiungere un utensile alla simulazione è sufficiente scegliere da File>Append>Database_tools.blend>Object l'utensile desiderato quindi portarsi nella scheda CAM Cutter e settare con i giusti parametri il campo Cutter (End, Ballnose o V-carve) e Cutter diameter. Parametri facoltativi sono il nome assegnabile nel campo Cutter preset e il numero di taglienti in Cutter flutes.

Aggiungere un Constraints all'utensile[modifica]

Per aggiungere un Constraints all'utensile fare clic destro sull'utensile per selezionarlo, dalla Properties scegliere Constraints>Add Object Contraints>Follow Path. Nel campo Target selezionare il percorso utensile (cam_path_Operation_1 ad esempio) quindi premere Animate Path.

Visualizzare la Timeline[modifica]

Prima di tutto dobbiamo visualizzare la Timeline nella parte bassa della finestra, per fare questo posizionare il puntatore del mouse nell'angolo inferiore sinistro (cambierà in una croce), premere il tasto sinistro e trascinare verso l'alto, verrà così creata una nuova finestra che cambieremo di funzionalità premendo il menù a tendina che visualizza un cubo (Vista 3D View) e scegliendo Timeline.

Posizionare l'utensile nel percorso[modifica]

Per una corretta visualizzazione della simulazione dobbiamo posizionare l'utensile nel punto di partenza del percorso, per fare questo ci sono almeno due modi: il primo consiste nel posizionare approssimativamente l'utensile premendo il tasto G e spostandolo a piacimento, il secondo invece posiziona con estrema precisione l'utensile ma necessita di alcuni passaggi supplementari.

Nella finestra Timeline posizionarsi nel campo Current Frame e digitare 1 per posizionare il cursore nel primo frame. Premere il tasto 7 per visualizzare Top Ortho, selezionare con il tasto destro l'utensile, premere G e spostarlo nel punto di inizio del percorso che dovrebbe coincidere con il punto X0 e Y0 (a meno di averlo modificato dalla scheda CAM Machine>Use position definitions nei campi X, Y e Z di Start Position). Possiamo anche digitare nella Properties Windows (tasto N) nella scheda Transform>Location i valori X0 e Y0 nei rispettivi campi. Il posizionamento sull'asse Z invece lo dobbiamo fare o approssimativamente (tasto G) oppure facendo dei calcoli per differenza.

Posizionare l'utensile nel percorso con precisione[modifica]

Nella finestra Timeline posizionarsi nel campo Current Frame e digitare 1 per posizionare il cursore nel primo frame.

Selezionare l'utensile e riposizionarne l'origine:

Fresa piana[modifica]

Selezionare la fresa piana facendo clic destro, premere Tab per entrare in Edit Mode, deselezionare tutto premendo A, premere Ctrl+Tab e scegliere Vertex, premere Z per visualizzare in Wireframe, premere B e fare una finestra di selezione che comprenda tutti i vertici inferiori del cilindro, dal menù Pivot Center scegliere Median Point, premere Shift+S e scegliere Cursor to Selected, premere Tab per uscire da Edit Mode, premere Ctrl+Shift+Alt+C e scegliere Origin to 3D Cursor.

Fresa sferica[modifica]

Selezionare la fresa sferica facendo clic destro, premere Tab per entrare in Edit Mode, deselezionare tutto premendo A, premere Ctrl+Tab e scegliere Vertex, Z per visualizzare in Wireframe, fare clic destro sul vertice al centro della sfera, dal menù Pivot Center scegliere Median Point, premere Shift+S e scegliere Cursor to Selected, premere Tab per uscire da Edit Mode, premere Ctrl+Shift+Alt+C e scegliere Origin to 3D Cursor.

Bulino conico[modifica]

Selezionare il bulino conico facendo clic destro, premere Tab per entrare in Edit Mode, deselezionare tutto premendo A, premere Ctrl+Tab e scegliere Vertex, Z per visualizzare in Wireframe, fare clic destro sul vertice al centro della punta, dal menù Pivot Center scegliere Median Point, premere Shift+S e scegliere Cursor to Selected, premere Tab per uscire da Edit Mode, premere Ctrl+Shift+Alt+C e scegliere Origin to 3D Cursor.

Dopo aver posizionato l'origine nell'utensile selezionare con clic destro il percorso oppure dall'Outliner fare clic sinistro sulla relativa voce, premere Tab per entrare in Edit Mode, deselezionare tutto premendo A, premere Ctrl+Tab e scegliere Vertex, Z per visualizzare in Wireframe, fare clic destro sul vertice all'inizio del percorso quindi premere Shift+S e scegliere Cursor to Selected, premere Tab per uscire da Edit Mode. Selezionare l'utensile (fresa piana, sferica o bulino conico), premere Shift+S e scegliere selection to Cursor. L'utensile verrà posizionato con estrema precisione nel punto di partenza del percorso.

Avviare la simulazione[modifica]

Se sono stati seguiti i passaggi Aggiungere un Constraints all'utensile e Posizionare l'utensile nel percorso siamo pronti per avviare la simulazione; possiamo usare la scorciatoia Alt+A, il tasto Play Animation posto nella timeline oppure trascinare il cursore verde della Timeline con il mouse. L'utensile dovrebbe seguire il percorso precedentemente calcolato. Ripremendo Alt+A si ferma la simulazione.

Settare i parametri di simulazione[modifica]

Per regolare la velocità di simulazione dobbiamo agire sul parametro Frame; selezionare il percorso facendo clic destro e dalla Properties scegliere Data>Path Animation>Frame

Esempio di simulazione con Blender CAM[modifica]

Dopo aver fatto calcolare il percorso a BlenderCAM apriamo una nuova finestra che visualizzerà la Timeline. Convertiamo il percorso in Curve selezionandolo dall'Outliner o con clic destro nella 3D View quindi premere Alt+C e scegliere Curve from mesh/Text. Premendo TAB ed entrando in Edit Mode ci possiamo assicurare della conversione effettuata. Selezionare il percorso convertito, premere TAB e fare clic destro sul vertice punto di partenza quindi premere Shift+S e scegliere Cursor to selected, uscire da Edit Mode premendo Tab. Selezionare l'utensile e dalla Properties scegliere Constraints>Add Object Contraint>Follow path , nel campo Target scegliere il percorso (cam_path_Operation_1) quindi premere Animate path. Posizioniamo l'utensile con precisione impostando nella Timeline il frame 1, selezionando l'utensile e premendo Shift+S>Selection to Cursor. Selezioniamo il percorso e dalla Properties>Data>Path Animation modifichiamo a piacimento il campo Frames ed eventualmente anche nella Timeline il campo END (questo modificherà la velocità di riproduzione). Premiamo Alt+A per avviare la simulazione e per fermarla.