Software e didattica/Il software autore JClic

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
CopertinaSoftware e didattica/Copertina
  1. IntroduzioneSoftware e didattica/Introduzione
  2. Il softwareSoftware e didattica/Il software
  3. I programmi autoreSoftware e didattica/I programmi autore
  4. Il software autore JClicSoftware e didattica/Il software autore JClic
  5. Uso di JClic nella didatticaSoftware e didattica/Uso di JClic nella didattica

Il software autore Jclic[modifica]

Il nostro viaggio alla scoperta del programmi autore termina con l'analisi del software JClic, open source distribuito con licenza GNU GPL, scelto da Giorgio Musilli come mezzo privilegiato per la creazione di oggetti di apprendimento, con il solo limite di non supportare in modo efficiente filmati e animazioni.

A JClic possono comunque essere affiancati tranquillamente altri prodotti molto validi tra quelli che sono stati descritti in questo lavoro, e cioè:

  1. i migliori software per realizzare risorse testuali, grafiche, audio e video;
  2. alcuni generatori di presentazioni (ad es. Didapages, CamStudio);
  3. altri programmi autore veri e propri (EdiLIM e Hot Potatoes in primis).

La scelta di JClic come strumento principe per la realizzazione di "learning objects" non è esclusiva, cioè non esclude altre possibilità e altri software: anzi, l'uso combinato di più applicazioni diverse molto spesso permette di raggiungere risultati di eccellenza, inarrivabili utilizzando singoli programmi.

Le ragioni di una scelta[modifica]

Si è visto come Hot Potatoes sia un valido programma autore e come alcuni suoi strumenti siano flessibili, potenti e facili da usare. Numerose ragioni ci spingono però a preferire JClic; in particolare è possibile:

  1. disporre di una versione "portatile" molto stabile completamente in italiano del programma;
  2. organizzare i progetti in sequenze ordinate di attività;
  3. importare e gestire in un'unica libreria multimediale le risorse grafiche, audio e video;
  4. compilare numerosi descrittori;
  5. inserire diversi "skin" (integrabili) per l'interfaccia in esecuzione;
  6. distribuire i progetti in pacchetti per Windows (anche disciplinari), senza bisogno di collegamento Internet;
  7. rendere eseguibile un progetto, senza avere Java installato, su qualsiasi sistema Windows (98/ME/XP/Vista/7/8/10);
  8. ottenere rapporti e resoconti sulle attività svolte dagli alunni;
  9. durante lo svolgimento degli esercizi, usare 3 tipi di contatori (cronometro, tentativi, punteggio), attivare gli aiuti, visualizzare/nascondere le frecce di navigazione, scegliere tra due diverse modalità di interazione (due clic o trascinamento);
  10. definire in modo distinto lo stile della finestra principale, della finestra di lavoro e dei pannelli delle attività;
  11. importare, esportare, copiare, incollare, duplicare, eliminare, spostare e modificare le attività inserite; 12) salvare i progetti, con tutte le risorse necessarie, in un unico file .jclic.zip;
  12. definire e gestire i messaggi iniziali, finali e d'errore, utilizzando anche immagini e suoni già pronti;
  13. lavorare direttamente sull'albero del documento;
  14. creare una pagina web (.html) per accogliere un progetto creato (in formato .jclic.zip);
  15. visualizzare immediatamente l'anteprima del progetto;
  16. modificare direttamente (all'interno dell'archivio .jclic.zip) il file .jclic in formato XML creato dal programma;
  17. realizzare attività vivaci e molto diverse tra loro (associazioni complesse e semplici, memory, esplorazioni, identificazioni, schermate informative, puzzle doppi, a scambio e a buchi, scrittura di risposte, cruciverba, crucipuzzle, attività testuali di completamento, riempimento, identificazione e ordinamento) in modo semplice e veloce, usando comode griglie e spazi già predisposti;
  18. convertire attività compatibili (es. puzzle a scambio e puzzle doppi);
  19. usufruire di una funzione "ritaglio" particolarmente utile per la preparazione di attività interattive complesse e gradevoli;
  20. utilizzare in modo flessibile le griglie e le varie funzioni del programma per ideare esercizi nuovi;
  21. prelevare e modificare migliaia di progetti già pronti, molti dei quali in lingua italiana, distribuiti con la stessa licenza open source del programma ;
  22. esportare i progetti direttamente in formato Html5 per la loro esecuzione on-line con qualsiasi dispositivo collegato a Internet.

I limiti sono relativamente pochi e si possono individuare nei seguenti punti:

  1. la versione originale con installer talora va in blocco (ma la versione "portatile" è stabilissima);
  2. manca di un generatore automatico di schemi per crucipuzzle e cruciverba;
  3. i files .avi e .swf non sono effettivamente supportati, anche se viene dichiarato il contrario, e per inserire animazioni bisogna ricorrere a .gif animate;
  4. manca uno strumento pensato specificatamente per la realizzazione di test a scelta multipla (anche se si possono realizzare ugualmente, ad es. con l'attività "Identificare celle").

In linea generale e operando con una certa approssimazione, possiamo dire che Hot Potatoes è più orientato verso studenti delle scuole superiori e delle università (con le collegate esigenze di valutazione delle conoscenze rispetto a contenuti molto estesi), mentre JClic è rivolto maggiormente agli alunni della scuola dell'infanzia, della scuola primaria e della scuola secondaria di primo grado e privilegia le attività più visuali (puzzle, memory, abbinamenti immagini-parole, cruciverba e crucipuzzle con immagini), rispetto a quelle prettamente linguistiche (cloze, ordinamenti, identificazione di parole). In JClic il continuo uso di immagini e suoni (nei messaggi, nelle finestre e nei pannelli) è previsto e incoraggiato e numerose opzioni regolano l'inserimento, la posizione e il comportamento di tali risorse all'interno di tutte le attività previste dal programma.

Il prodotto e gli autori[modifica]

JClic [1], pacchetto open source distribuito con licenza GNU GPL e basato su standard aperti (come l'XML), è stato realizzato da Francesc Busquets, con la collaborazione di Mònica Grau, Fernando Cuartero e Albert Llastarri, per conto del Ministero dell'educazione del governo autonomo della Catalogna (Departament d'Educació de la Generalitat de Catalunya). Il programma rappresenta l'evoluzione del programma Clic 3.0, creato sempre da Francesc Busquets nel 1992. L'utilizzo intensivo di questi strumenti da parte degli insegnanti in Spagna, ma anche in Francia, Germania e Gran Bretagna, ha permesso a Clic 3.0 prima e JClic dopo di essere al centro di un progetto collaborativo vivo e produttivo. Sono state realizzate migliaia di unità didattiche soprattutto in lingua spagnola (castigliano), catalano, basco e gallego, ma anche in francese, inglese, italiano e tedesco. La versione iniziale di JClic è stata la 0.1.0.0 (09/12/2005); successivamente JClic è stato aggiornato diverse volte: il 25/05/2006 (0.1.2.0), il 02/11/2006 (0.1.2.1), il 27/02/2007 (0.1.2.2), il 07/04/2008 (0.2.0.3), il 05/03/2009 (0.2.0.6), il 25/01/2010 (0.2.1.0), il 23/08/2013 (0.2.3.0), il 07/10/2013 (0.2.3.2), il 16/12/2013 (0.2.3.4), il 10/12/2015 (0.3.1.0), il 15/07/2016 (0.3.2.0), il 05/09/2016 (0.3.2.1), il 09/10/2017 (0.3.2.4), il 29/10/2017 (0.3.2.6). Se già nella versione 0.2.1.0 era stato previsto un inserimento più semplice e diretto delle risorse multimediali all'interno di tutte le attività e una facile importazione dei files preparati con Clic 3.0, con gli aggiornamenti del 10/12/2015 e del 15/07/2016 e con l'ultima versione del 29/10/2017, il programma ha raggiunto la sua maturità, correggendo numerosi bug, ma soprattutto prevedendo la possibilità di esportare i progetti in Html5 (pur con alcune limitazioni per determinate attività).

Attualmente JClic è distribuito in diversi modi: 1) con installer per Windows [2]; 2) in formato Java per tutti i sistemi operativi [3]; 3) come "portatile" per Windows 98/Xp/Vista/7/8/10 creato dagli esperti di Winpenpack e perfezionato da Giorgio Musilli [4]. Quest'ultima versione è in italiano (traduzione dall'inglese ad opera di Giorgio Musilli e di Roberto Marcolin), è assolutamente stabile e si avvia anche in sistemi Windows senza Java; l'archivio deve essere scompattato in una cartella vuota e poi si deve avviare X-JClicAuthor.exe nella directory principale. Questa versione "portable" si trova nel sito www.didattica.org/clic.htm (insieme a numerose risorse riguardanti JClic), mentre le altre due versioni del pacchetto sono prelevabili dal sito di clicZone (clic.xtec.net/en/jclic/index.htm), disponibile attualmente in spagnolo, catalano e inglese, e composto dalle seguenti sezioni: 1) JClic (caratteristiche, installazione, progetto); 2) Clic 3.0 (caratteristiche, scaricamento e installazione); 3) attività (ricerca, collaborazioni, informazioni); 4) comunità (mailing lists, collegamenti, mailbox); 5) documenti (articoli, corsi); 6) supporto (FAQ, segnalazione di bugs); 7) strumenti (utilities, altro); 8) ricerche (mappa del sito, attività); 9) selezione lingua (catalano, spagnolo, inglese). Le parti più interessanti sono ovviamente l'archivio con oltre 1300 progetti già pronti (clic.xtec.cat/db/listact_en.jsp) e la sezione della documentazione (clic.xtec.cat/en/documents/index.htm). Abbiamo parlato di "pacchetto" perché JClic è effettivamente composto da quattro moduli: 1) JClic Author, il software autore per la creazione, modifica e pubblicazione dei progetti JClic; 2) JClic Player, per eseguire un progetto di JClic off-line; 3) JClic Applet, per utilizzare i nostri lavori in una pagina web; 4) JClic Reports, per la raccolta e la memorizzazione delle informazioni sui risultati degli utenti. Si noti che: 1) JClic Reports non è necessario per il funzionamento degli altri moduli; 2) le pagine web create da JClic Author fanno riferimento all'Applet JClic che si trova sui server di clicZone (clic.xtec.cat/db/jclicApplet.jsp); 3) JClic Player non sarà analizzato in modo specifico, dato che è stato inserito all'interno di interfacce apposite per la distribuzione dei progetti JClic, le quali invece saranno descritte in seguito nei particolari. Nei prossimi paragrafi, oltre alla portabilità dei progetti, si provvederà anche ad analizzare in profondità JClic Author, mentre JClic Reports sarà trattato sono marginalmente.

Il modulo JClic Author[modifica]

JClic non è stato aggiornato da gennaio del 2010 ad agosto 2013; del resto non erano emersi "bugs" gravi e per un programma autore destinato agli insegnanti è positivo che l'aspetto e le procedure siano stabili nel tempo. Le versioni del 2013 si sono limitate a correggere diversi piccoli bug, senza modificare le caratteristiche, le funzioni e l'interfaccia del programma. Le ultime due versioni hanno invece introdotto, come detto, l'importante novità dell'esportazione dei progetti direttamente in Html5. All'interno del pacchetto una rilevanza particolare riveste ovviamente il modulo JClic Author. Se usiamo la versione "portatile" [5], consigliabile per la sua solidità, sarà opportuno creare sul desktop un collegamento a questo programma (X-JClicAuthor.exe presente nella directory principale), che è l'unico veramente necessario per la produzione di oggetti di apprendimento. Per il resto non dobbiamo fare altre operazioni, ma probabilmente è utile sapere che: 1) i files .exe presenti nella directory principale (X-JClicAuthor.exe, X-JClic.exe e X-JClicReports.exe) richiamano i corrispondenti files .jar (Java) posti nella sottodirectory "Bin\JClic"; 2) nella sottodirectory "Lib" la cartella "7za" contiene il compressore in .jclic.zip usato dal programma, mentre la cartella "Java" presenta una versione Java aggiornata; 3) la sottodirectory "ReadMe" raccoglie alcuni files informativi in formato .txt; 4) ultima, ma non meno importante, la sottodirectory "User\JClic" contiene tutti i nostri progetti (in cartelle separate) e piccole immagini .gif e .jpg (elaborate e distribuite da Giorgio Musilli) che possiamo usare nei messaggi (iniziali, finali, di errore), ma anche nelle caselle di qualsiasi esercizio (inserendo uno sfondo bianco per avere una migliore resa visiva). Se si usa la versione standard di JClic [6] o quella Java [7], le immagini per i messaggi possono essere aggiunte scaricandole dall'indirizzo [8] e scompattandole nella sottocartella "User\JClic".

Tornando alla gestione dei nostri lavori, è buona norma (e il programma lo suggerisce) assegnare una cartella a ogni progetto: anche quando si modifica un file .jclic.zip già pronto è opportuno creare per esso una cartella di lavoro apposita. Un altro accorgimento importante è l'assegnazione di nomi significativi ai progetti, adoperando caratteri solo minuscoli e il segno "_" (sottolineato) per separare le varie parole (es. germania_stati_federati). Infine è sempre consigliabile salvare spesso il proprio lavoro, ma soprattutto realizzare copie di sicurezza del file .jclic.zip in altre posizioni dell'hard disk o su una pen disk. Ma perché questa seconda soluzione sarebbe migliore? Le esperienze in laboratorio hanno dimostrato che la causa più frequente di danneggiamento dei files di dati è la mancanza di un file di risorse proprio durante la fase di salvataggio. L'unico modo quindi per salvaguardare con certezza il proprio lavoro è realizzare copie di sicurezza con una certa frequenza: in caso di crash del programma (e conseguente danneggiamento del file di lavoro) avremo una copia recente del progetto da cui ripartire.

L'interfaccia di JClic, pulita e funzionale, comprende una barra dei menu (in alto) e quattro distinte aree di lavoro, Progetto (in primo piano in avvio), Libreria Multimediale, Attività e Sequenze.

La barra dei menu[modifica]

La barra dei menu comprende 6 voci, File, Modifica, Inserisci, Strumenti, Visualizza e Aiuto.

Nel menu "File", accanto alla visualizzazione dei files recenti (massimo 8, selezionabili con il mouse oppure con le combinazioni dei tasti Alt+1, Alt+2, ecc.), troviamo 6 sottovoci: 1) "Nuovo progetto" (nella finestra che appare bisogna specificare il nome del progetto, il nome del file e la cartella di destinazione, quest'ultima selezionabile anche sfogliando il proprio hard disk); 2) "Apri file" (possono essere caricati pacchetti di Clic 3.0, progetti di JClic e installatori di progetti JClic); 3) "Apri URL" (carica un file .jclic.zip prelevandolo dalla pagina Internet specificata); 4 e 5) salvataggio del file corrente, anche con un altro nome; 6) uscita dal programma.

Con il menu "Modifica" si prevede di: 1) tagliare, copiare, incollare, cancellare, spostare in alto e spostare in basso le attività selezionate del progetto corrente o delle sequenze; 2) copiare le caratteristiche di un'attività in altre attività (molto utile ad esempio quando si vuole rendere uguale per tutte le attività lo stile dei messaggi). Le sottovoci del menu "Modifica" sono attive (a eccezione di "Copia le caratteristiche") solo quando ci si trova nelle aree "Attività" e "Sequenze".

Tramite il menu "Inserisci" è possibile: 1) aggiungere un nuovo oggetto multimediale, una nuova attività, un nuovo elemento in una sequenza; 2) importare attività da altri progetti.

Nel menu "Strumenti" troviamo 4 sottovoci: 1) "Impostazioni" (si possono modificare: l'aspetto di JClic Author con uno stile a scelta tra "system", "metal" e "motif"; la lingua, il codice della nazione, il codice opzionale della variante della lingua, il browser preferito; la dimensione massima delle immagini; un sistema multimediale a scelta tra "Autorilevamento", di default, "Java Media Framework" e "QuickTime"; le caratteristiche dell'Applet JClic); 2) "Albero del documento" (tutto il contenuto delle 4 aree di lavoro di JClic viene visualizzato in un albero e può essere modificato e salvato in ogni sua parte, tramite l'assegnazione di "valori" ai vari "attributi" che caratterizzano ogni elemento del progetto); 3) "Creazione della pagina web" (devono essere specificati: il titolo della pagina; un link per quando si esce dal progetto; la scelta tra "Applet a tutto schermo", di default, e "Applet con dimensioni specifiche" da indicare); 4) "Creazione dell'installatore del progetto" (sono già indicati, ma possono essere modificati, il titolo, gli autori, la cartella, i files da copiare, mentre per il pulsante di attivazione, oltre al progetto principale e all'etichetta, si possono inserire un'icona e una descrizione).

Il menu "Visualizza" permette di: 1) mostrare la pagina del progetto o della mediateca o delle attività o infine delle sequenze; 2) avviare l'anteprima dell'attività selezionata nelle aree "Attività" e "Sequenze"; 3) visualizzare l'anteprima del file multimediale selezionato nella "Libreria multimediale".

Nel menu "Aiuto" vengono mostrate unicamente le informazioni sul programma (versione, autore e collaboratori, traduttori, codice libero utilizzato, condizioni di licenza, informazioni sul sistema).

L'area "Progetto"[modifica]

L'area "Progetto" prevede tre settori per l'inserimento delle informazioni sul progetto ("Descrizione", "Creazione", "Descrittori") e una sezione con due impostazioni per l'interfaccia utente. Ogni settore può essere compresso/espanso cliccando sulla freccia vicino al nome che lo contraddistingue.

Nel settore "Descrizione" vanno inseriti il titolo del progetto e (appunto) la sua descrizione. Nel settore "Creazione" si possono indicare gli autori (nome, ruolo, e-mail, URL, organizzazione, commenti), la scuola (nome, e-mail, URL, indirizzo, CP, città, stato, nazione, commenti) e le revisioni (ognuna con data, descrizione, autori e commenti). Il settore "Descrittori" è didatticamente molto importante e permette l'inserimento di alcuni dati significativi: 1) livelli (ad es. "Scuola primaria"); 2) aree (ad es. "Matematica, Geografia"); 3) descrittori (ad es. "coordinate, assi cartesiani"); 4) lingue (selezionabili, eliminabili, modificabili e spostabili usando le apposite icone). Infine, nella sezione "Interfaccia utente", è consentito attivare/disattivare/impostare il "Suono dell'evento" e si possono applicare ai progetti diverse vesti grafiche ("skins"), corrispondenti ai seguenti stili: 1) @orange (normale arancione); 2) @green (normale verde); 3) @empty (senza barra inferiore e cornice); 4) @mini (con la sola barra inferiore molto sottile); 5) @default (normale grigio-chiaro); 6) @blue (normale blu); 7) @simple (barra della navigazione in alto, barra dei messaggi in basso). Nuovi "skin" possono essere creati, aggiunti e distribuiti con JClic Author.

Tutti i campi previsti nell'area "Progetto" sono facoltativi e la loro mancata compilazione non pregiudica il salvataggio dei lavori.

La libreria multimediale[modifica]

La gestione delle risorse in JClic è molto efficiente e funzionale. Ogni file multimediale da usare in un progetto va inserito nella "Libreria multimediale" o viene in esso copiato quando si seleziona una risorsa locale all'interno di un'attività. L'area è contraddistinta da diverse sezioni. In alto a sinistra troviamo 5 icone, corrispondenti alle seguenti funzioni: 1) "Aggiungi una nuova immagine o un nuovo oggetto multimediale alla biblioteca" (attraverso una finestra è possibile selezionare e importare immagini .gif, .jpg, .png, .bmp e .ico, suoni .wav, .mp3, .ogg, .au e .aiff, video .avi, .mov e .mpeg, caratteri .ttf, files .mid, files .swf di Flash 2.0, skins in formato .xml; se i files non si trovano nella directory del progetto, se ne chiede la copia in essa); 2) "Anteprima della risorsa multimediale" (selezionata); 3) "Cestino"; 4) "Aggiorna tutti i contenuti multimediali richiamando i loro archivi" (funzione molto utile quando si modificano i files con le risorse multimediali); 5) "Salva i files dei contenuti di tutti gli elementi multimediali" (si crea una copia delle risorse nella cartella del progetto).

Un filtro alle risorse multimediali può essere applicato selezionando una delle 8 opzioni elencate (tutti, immagini, suoni, midi, video, Flash, skins, caratteri) nel "combobox" sotto le icone.

Un clic semplice su una risorsa ne permette la selezione e di conseguenza vengono visualizzate nella parte inferiore dell'area le seguenti informazioni, molto utili per la loro ricerca e modifica sul disco rigido e all'interno delle varie attività: 1) nome (modificabile); 2) file (modificabile, estraibile dal files .jclic.zip e aggiornabile da file); 3) tipo di file multimediale; 4) grandezza del file; 5) attività in cui è presente (selezionandone una, è possibile accedervi direttamente tramite il tasto "Modifica...").

L'area delle attività[modifica]

Nell'area delle "Attività", la barra in alto a sinistra permette di creare e manipolare le attività e contiene 9 comandi sotto forma di icone: 1) "Aggiungi una nuova attività al progetto" (nella finestra che appare basta selezionare una delle 16 attività standard e scrivere il nome); 2) "Anteprima e prova dell'attività"; 3) e 4) sposta in alto e in basso l'attività selezionata; 5), 6), 7) e 8) copia, taglia, incolla e cancella l'attività selezionata; 9) "Copia le caratteristiche dell'attività corrente in altre attività". Quando si inserisce una nuova attività, essa viene aggiunta nella barra di selezione a sinistra dell'area delle "Attività".

Una volta inserite le attività desiderate, è possibile operare su ognuna di essa, definendone le caratteristiche e il comportamento all'interno di 4 sezioni, "Opzioni", "Finestra", "Messaggi" e "Pannello".

La sezione "Opzioni" è abbastanza trascurata, ma è piuttosto importante e comprende 7 settori chiudibili/espandibili: 1) "Descrizione", con l'indicazione del tipo di esercizio e del nome (entrambi modificabili) e l'aggiunta facoltativa di un testo informativo; 2) "Rapporti" (opzioni utili per ottenere resoconti sulle attività degli utenti); 3) "Interfaccia utente" (possono essere impostati "Suoni dell'evento" e "Skins" diversi per le varie attività); 4) "Generatore di contenuti" (opzioni utili per la generazione di contenuti automatici per l'aritmetica); 5) "Contatori" (Cronometro, Contatore dei tentativi, Punteggio); 6) "Pulsanti" (di aiuto e di informazione); 7) "Comportamento" (cicli di mescolamento, eventuale impostazione del trascinamento degli oggetti e del controllo dell'ordine di selezione). Si noti che: 1) quando si cambia il tipo di attività, non vengono mostrate tutte le opzioni disponibili, ma solo quelle compatibili; 2) selezionando "Arith" nella sezione "Generatore di contenuti" e cliccando su "Parametri", si viene introdotti in una finestra molto ricca in cui è possibile scegliere una delle 4 operazioni aritmetiche, la posizione dell'incognita, le caratteristiche del primo e secondo operando (campo di variazione, numeri specificati, tipo di decimali), le condizioni del rapporto tra operandi (indifferente, A > B, A < B) e le opzioni riguardanti il risultato (campo di variazione, tipo di ordinamento, ammissione di duplicati); 3) per il "Cronometro" si può impostare un tempo massimo (in secondi) e il conto alla rovescia; 4) per il "Contatore dei tentativi" si può stabilire un numero massimo di tentativi e il conto alla rovescia; 5) per il "Pulsante di aiuto" si può mostrare la soluzione dell'attività oppure può essere visualizzato un messaggio preparato dall'utente; 6) per il "Pulsante delle informazioni" può essere mostrato un URL Internet, oppure è possibile eseguire un comando; 7) i contatori e i pulsanti sono visualizzati e sono in funzione nell'attività solo se il quadratino corrispondente viene selezionato; 8) le attività sono elencate sulla sinistra in ordine alfabetico secondo il nome che abbiamo loro attribuito (modificando il nome è possibile quindi ottenere un ordine alfabetico diverso); 9) conviene dare un nome significativo alle varie attività, magari utilizzando all'inizio una numerazione (ad esempio 001_nome1, 002_nome2, ecc.) che consenta di riprodurre l'ordine con cui gli stessi esercizi sono riportati nelle sequenze.

La sezione "Finestra" è quella meno ricca, ma in certe occasioni è determinante per la buona realizzazione di un progetto. Ad esempio potrebbe essere necessario inserire una lista di parole come sfondo per un gioco enigmistico e porre la finestra di gioco in un angolo dello schermo. Le modifiche alla finestra dell'attività vengono visualizzate in tempo reale e riguardano 2 parti distinte: 1) per la finestra principale (lo sfondo vero e proprio) si possono impostare un colore, la sfumatura tra due colori (con impostazione delle ripetizioni e dell'orientamento delle strisce), un'immagine prelevabile dalla libreria multimediale o dal disco, la ripetizione della stessa (eventuale) immagine; 2) per la finestra di lavoro (che contiene i pannelli delle varie attività), non si può inserire un'immagine, ma è possibile impostarne il colore di sfondo, la sfumatura tra due colori, l'effetto di trasparenza, la presenza/assenza di un bordo, lo spessore del margine, la posizione centrata o assoluta.

La sezione "Messaggi", costituita da 3 barre (Messaggio iniziale, Messaggio finale, Messaggio d'errore), è importantissima dal punto di vista didattico: la presenza di istruzioni chiare e di rinforzi adeguati e positivi è la base per la piena riuscita di un'attività educativa. Per tutti e tre i tipi di messaggi (comunque facoltativi) è consentito: 1) inserire e posizionare un testo; 2) aggiungere e posizionare un'immagine; 3) impostare il bordo e l'aspetto di testi e sfondi; 4) indicare un contenuto attivo. Nel dettaglio: 1) il testo può essere messo in 9 posizioni diverse, ma nella maggior parte dei casi sarà sufficiente lasciarlo al centro; 2) per l'aspetto di un messaggio possono essere inseriti un colore di sfondo, una sfumatura tra due colori, l'effetto trasparenza, un carattere a scelta con grandezza ed effetti (normale, grassetto, italico) impostabili, il colore (normale e alternativo) del testo, la presenza di un'ombreggiatura colorata per il testo, il colore e la larghezza del bordo, il colore dello stato inattivo, la larghezza del marcatore; 3) è preferibile che le immagini per i messaggi siano piccole e che l'altezza corrisponda a 40 pixel; 4) una libreria di immagini già pronte si trova nel sito di Giorgio Musilli [9]; 5) se si seleziona la casella con "Permetti al testo di sconfinare dall'immagine", molto utile per evitare sovrapposizioni confuse tra testi e immagini, allora bisognerà porre attenzione alla disposizione degli elementi testuali e grafici (la nostra scelta "standard" è porre al centro il testo e a destra l'immagine). Si noti infine come per i contenuti attivi nei messaggi è possibile: 1) aggiungere suoni, video, midi; 2) registrare e riprodurre suoni; 3) andare ad un'attività o a una sequenza; 4) eseguire un programma esterno; 5) mostrare un URL Internet.

La sezione "Pannello" è la più complessa, ma anche il cuore pulsante di JClic, il motore per la creazione e modifica delle attività. L'aspetto della sezione e i comandi presenti in essa dipendono dal tipo di esercizio/gioco e quindi saranno trattati nello specifico nei paragrafi successivi dedicati alle singole attività.

L'area delle sequenze[modifica]

Nell'area delle "Sequenze", rispetto alla barra delle icone dell'area delle "Attività", sparisce la funzione di copia delle caratteristiche di un'attività in un'altra e l'attività viene aggiunta a una sequenza in cui composizione, ordine, struttura degli elementi sono stabiliti dall'utente. Per ogni attività aggiunta a una sequenza si possono indicare: 1) un'etichetta (utile per effettuare salti tra attività); 2) una descrizione; 3) la presenza/assenza della freccia avanti e della freccia indietro; 4) le azioni collegate alla freccia avanti e alla freccia indietro; 5) il comportamento della freccia avanti (avanzamento automatico dopo determinati secondi, salti condizionali a un livello superiore o inferiore). Si noti che: 1) è possibile accedere direttamente all'area "Attività" di un esercizio cliccando sul pulsante "Modifica"; 2) l'etichetta di un'attività all'inizio di una sequenza corrisponde anche all'etichetta dell'intera sequenza; 3) le attività nell'area delle "Sequenze" non sono poste automaticamente in ordine alfabetico (come avviene nell'area "Attività"), ma secondo la disposizione decisa dal realizzatore del progetto; 4) se i pulsanti della freccia avanti e indietro non sono attivi, per passare a una nuova attività si deve usare l'avanzamento automatico oppure si devono inserire salti ad attività e/o sequenze all'interno dei pannelli degli esercizi; 5) l'avanzamento automatico si può inserire anche insieme ai pulsanti "Freccia avanti" e "Freccia indietro" attivi; 6) i pulsanti "Freccia avanti" e "Freccia indietro" presentano 5 opzioni, tuttavia è consigliabile ignorare "Arresta" ed "Esci da JClic" e utilizzare "Torna al programma" e soprattutto "Vai avanti/indietro" e "Salta a..."; 7) un menu iniziale (senza "Freccia avanti" e "Freccia indietro") può contenere i riferimenti (salti) a più sequenze o attività; 8) in una sequenza con accesso regolato da un menu è opportuno: A) all'inizio inserire per il pulsante "Freccia avanti" il comando "Vai avanti" e per il pulsante "Freccia indietro" un salto al menu iniziale; B) alla fine inserire per il pulsante "Freccia indietro" il comando "Vai indietro" e per il pulsante "Freccia avanti" un salto al menu iniziale; 9) se non è necessario un menu iniziale e il progetto è costituito da un'unica sequenza di attività, alla fine saranno attivi "Freccia avanti" con l'opzione "Vai avanti" e "Freccia indietro" con l'opzione "Vai indietro", mentre all'inizio sarà attivo solo il pulsante "Freccia avanti" sempre con l'opzione "Vai avanti". Naturalmente queste indicazioni sono prodotte per lavori standard e gli utenti potranno decidere liberamente come strutturare le proprie sequenze e l'avanzamento/spostamento tra le varie attività.

Le attività di JClic Author[modifica]

Tutte le attività di JClic possono essere eseguite all'interno delle aree "Attività" e "Sequenze" cliccando sul triangolo verde con la punta rivolta a destra. In esecuzione, con lo stile di default, si vedono: 1) in alto, il nome del progetto; 2) al centro, la finestra con il pannello di gioco; 3) in basso a sinistra, le due frecce di spostamento, la bandierina verde per ripetere l'esercizio, i tasti di aiuto e di informazione; 4) in basso al centro, i messaggi (iniziali, finali, d'errore); 5) in basso a destra, il punteggio, i tentativi e il tempo. Per altre vesti grafiche ("skins") questi elementi variano in numero e posizione.

Le 16 attività standard di JClic, integrabili solo da persone esperte in programmazione Java, possono essere divise in 9 categorie e come tali sono analizzate nei paragrafi che seguono. Per ogni attività viene descritto il settore "Pannello" dell'area "Attività", l'unico che cambia secondo il tipo di esercizio proposto.

Schermata informativa[modifica]

La "Schermata informativa" è probabilmente l'attività più semplice e ci consente di descrivere accuratamente funzioni di base comuni con molte altre attività e che per questo motivo in seguito non saranno riprese. Come dice il nome stesso, si tratta di un'attività per la fornitura di informazioni all'utente. Una tipica schermata informativa è quella posta spesso all'inizio di un progetto con le indicazioni su titolo, autore e finalità degli esercizi. Oppure all'inizio di una sequenza di attività, un testo ricorda, riassume e riporta tutti i dati necessari per la corretta esecuzione degli esercizi che seguono. Infine possono essere inseriti approfondimenti con testi e immagini al termine di una sequenza.

Si lavora con un pannello di cui è possibile impostare: 1) righe (es. 3), colonne (es. 2), dimensione orizzontale (es. 300), dimensione verticale (es. 200); 2) stile (con gli stessi parametri usati per lo stile dei messaggi); 3) presenza/assenza del bordo; 4) eventuale immagine di sfondo. In alto c'è il "combobox" per la selezione della forma: la forma rettangolare è la più comune e normale, ma per questa attività è anche possibile usare forme varie tracciate tramite la funzione "Ritagli". Ogni casella della forma rettangolare o ogni forma ritagliata può essere definita nello stile e nei contenuti, indipendentemente dalle impostazioni generali dell'attività "Schermata informativa". Così, se abbiamo una griglia rettangolare 3x2, ognuna delle 6 caselle può essere impostata diversamente (ad es. nel colore di sfondo, nell'aspetto del testo, nella posizione delle immagini inserite) semplicemente con un clic sull'elemento interessato. Quando si operano dei ritagli, si smette di utilizzare una griglia rettangolare e si viene introdotti, cliccando sulla casella con i tre punti vicino a "Ritagli", in una finestra di lavoro piuttosto completa in cui è possibile: 1) aggiungere rettangoli, cerchi, poligoni; 2) selezionare, eliminare, copiare, incollare, ruotare figure; 3) aggiungere punti su una figura; 4) unire punti vicini; 5) fare zoom avanti e indietro per disegnare meglio le forme. Le forme realizzate sono indicate nella lista sulla destra e possono essere usate come se fossero caselle di una griglia. Si intuiscono le potenzialità di questo strumento, ad es. per la selezione di regioni geografiche o di parti di schede didattiche.

Esplorazione[modifica]

Nell'attività "Esplorazione" se clicchiamo su uno spazio, una casella, un testo, un'immagine, appare un testo o un suono o un'immagine che sono in relazione con l'elemento cliccato. Rispetto all'attività "Schermata informativa", qui si ha l'introduzione di: 1) una griglia B accanto alla griglia A (le modalità di modifica sono uguali a quelle già viste per la "Schermata informativa"); 2) una finestra per la disposizione delle griglie A e B (sono previste quattro modalità: AB, BA, A/B, B/A); 3) una finestra per indicare le relazioni tra le caselle delle due griglie. Si noti che: 1) si possono usare griglie rettangolari e forme ritagliate per entrambe le griglie; 2) la funzione "Mescola" può essere selezionata sia per la griglia A che per la griglia B; 3) mentre si inseriscono le relazioni, le frecce possono essere mostrate tutte (in alternativa viene visualizzata solo la freccia dello spazio corrente) e nel colore desiderato. L'applicazione "standard" di questo strumento è la visualizzazione e/o l'ascolto di informazioni relative agli oggetti contenuti nelle varie caselle di una griglia rettangolare. Ma possiamo pensare anche all'esplorazione delle parti del corpo umano o di un animale o di una pianta oppure alla visualizzazione delle informazioni relative alle varie regioni italiane; in queste attività è evidente come sia preferibile usare forme ritagliate invece di caselle di griglie rettangolari. La scelta del pannello adeguato, nell'attività di "Esplorazione" come anche in diverse altre attività, dipende dai contenuti e dagli obiettivi dell'esercizio e presuppone una ponderata progettazione iniziale dell'intero progetto Jclic.

Identificare celle[modifica]

Con "Identificare celle" torniamo ad un'attività con una sola griglia, in cui bisogna cliccare sulle forme ritagliate o sulle caselle corrette, definite dall'utente utilizzando la finestra "Relazioni". Semplicemente in quest'ultimo ambiente basta cliccare sulle caselle/forme desiderate ed esse assumono un colore scuro che indica la loro selezione; in fase di esecuzione l'utilizzatore dovrà cliccare solo su quelle celle/forme per completare l'esercizio senza errori. "Identificare celle" ci permette di introdurre un altro elemento interessante, il "contenuto alternativo", applicabile alla griglia principale (A) delle varie attività; la funzione si attiva mettendo la spunta in alto a destra vicino alla scritta "Contenuto alternativo:" e consente la definizione di un contenuto diverso sottostante la casella che si identifica correttamente: si può trattare di un messaggio o un'immagine di conferma, di un suono, di una .gif animata... Il contenuto alternativo è particolarmente importante da punto di vista didattico come rinforzo e stimolo per i piccoli utenti e come indicatore "in progress" per la corretta risoluzione degli esercizi. Si noti che: 1) per passare dal contenuto "standard" delle caselle/forme al contenuto "alternativo" si deve cliccare sulla casella "ALT" in alto a destra; 2) l'aspetto del contenuto alternativo per le celle di un'intera griglia o delle singole caselle/forme può essere definito all'interno delle corrispondenti finestre "Stile". Come per l'attività di "Esplorazione", anche per "Identificare celle" l'uso di griglie rettangolari o di tante forme ritagliate dipende dall'argomento degli esercizi e dei nostri obiettivi: identificare le parti del corpo di un elefante è un'attività molto diversa dall'identificare i mammiferi tra tante immagini differenti di animali; come anche è molto diverso selezionare tra 10 parole (ognuna in una casella) gli articoli e le preposizioni oppure indicare in un lungo testo (in un'unica cella) gli avverbi e gli aggettivi.

Scrivi la risposta[modifica]

"Scrivi la risposta" prevede un pannello con due griglie e le funzioni previste sono quelle dell'attività di "Esplorazione". La differenza principale è che cliccando su una cella della griglia A o su un elemento ritagliato sempre della prima griglia, nella seconda griglia (B) non viene visualizzato il contenuto della casella corrispondente, ma viene richiesta l'immissione di un testo scritto con la tastiera. Un'altra differenza è la possibilità di inserire un contenuto alternativo (nelle modalità illustrate per l'attività di "Identificazione") sempre per le caselle e forme della griglia A. Nella pratica la casella/forma interessata viene evidenziata con un bordo e l'immissione corretta del testo richiesto determina l'annullamento del contenuto principale della cella corrispondente nella griglia A e l'eventuale visualizzazione del suo contenuto alternativo.

Si noti che: 1) il testo da scrivere va inserito nelle varie caselle facendo attenzione a specificare tutte le varianti opportune (separate dal carattere "|", posto sopra il carattere "\" nella tastiera italiana), in modo da evitare frustrazioni per i piccoli utenti (ad es. per la regione "Valle D'Aosta" si dovrebbero inserire anche le varianti "Valle Di Aosta" e "Val D'Aosta", e per l'alimento "Yogurth" si potrebbero aggiungere pure le forme "Yogurt", "Jogurth" e "Jogurt"); 2) è opportuno prevedere per la griglia B una larghezza opportuna dello spazio di inserimento del testo; 3) di solito le lettere maiuscole e minuscole non influiscono sull'esatta risoluzione degli esercizi; 4) gli elementi della griglia B possono essere diversi da quelli della griglia A; 5) un elemento della griglia B può fare riferimento a più caselle/forme della griglia A; 6) se nella finestra "Relazioni" si seleziona l'opzione "Risoluzione inversa", il gioco termina quando sono stati assegnati tutti gli elementi della griglia B; 7) l'opzione di mescolamento ("Mescola") ha senso (e può essere usata) solo per la griglia A; 8) bisogna fare attenzione a non inserire spazi alla fine del testo da immettere, mentre i caratteri accentati sono ammessi e riconosciuti; 9) è consigliabile impostare bordi più spessi (quindi aumentare il valore della "Larghezza del bordo" nelle varie finestre "Stile") in modo da riconoscere meglio le caselle attive della griglia A.

Associazione semplice e complessa[modifica]

In ambito scolastico sono molto utili le due attività relative ai collegamenti presenti in JClic. L'"Associazione semplice" permette di associare caselle dello stesso numero: ad ogni casella nella griglia A corrisponde una (e una sola) cella nella griglia B. L'"Associazione complessa" consente anche di associare una cella/forma della griglia B a più caselle/figure ritagliate della griglia A. Nel secondo caso è necessaria la finestra "Relazioni" per l'indicazione dei rapporti tra le caselle delle due griglie (A e B), mentre nel primo caso l'associazione è fissa e si possono decidere solo la disposizione delle due griglie e l'attivazione del mescolamento per esse. Per il resto le due attività presentano le stesse funzioni dell'attività "Scrivi la risposta". Le applicazioni pratiche delle attività di associazione sono infinite; si possono indicare come esempi un lavoro di collegamento immagini-nomi all'inizio della primaria, un esercizio di collegamento nomi - parti dell'albero, una catalogazione di parole (articoli - nomi - avverbi), tutte attività possibili sia tramite l'"Associazione semplice", sia per mezzo dell'"Associazione complessa". Per l'attività di associazione semplice si noti che: 1) le due griglie (A e B) sono uguali nel numero di righe e colonne e le modifiche eventualmente apportate in questo senso su una griglia hanno effetto anche sull'altra; 2) le caselle della griglia A sono associate automaticamente alle caselle della griglia B nelle stesse posizioni. Per l'attività di associazione complessa è importante sapere che: 1) a una cella/forma della griglia B possono corrispondere più elementi della griglia A, ma non viceversa; 2) se nella finestra "Relazioni" si seleziona l'opzione "Risoluzione inversa", il gioco termina quando sono stati assegnati tutti gli elementi della griglia B.

Puzzle doppio, a scambio e a buchi[modifica]

Tre attività di JClic sono dedicate ai puzzles, in assoluto i più apprezzati dai piccoli utenti delle scuole primarie. Le verifiche sul campo hanno indicato come sia preferibile utilizzare con frequenza il "Puzzle doppio", seguito a discreta distanza dal "Puzzle a scambio". Il "Puzzle a buchi" appare invece non molto chiaro nella forma ed è comunque piuttosto difficile da risolvere, soprattutto se le tessere sono numerose (ad esempio 6x5). In generale i puzzles possono essere usati per produrre esercizi di due tipi: 1) puzzles classici, per cui un'immagine unica occupa tutta la griglia; 2) esercizi di riordinamento di qualsiasi tipo (ricostruzione di frasi, ordinamento di numeri e oggetti dal più piccolo al più grande, ecc.), con l'uso di testi, immagini, animazioni e suoni. Ovviamente per il secondo tipo di esercizi il "Puzzle a buchi" è assolutamente da evitare, mentre molto adatto è il "Puzzle doppio".

Per tutti e tre i tipi di puzzle è possibile selezionare, oltre alle griglie rettangolari e alle figure ritagliate, anche: 1) "Puzzle con unioni a curva" (tipici pezzi dei puzzles); 2) "Puzzle con unioni rettangolari"; 3) "Puzzle con unioni triangolari". Si noti che per queste 3 opzioni c'è la possibilità, cliccando sul pulsante con i tre puntini, di attivare/disattivare la distribuzione casuale dei tasselli e di impostare l'altezza e larghezza della loro dentatura. Il "Puzzle doppio" e il "Puzzle a buchi" prevedono due griglie, il "Puzzle a scambio" solo la griglia A. Per il “Puzzle a scambio” è consigliabile l'uso di tessere rettangolari, piuttosto che i classici pezzi con indentature. Infine l'opzione di mescolamento, necessaria nei puzzles, non è disattivabile, mentre è da tenere in considerazione la possibilità di togliere il bordo alle tessere, ad esempio nella ricostruzione di una cartina geografica dell'Italia con le varie regioni.

Memory[modifica]

Se le attività di puzzles prevedono l'inserimento di un'unica immagine come sfondo per la griglia A, il memory, per funzionare, deve veder definite singolarmente tutte le caselle. In ogni cella va messo un contenuto (testuale, grafico, sonoro, misto) che viene automaticamente raddoppiato da JClic. Il contenuto alternativo è essenziale per creare esercizi di memory in cui siano associati contenuti di tipo diverso (ad es. il nome di un animale all'immagine che lo rappresenta, ma anche un articolo a un nome).

Crucipuzzle e cruciverba[modifica]

I due giochi di enigmistica presenti in JClic, "Crucipuzzle" e "Cruciverba" sono molto interessanti, se non altro per la possibilità di associare immagini alle parole da cercare nel primo caso e alle definizioni nel secondo. Non esiste un'opzione per la generazione automatica di schemi, ma nel complesso, i due giochi sono più facili da costruire rispetto a Hot Potatoes 6.3, ed è sempre possibile usare programmi appositi per la preparazione di crucipuzzle e cruciverba. In particolare per i cruciverba e i crucipuzzle si possono utilizzare i già descritti Eclipse Crossword, Crossword Express (ex Magnum Opus) e The Spellbound! Word Search Creator.

L'attività "Crucipuzzle" si presenta come una griglia 3x3 con le lettere da A a I e con celle larghe e alte 20 pixel. Agendo sul numero di righe e colonne e sulle dimensioni di ogni casella, si può ottenere il diagramma nella dimensione desiderata. Una volta scritte le parole da cercare nello spazio bianco in alto a destra ("Parole nascoste"), esse possono essere aggiunte nello schema. Dopo il completamento dell'inserimento, in esecuzione JClic provvederà a riempire le caselle vuote con lettere a caso. E' comunque consigliabile cercare di completare lo schema per evitare che le lettere inserite a caso vadano a formare parole uguali a quelle già inserite (eventualità possibile, anche se piuttosto remota). Le parole aggiunte nella lista vengono automaticamente messe in caratteri maiuscoli; e sempre in maiuscolo vengono scritte le lettere nel diagramma. Si noti che: 1) è possibile eliminare il bordo alle caselle e cambiare l'aspetto di ogni parte del crucipuzzle; 2) cliccando su "Usa il pannello B" si può attivare la griglia B che può essere disposta a sinistra, a destra, sopra e sotto la griglia A e può contenere testi, immagini, suoni e animazioni collegati con la parola corrispondente; 3) le caselle della griglia B seguono nel loro contenuto l'ordine dei vocaboli nella lista delle parole nascoste; 4) per avere un crucipuzzle "classico" si può sfruttare un'immagine con parole da cercare da mettere come sfondo alla finestra principale dell'attività; esempi in questo senso si trovano nel pacchetto per la lingua italiana preparato da Giorgio Musilli (www.softwaredidattico.org/files/Jclic_italiano.zip); 5) si può inserire un'immagine unica per tutto il pannello B, in modo che la risoluzione del crucipuzzle porti alla visualizzazione progressiva di un puzzle; la stessa immagine può essere ritagliata (strumento "Ritagli"), in modo che risolvendo il crucipuzzle si possa pervenire al completamento dell'immagine con le forme mancanti (in questo caso conviene togliere il bordo alle forme ritagliate); 6) le dimensioni dei diagrammi (in righe e colonne) possono essere molto grandi; 7) in fase di preparazione, è ammessa la scrittura del diagramma solo in senso orizzontale.

Nell'attività "Cruciverba" la griglia A iniziale è uguale a quella dell'attività "Crucipuzzle", ma sono presenti subito una griglia B non disattivabile e la finestra della disposizione delle griglie. Una volta preparato lo schema di un cruciverba agendo opportunamente sulla griglia A (basta scrivere e incrociare le parole, le caselle nere occuperanno gli spazi senza lettere), cliccando sulle caselle iniziali di ogni parola si potranno aggiungere le definizioni sotto qualsiasi forma (testo, immagini, suoni, contenuti misti). Si noti che: 1) non ci sono numeri per le definizioni; 2) possono essere definite anche singole lettere (opzione utile per aiutare gli utenti a risolvere il cruciverba); 3) a differenza dell'attività "Crucipuzzle" non va scritta la lista dei vocaboli; 4) selezionando "Separatori trasparenti" le caselle nere vengono sostituite in esecuzione da spazi trasparenti; 5) come per l'attività "Crucipuzzle", in fase di preparazione, è ammessa la scrittura dello schema solo in senso orizzontale; 6) possono essere inseriti cruciverba anche di dimensioni notevoli.

Attività testuali e linguistiche[modifica]

Le attività testuali di JClic sono leggermente più complesse, ma permettono comunque di elaborare esercizi efficaci con testi, immagini, suoni e animazioni. Punti deboli delle quattro attività testuali ("Completa il testo", "Riempi gli spazi", "Identifica gli elementi", "Ordina gli elementi") sono: 1) difficoltà a memorizzare alcune modifiche apportate a esercizi testuali; 2) impossibilità di disporre correttamente i testi attorno alle immagini (di conseguenza spesso il testo slitta in basso o in alto e le immagini non risultano allineate correttamente alle parole); 3) necessità di un certo periodo di apprendimento delle procedure di creazione degli esercizi. La barra dei comandi della finestra "Stile" è presente allo stesso modo nei quattro esercizi testuali e contiene le seguenti funzioni: 1) modifica degli stili del documento; 2) rimozione degli stili di testo; 3) impostazione del tipo e della grandezza del carattere; 4) inserimento di grassetto, corsivo e sottolineato; 5) centratura del testo o suo allineamento a sinistra o a destra; 6) colore del testo e dello sfondo. Similmente sono comuni alle 4 attività testuali quasi tutti i comandi della finestra "Contenuto": 1) creazione e rimozione di un testo nascosto; 2) inserimento di una cella con testi e immagini; 3) impostazione dello schermo precedente e della correzione; 4) larghezza e altezza in pixel dell'oggetto. Si noti che: 1) per l'attività "Testo - Identifica elementi", è possibile scegliere due tipi di attività, "Identifica le parole" e "Identifica i caratteri"; 2) per l'attività "Testo - Ordina elementi", è possibile scegliere due tipi di attività, "Ordina i paragrafi" e "Ordina le parole" (con possibilità di sparpagliare le parole nel paragrafo); 3) nella finestra "Schermo precedente" di default non viene visualizzato alcun testo prima di un'attività, ma si può anche mostrare un testo inserito dall'utilizzatore oppure il testo completo dell'esercizio; 4) sempre nella finestra "Schermo precedente" è possibile agire sullo stile e il contenuto del messaggio precedente e sul tempo massimo di visualizzazione dello schermo precedente; 5) il comando "Inserisci una cella" permette l'inserimento di elementi multimediali nell'esercizio e consente la preparazione di attività più stimolanti e interessanti per i piccoli utenti.

Infine, le opzioni di correzione, particolarmente importanti in ambito didattico, riguardano: 1) per tutte le attività testuali, la presenza del pulsante di correzione (con testo modificabile); 2) per tutte le attività testuali, tranne "Testo - Identifica elementi", l'attivazione o meno di alcuni criteri ("Considera maiuscole/minuscole", "Considera accenti e caratteri speciali", "Considera la punteggiatura", "Permetti spazi ripetuti"); 3) per "Testo - Completa il testo" e "Testo - Riempi gli spazi", l'analisi della risposta; 4) per il solo "Testo - Riempi gli spazi", le possibilità di avanzamento ("Passa alla nuova parola nascosta una volta completato il riempimento", "Passa alla nuova parola solo dopo risposta corretta").

Uso avanzato di JClic Author[modifica]

JClic è un programma autore estremamente flessibile e può essere utilizzato per creare facilmente anche attività molto complesse, di solito realizzabili con una certa fatica adoperando i linguaggi di programmazione ad alto livello. In aggiunta è possibile operare variazioni nei files .jclic e .jclic.zip senza avviare JClic Author, in modo da velocizzare l'attuazione di determinate modifiche nei nostri progetti.

Attività complesse[modifica]

Alcune possibili attività complesse creabili con JClic saranno illustrate esaminando vari progetti inseriti nei pacchetti disciplinari presenti nella sezione JClic del sito "Didattica" di Giorgio Musilli (www.didattica.org/clic.htm). In generale molte possibilità di creazione di attività complesse sono legate allo sfondo della finestra di esecuzione e soprattutto allo strumento "ritagli", in combinazione con le attività "Associazione complessa", "Identificazione" e "Puzzle doppio".

Nel pacchetto JClic Immagine [10], descritto nel file www.softwaredidattico.org/files/jclic_immagine.pdf, ci sono: 1) clic_per_l'infanzia (fornitura di informazioni, istruzioni e messaggi senza l'uso di testi); 2) colori (sfondi vivaci e adeguati e avanzamento tra le pagine anche regolato da timer); 3) i_giochi_dei_colori_1_esploriamo_i_colori (esplorazione di parti di un disegno); 4) memory_animato (memory realizzato con immagini .gif animate); 5) nonogrammi_5x5_1 (gioco dei nonogrammi preparato usando una griglia A 8x8, con parte attiva 5x5, e una griglia B con i due colori necessari per risolvere il gioco); 6) quadratini_livello_1 (copia di piccoli disegni fatti con i quadratini).

Nel pacchetto JClic Italiano [11], descritto nel file www.softwaredidattico.org/files/jclic_italiano.pdf, sono presenti: 1) crucipuzzle_1 (creazione di un crucipuzzle classico sfruttando lo sfondo sottostante il pannello di gioco per evidenziare le parole trovate); 2) cruciverba_illustrati_1 (in questi cruciverba da completare con le lettere poste a sinistra e osservando le immagini presenti, sono stati sfruttati uno stile di pagina che dà più spazio agli schemi e lo strumento ritagli per i collegamenti lettere-caselle); 3) riconosci_la_lettera_a (test a 2 e 3 risposte con immagine corretta da cliccare).

Nel pacchetto JClic Lingue Straniere [12], descritto nel file www.softwaredidattico.org/files/jclic_lingue_straniere.pdf, ci sono: 1) actions_2 (uso massiccio di files audio); 2) christmas_is_here (uso di files audio di diverso tipo, .mp3, .wav e .mid).

Nel pacchetto JClic Matematica [13], descritto nel file www.softwaredidattico.org/files/jclic_matematica.pdf, sono presenti: 1) addizioni_puzzle e sottrazioni_puzzle (riproduzione esatta di due programmi creati da Giorgio Musilli in linguaggio Delphi); 2) alberi_di_addizioni (completamento di alberi di addizioni usando il collegamento numeri-caselle); 3) attività_di_calcolo_mentale_livello_1 (applicazione del motore matematica "Arith"); 3) futoshiki_1_4 (griglia A 7x7 per il futoshiki 4x4 e griglia B con i 4 numeri necessari).

Nel pacchetto JClic Musica [14], descritto nel file www.softwaredidattico.org/files/jclic_musica.pdf, si può indicare rispondiamo_a_tono_lezione_1 (le schede didattiche prendono vita).

Nel pacchetto JClic Scienze [15], descritto nel file www.softwaredidattico.org/files/jclic_scienze.pdf, si trova il progetto classe_1_prerequisiti_capacità_percettive_iniziali (tramite lo strumento ritagli vengono animate alcune schede didattiche per la classe prima).

Infine nel pacchetto JClic Storia, Geografia, Studi Sociali [16], descritto nel file www.softwaredidattico.org/files/jclic_storia_geografia_studi_sociali.pdf, sono presenti: 1) classe_1_prerequisiti_orientamento_spaziale_1 (schede rese interattive); 2) regioni_italiane (uso avanzato dello strumento "ritagli" per creare attività interattive riguardanti il nostro paese).

Modifiche dirette dei files .jclic e jclic.zip[modifica]

Una possibilità da considerare è quella di modificare direttamente sia il file .jclic sia l'archivio .jclic.zip. Operare su questi files ci permette in determinate situazioni di risparmiare tempi notevoli. Ad esempio, se convertiamo tutti i files .gif di un progetto in formato .jpg, non è necessario importarli tutti nella libreria multimediale e quindi cambiare uno per uno ogni collegamento all'interno delle varie attività; sarà molto più veloce: 1) eliminare tutti i files .gif dall'archivio .jclic.zip e sostituirli con i corrispondenti files .jpg; 2) estrarre dallo stesso archivio il file .jclic e modificarlo in un editor ASCII, sostituendo tutte le stringhe di testo ".gif" con la stringa ".jpg"; 3) salvare il file .jclic modificato e sostituire il file originale presente nell'archivio .jclic.zip. Naturalmente: 1) queste operazioni possono essere effettuate se il file .jclic.zip non è aperto correntemente da JClic Author; 2) prima di modificare .jclic.zip crearne una copia di salvataggio. Si noti che il file .jclic è in formato "aperto" XML e ogni sua parte può essere modificata.

Portabilità e distribuzione dei progetti[modifica]

Interfaccia vuota per JClic [17], preparata da Giorgio Musilli in linguaggio Delphi, può essere utile per preparare pacchetti personalizzati (come quelli disciplinari già descritti presenti in www.didattica.org/clic.htm) e per distribuire i propri progetti JClic. Basta mettere i progetti (nel formato .jclic.zip) nella directory "jclic".

Nelle ultime versioni (dalla 0.3.1.0) JClic permette l'esportazione dei progetti direttamente in Html5 per la loro esecuzione in rete tramite i navigatori Internet e senza bisogno di Java o Flash installato. È una possibilità eccezionale per la pubblicazione on-line dei nostri progetti. Centinaia di esempi si trovano in [18]; bisogna però tenere presente che per il player web ci sono alcune limitazioni: 1) sono assenti i pulsanti "Aiuto" e "Ripeti l'attività"; 2) i suoni degli eventi non sono ancora implementati (funzionano invece i suoni all'interno delle attività); 3) non bisogna usare files .wav, ma solo files .mp3; 4) la riproduzione dei video e la registrazione dei suoni non sono ancora implementate; 5) le attività testuali "Completa il testo", "Ordina gli elementi" e "Identifica gli elementi" non sono ancora implementate; conviene sostituire le attività testuali con attività di "puzzle doppio" usando la funzione "ritagli" per le immagini con i testi da completare; 6) la riproduzione dei files MIDI non è ancora implementata; 7) conviene non convertire progetti più grandi di 10 Mb; 8) il lettore on-line è testato solo con le ultime versioni di Chrome/Chromium e Firefox; 9) le attività con ritagli complessi devono essere verificate caso per caso; 10) usiamo caratteri abbastanza grandi in tutte le attività (16-22 in genere per tutte le attività, almeno 20 per le attività "Scrivi il testo", "Crucipuzzle", "Cruciverba" (schema e definizioni); 11) facciamo in modo (ma questo vale anche per i progetti non on-line) che le dimensioni totali delle finestre delle varie attività sia 800-1000 in orizzontale e 600-700 in verticale.

Al di là di questi limiti, che saranno sicuramente corretti in versioni successive del player on-line, si può verificare in [19] l'ottima qualità dei prodotti che è comunque possibile pubblicare; è disponibile una lista dei progetti convertiti, con descrizioni e collegamenti attivi [20].


TUTTI I COLLEGAMENTI:

  1. LINKS


Note