DoubleCAD XT/Punti, linee, poligoni

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search

Copertina

Point, Line, Polyline, Rectangle, Polygon, Construction geometry

Punti[modifica]

La funzione Point si usa per creare dei marcatori all’interno del foglio di lavoro.

Il comando dello strumento si trova nella barra in alto, nel menù a tendina sotto la voce Draw -> Point.

I punti possono essere identificati da diversi tipi di marcatori: punto, quadrato, croce, stella o circonferenza. Per impostazione predefinita del programma i punti vengono collocati nello spazio 2D.

Proprietà dei punti

- colore;

- tipo di marcatore (punto, quadrato, croce, stella o circonferenza)

La dimensione del punto non può essere modificata, in quanto questo oggetto ha sempre una dimensione minima.

Linee[modifica]

Linea Doublecad.JPG

Lo strumento linea permette di disegnare dei segmenti di retta sul foglio di disegno.

Lo strumento Line Linea Doublecad.JPG si trova nella barra degli strumenti alla sinistra del monitor. Può essere trovato anche a partire dalla barra in alto sotto al menù a tendina Draw -> Line.

Per disegnare una linea si deve:

- attivare lo strumento Line

- selezionare il punto iniziale e il punto finale della linea.

Se si vuole ottenere una linea di una lunghezza precisa o con una certa inclinazione si possono inserire i dati necessari nella barra delle impostazioni ( in basso a sinistra dello schermo).

Tenendo premuto il triangolo nero in basso a sinistra dell’icona (o a partire dalla barra in alto sotto Draw -> Lines) si possono scegliere altri tipi di linee: parallela, perpendicolare e tangente.

Linea Parallela[modifica]

Parallel doublecad.JPG

Per creare una retta parallela a una linea esistente si procede in questo modo:

- attivare lo strumento Parallel Parallel doublecad.JPG tenendo premuto il comando Line Linea Doublecad.JPG dalla barra degli strumenti a sinistra del monitor o dalla barra in alto sotto Draw -> Lines -> Parallel

- selezionare una linea esistente della quale si vuole disegnare la parallela

- cliccare sul foglio di disegno nella posizione in cui si vuole avere la linea parallela

La lunghezza può essere modificata veriando i dati della barra delle impostazioni ( in basso a sinistra dello schermo). Bisogna inoltre tenere conto che la linea parallela avrà la stessa lunghezza della linea originale e che verrà generata a partire dal punto in cui è stata selezionata la linea di origine; la lunghezza e la posizione del punto iniziale possono essere modificate veriando i dati della barra delle impostazioni ( in basso a sinistra dello schermo).

Linea Perpendicolare[modifica]

Perpendicolare doublecad.JPG

Per creare una linea perpendicolare ad una linea esistente si procedere nel seguente modo:

- attivare il comando PerpendicularPerpendicolare doublecad.JPG tenendo premuto il comando Line Linea Doublecad.JPG dalla barra degli strumenti a sinistra del monitor o dalla barra in alto sotto Draw -> Lines -> Perpendicular

- selezionare una linea del disegno e posizionare le linea perpendicolare nel punto desiderato. La lunghezza della linea può essere definita in modo preciso inserendo la misura nella barra delle impostazioni (in basso a sinistra).

Linea tangente a un arco[modifica]

Tangente a 1 arco doublecad.JPG

Questo strumento permette di disegnare una linea tangente ad un arco, un cerchio o un'ellisse, con il punto medio della linea situata nel punto di tangenza.

Per creare una linea tangente ad un arco si procedere nel seguente modo:

- attivare il comando Tangent arc Point Tangente a 1 arco doublecad.JPG tenendo premuto il comando Line Linea Doublecad.JPG dalla barra degli strumenti a sinistra del monitor o dalla barra in alto sotto Draw -> Lines -> Tangent Arc Point

- selezionare l'arco rispetto al quale si vuole disegnare la retta tangente

- determinare con il mouse la lunghezza della linea, oppure impostare la misura nella barra delle impostazioni (in basso a sinistra).

Tangent from Arc[modifica]

Tangent FROM arc doublecad.JPG

Questo strumento permette di disegnare una linea tangente a un arco con il punto iniziale posto sull’arco stesso.

Per disegnare una linea tangente a un arco in un punto si deve procedere:

- attivare il comando Tangent from Arc Tangent FROM arc doublecad.JPG tenendo premuto il comando Line Linea Doublecad.JPG dalla barra degli strumenti a sinistra del monitor o dalla barra in alto sotto Draw -> Lines -> Tangent from Arc

- selezionare un punto dell’arco rispetto al quale si vuole disegnare la retta tangente

- determinare con il mouse la lunghezza della linea, oppure impostare la misura nella barra delle impostazioni (in basso a sinistra).

Tangent to arc[modifica]

Tangent TO arc doublecad.JPG

Lo strumento disegna una linea tangente ad un arco, un cerchio o un'ellisse, partendo da un punto esterno. Si deve procedere come segue:

- attivare il comando Tangent to Arc Tangent TO arc doublecad.JPG tenendo premuto il comando Line Tangent TO arc doublecad.JPG dalla barra degli strumenti a sinistra del monitor o dalla barra in alto sotto Draw -> Lines -> Tangent to Arc

- selezionare il punto iniziale della linea, che non deve essere appartenente all’arco

- selezionare l'arco rispetto al quale si vuole ottenere la linea tangente.

Linea tangente a due archi[modifica]

Tangente a 2 archi duoblecad.JPG

Il comando permette di ottenere una linea tangente a due archi o cerchi.

Per disegnare una linea tangente a due cerchi si deve:

- attivare il comando Tangent to 2 Arcs Tangente a 2 archi duoblecad.JPG tenendo premuto il comando Line Linea Doublecad.JPG dalla barra degli strumenti a sinistra del monitor o dalla barra in alto sotto Draw -> Lines -> Tangent to 2 Arcs

- selezionare un punto del primo oggetto e poi un punto del secondo arco. Si ottiene una linea che parte dal primo arco e arriva al secondo e risulta essere tangente a entrambi.

Polilinea[modifica]

Polilinea dublecad.JPG

Questo comando permette di disegnare una serie di linee rette collegate tra loro. L’icona Polylline Polilinea dublecad.JPG si trova nella barra degli strumenti sulla sinistra dello schermo oppure si può trovare nella barra in alto sotto Draw -> Polyline.

Per creare una polilinea si deve procedere come segue:

- attivare il comando polilinea

- selezionare il punto iniziale e il punto finale del primo segmento (se si vuole essere precisi si può indicare la misura del segmento nella barra delle impostazioni in basso a sinistra)

- il punto iniziale del secondo segmento coincide con il punto finale del primo.

Si procede in questo modo fino ad ottenere la serie di segmenti desiderata.

Le polilinee possono essere formate anche da tratti di archi, nelle queli gli archi sono tangenti al segmento fatto precedentemente.

Per disegnare degli archi all’interno della polilinea si deve:

- selezionare Arc Segment dal menù a tendina che si ottine cliccando il tasto destro del mouse

- si deve cliccare il punto finale dell’arco oppure si può inserire l’angolo nella barra delle impostazioni (in basso a sinistra)

- per tornare poi a disegnare dei segmenti lineari bisogna selezionare Line Segment dal menù a tendina che si è ottenuto cliccando nuovamente con il tasto destro del mouse


-per teminare la polilinea è necessario dare invio.

Poligoni[modifica]

Poligono regolare[modifica]

Poligono doublecad.JPG

Lo strumento permette di creare dei poligoni regolari, cioè con lati e angoli della stessa misura.

Per disegnare un poligono regoalre si deve procedere:

- selezionare il comando Polygon Poligono doublecad.JPG dalla barra degli strumenti a sinistra dello schermo o dalla barra in alto sotto Draw -> Polygon - scrivere il numero di lati che si vuole ottenere nella barra delle impostazioni (in basso a sinistra)

- scegliere se si vuole disegnare un poligono inscritto o circoscritto in un cerchio e cliccare sull’opzione più adatta

- stabilire la misura del raggio del cerchio e dare invio per terminare il comando.

Poligono irregolare[modifica]

Poligono irregolare double cad.JPG

Questo comando è simile alla polilinea e permette di disegnare dei poligono con lati e angoli irregolari.

Per disegnare un poligono si deve:

- selezionare lo strumento Irregular PolygonPoligono irregolare double cad.JPG dalla barra degli strumenti sulla sinistra tenendo premuta l’icona del comando Polygon Poligono doublecad.JPG oppure dalla barra in alto nel menù a tendina sotto Draw ->Irregular Polygon

- definire i primi due vertici del poligono cliccando 2 punti sul foglio di disegno con il mouse o stabilire la distanza nella barra delle impostazioni (in basso a sinistra)

- dalla linea disegnata si vengono a formare 2 segmenti di chiusura (collegati alle etremità del segmento disegnato); è necessario cliccare con il mouse nel punto desiderato per ottenere il poligono irregolare o indicare la misura del lato e dell’angolo desiderati

- premere esc o invio per teminare il comando.

Rettangolo[modifica]

Rettangolo doublecad.JPG

Lo strumento permette di disegnare dei rettangoli a partire daagli angoli opposti.

Si può selezionare lo strumento Rectangle Rettangolo doublecad.JPG dalla barra a sinistra oppure dalla barra in alto nel menù a tendina sotto Draw -> Rectangle .

Un rettangolo si può disegnare come segue:

- selezionare il comando Rectangle

- selezionare un angolo del rettangolo cliccando il punto con il mouse

- cliccare sempre con il mouse l’angolo opposto oppure indicare le misure dei lati nella barra delle impostazioni (in basso a sinistra)

Rettangolo inclianto[modifica]

Rettangolo inclianto double cad.JPG

Lo strumento funziona come quello descrtitto in precedenza, con la sola differenza di avere i lati inclinati di un angolo a piacere che si può determinare nella barra delle impostazioni.

L’icona dello strumento Rotated Rectangle Rettangolo inclianto double cad.JPG si trova nella barra degli strumenti sulla sinistra dello schermo tenendo premuta l’icona Rectangle Rettangolo doublecad.JPG o nella barra in alto sotto Draw -> Rotated Rectangle.

Costruzioni geometriche[modifica]

Gli strumenti di costruzione sono linee e cerchi che vengono utilizzati come riferimenti per realizzare il disegno.

Il programma mette automaticamente gli strumenti di costruzione su un loro livello prestabilito $CONSTRUCTION; il layer ha il colore azzurro e ha un proprio stile di linea, che però possono essere modificati. È necessario prestare attenzione a non posizionare altri oggetti non riguardanti la costruzione su questo layer.

Per cancellare gli oggetti di costruzione si deve andare su Edit -> Clear -> Construction e poi selezionare gli oggetti da eliminare.

In Imposta Pagina si può scegliere se le linee di costruzione verranno stampate come parte del disegno o no.

Tenendo premuto il triangolo nero in basso a sinistra dell’icona Construction line.JPG (o a partire dalla barra in alto sotto Draw -> Constructions) si possono scegliere altri tipi di linee: verticale, orizzontale, angolare o si può scegliere di disegnare delle circonferenze di costruzione.

Linee di costruzione[modifica]

Construction line.JPG

L’icona dello strumento Construction Line Construction line.JPG si trova nella barra degli strumenti sulla sinistra dello schermo o nella barra in alto sotto Draw -> Constructin Line.

Per inserire una linea di costruzione si deve:

- attivare il comando Construction Line

- selezionare un punto con il mouse e cliccare un secondo punto o indicare l’angolo di inclinazione nella barra delle impostazioni

- dare invio per terminare il comando.

Linea di costruzione angolare[modifica]

Linea di costruzione angolare.JPG

Lo strumento permette di ottenere una linea di costruzione con un preciso angolo di inclinazione.

Si può selezionare lo strumento Angular Construction Line Linea di costruzione angolare.JPG tenendo cliccato il comando Construction Line Construction line.JPG nella barra a sinistra o a partire dalla barra in alto sotto Draw -> Constructions -> Angular Construction Line.

La linea di costruzione angolare si disegna:

- selezionare lo strumento

- indicare un primo punto della linea e indicare nella barra delle impostazioni.

Linee di costruzione orizzontale e verticale[modifica]

Linea di costruzione orizzontale.JPG Linea di costruzione verticale.JPG

Lo strumento permette di disegnare delle linee di costruzione orizzontali o verticali.

Le icone dei comandi Horizontal & Vertical Construction Line Linea di costruzione orizzontale.JPG Linea di costruzione verticale.JPG si trova tenendo cliccato il comando Construction Line Construction line.JPG nella barra a sinistra o a partire dalla barra in alto sotto Draw -> Constructions -> Horizontal e Vertical Construction Line.

Una volta selezionato lo strumento si possono disegnare delle linee verticali e orizzontali fino a quando non viene terminato il comando.

Linea di costruzione parallela[modifica]

Linea di costruzione parallela.JPG

Si utilizza questo strumento per disegnare delle linee di costruzione parallele a una linea data.

L’icona del comando Offset Construction Line Linea di costruzione parallela.JPG si trova tenendo cliccato il comando Construction Line Construction line.JPG nella barra a sinistra o a partire dalla barra in alto sotto Draw -> Constructions -> Offset Construction Line.

Per disegnare una linea di costruzione parallela si deve:

- selezionare lo strumento

- selezionare la linea della quale si vuole costruire la parallela (può essere anche un’altra linea di costruzione)

- selezionare un punto per il quale la linea passerà o indicare la distanza nella barra delle impostazioni.

Linea di costruzione perpendicolare[modifica]

Linea di costruzione parpendicolare.JPG

Permette di disegnare una linea perpendicolare a quella selezionata.

L’icona del comando Perpendicular Construction Line Linea di costruzione parpendicolare.JPG si trova tenendo cliccato il comando Construction Line Construction line.JPG nella barra a sinistra o a partire dalla barra in alto sotto Draw -> Constructions -> Perpendicular Construction Line.

È necessario:

- selezionare la linea rispetto alla quale ottenere la perpendicolare

- selezionare un punto per il quale passerà la linea.

Circonferenza di costruzione[modifica]

Circonferanza di costruzione.JPG Disegna una circonferenza di costruzione dato il centro.

L’icona del comando Center and Point Circle Circonferanza di costruzione.JPG si trova tenendo cliccato il comando Construction Line Construction line.JPG nella barra a sinistra o a partire dalla barra in alto sotto Draw -> Constructions -> Center and Point Circle.

Per disegnarla si deve:

- selezionare il punto centrale del cerchio

- definire il raggio, il diametro o la circonferenza nella barra delle impostazioni.

Circonferenza di costruzione dati due punti[modifica]

Circonferanza di costruzione 2 punti.JPG

Lo strumento crea una circonferenza dati due punti.

L’icona del comando Double Point Circle Circonferanza di costruzione 2 punti.JPG si trova tenendo cliccato il comando Construction Line Construction line.JPG nella barra a sinistra o a partire dalla barra in alto sotto Draw -> Constructions -> Double Point Circle.

Si disegna:

- selezionare un punto della circonferenza con il mouse

- selezionare un altro punto dalla parte opposta e si ottiene una circonferenza.

Circonferenza di costruzione dati tre punti[modifica]

Circonferanza di costruzione 3 punti.JPG

Permette di disegnare una circonferenza selezionando tre punti del foglio di disegno.

L’icona del comando Triple Point Circle Circonferanza di costruzione 3 punti.JPG si trova tenendo cliccato il comando Construction Line Construction line.JPG nella barra a sinistra o a partire dalla barra in alto sotto Draw -> Constructions -> Triple Point Circle.

Si procede semplicemente selezionando 3 punti e si ottiene la circonferenza.