DoubleCAD XT/I layer

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
Copertina

Prima dell’utilizzo dei sistemi CAD, i progetti erano costituiti da dozzine di disegni su carta o su mylar, che venivano stampati o copiati ed adoperati in cantiere per l'ideazione di un edificio. I disegni sono ancora necessari al processo di costruzione, ma oggi il progettista può organizzare in modo più efficiente le informazioni. I progetti cartacei necessitano infatti di un ordine preciso per essere letti ed analizzati, ma con la nascita dei sistemi Cad oggi il progettista puo' organizzare il proprio lavoro utilizzando un sistema di livelli, chiamati Layer, senza piu' dover fare affidamento a strumenti come lucidi sovrapposti e fissati con spilli. Infatti i Layer essenzialmente derivano dal processo base di posizionamento di informazioni simili sullo stesso foglio tramite strati sovrapposti. Rappresentano quindi lo strumento organizzativo più importante dei programmi CAD, poiché consentono di raggruppare vari tipi di informazioni per funzione e di applicare tipi di linee, colori ed altre impostazioni standard. È anche possibile utilizzare i Layer per evitare che alcuni oggetti vengano modificati o eliminati, per disporre gli oggetti secondo singole categorie e per rendere visibili o meno gli oggetti selezionati mentre si lavora.

Di seguito vengono elencate le funzioni e le impostazioni principali di questi ‘livelli’.


IMPOSTAZIONI LAYER

Aprire Gestione layer selezionando Format > Layers... , o facendo clic sull'icona nella barra degli strumenti Layer.

Questa pagina viene utilizzata per creare i layer, per assegnarne proprietà, e per l'organizzazione dei livelli stessi.

Il Layer caratterizzato da una numerazione di tipo "0" è il layer di default, e tutti gli oggetti sono posti qui se non diversamente specificato, o se non si crea un altro livello per poi renderlo attivo. Lo strato "$COSTRUZIONE" si crea solo quando viene creata una geometria di costruzione. Nessuno di questi strati di default può essere eliminato, ma è possibile modificarne le proprietà.

Per creare colonne e visualizzarle nella finestra Layer è necessario utilizzare la barra di scorrimento orizzontale. È possibile ordinare l'elenco facendo clic su qualsiasi colonna, l'elenco verrà ordinato in base al parametro selezionato Di seguito verranno elencati i vari parametri selezionabili:

Visibility / Visibilità (icona occhio): Verifica gli oggetti sullo strato visibile.

Read-only / Sola lettura (icona lucchetto): Verifica il livello di sola lettura, in modo che gli oggetti non possano essere modificati o eliminati. È possibile aggiungere oggetti di sola lettura attraverso lo strato elenco a discesa sulla barra degli strumenti (Doublecad layer toolbar).

Colours / Colore : selezionare il colore del livello dall'elenco a discesa e fare doppio clic (oppure fare clic su OK) per impostarlo. Il valore predefinito colore è nero. Gli oggetti avranno il colore del livello se il loro colore è impostato su by Layer.

Style / Stile : selezionare lo stile di linea dall'elenco a discesa e fare doppio clic per impostarlo. Gli oggetti avranno lo stile di livello se il loro stile è impostato sull'impostazione colore by layer.

Order / Ordine : determina l'ordine in cui gli strati sono disposti. L'ordine può essere utilizzato per inserire alcune categorie di oggetti di fronte agli altri, oggetti disegnati su uno strato superiore agli altri. L'ordine numerico è inizialmente impostato su zero. I Livelli che hanno lo stesso numero sono allineati in ordine alfanumerico. Il numero più alto di livello è 32767.

Width / Larghezza : Imposta la larghezza della linea. Gli oggetti avranno lo strato larghezza se la loro larghezza è impostata su Da layer.

Print style / Stile di stampa : Specifica dello stile di stampa per essere utilizzato da oggetti su quel livello.


LAYER MANAGER TOOLBAR (Barra di gestione dei Layer):

Qui sotto verranno elencati i comandi presenti nella Layer manager toolbar:

Manager Toolbar Refresh : Ripulisce il display dei livelli riportandolo alle impostazioni di default.

Nuovo livello di filtro: consente di creare un nuovo filtro layer. Per farlo è necessario assegnare un nome al filtro e quindi impostare il filtro nella finestra di dialogo Filtri layer. Vedere capitolo dedicato ai "Filtri di livello"

Modifica filtro Parametri: Aprire il filtro layer selezionato nella struttura nella finestra di dialogo “Filtri layer”.

Modificare i set di livelli: Apre la finestra di dialogo ed imposta il livello per creare e modificare i set di livelli. Vedere capitolo dedicato a "I set di livelli"

Nuovo Layer Template: Crea un nuovo modello di strato dai livelli attualmente selezionati.

Nuovo Layer: Crea un nuovo livello. Il nome predefinito include un prefisso di default, ma il nome può essere modificato.

Delete layer : Vedere capitolo sull' "Eliminazione di un livello"

Activate : consente di impostare il livello selezionato (solo) come il livello attivo. Questo avrà effetto su qualsiasi disegno,strumento o l'oggetto selezionato.

Select by : Seleziona tutti gli oggetti sul layer selezionato.

Edit proprietis: Apre la pagina con le opzioni di disegno.

Visible / Invisible All: Se uno strato invisibile tutti i livelli sono reso visibile. Se tutti i livelli sono visibili sono tutti realizzati invisibile.[sintassi]

Turn visibility: rende tutti i livelli visibili invisibili e viceversa.

Exclusive visible : rende solo i livelli selezionati visibili, tutti gli altri diventano invisibili.

Lock/ Unlock All: se un Layer viene sbloccato tutti i livelli vengono bloccati. Se tutti i Layer sono bloccati tutti i livelli vengono sbloccati.

Invert Lock: tutti i livelli bloccati si sbloccano e viceversa.

Exclusive Lock: Rende solo i Layer selezionati bloccati, tutti gli altri si sbloccano.

Layer Prefix: per impostazione predefinita, gli strati vengono denominati "Layer 1, Layer 2, etc.." . È possibile modificare o rimuovere il prefisso. Il simbolo @ è un segnaposto per la numerazione automatica dei livelli.


CREAZIONE DI UN NUOVO LAYER

Per creare un nuovo livello:

1. Selezionare Format > Layers , fare clic su New Layer, quindi assegnare un nome per il livello nella colonna Layer (o accettare il nome di default).

2. Regolare le varie impostazioni dei layer, come il colore e la linea stile.


ELIMINAZIONE DI UN LIVELLO

Si può eliminare qualsiasi livello tranne Livelli 0 e $COSTRUZIONE. I livelli possono essere eliminati anche quando contengono oggetti. Se un Layer da eliminare è impostato come predefinito per uno strumento (nella Pagina Generale della finestra Proprietà di uno strumento), si ricevere un messaggio di avviso prima che lo strato venga eliminato.

1. Selezionare Options > Layers e selezionare il livello che deve essere eliminato.

2. Fare clic su Elimina livello. Se il livello contiene oggetti, questi vengono eliminati. Questa azione può essere annullata, nel caso in cui si eliminino gli oggetti inavvertitamente.

In alcuni casi, gli oggetti sui livelli eliminati verranno spostati sul Layer 0 invece di essere eliminati. Se esiste un oggetto sul livello 1 sia nel both paper space o nel model space, e il livello 1 è stato eliminato dallo space model , nel paper space l'oggetto verrà spostato al layer 0. Ciò è dovuto a diversi "Annulla buffer" per model space e paper space.


MANIPOLAZIONE DEI LIVELLI E PROPRIETA'

Per impostazione predefinita, i nuovi oggetti vengono creati sul layer 0, a meno che venga selezionato un altro strato nella finestra delle proprietà di uno strumento specifico. Si può modificare il layer degli oggetti dopo che sono stati creati, oppure si può cambiare il layer di default di un gruppo di strumenti.


IMPOSTARE IL LIVELLO ATTIVO

Selezionare il livello che si desidera attivare spuntandolo dalla Layer List nella barra degli strumenti di DoubleCAD.

È necessario che vi siano uno strumento di disegno selezionato o un oggetto selezionato per cambiare il livello attivo.


IMPOSTARE IL LAYER DEGLI OGGETTI SELEZIONATI O UN GRUPPO DI STRUMENTI

È possibile impostare il livello che si desidera attivo selezionandolo dalla lista dei layer sulla barra degli strumenti in Format > Layer. È però necessario selezionare uno strumento di disegno o un oggetto per modificare il livello attivo; è così possibile impostare il layer degli oggetti selezionati o di un gruppo di strumenti per cambiare velocemente il layer degli oggetti stessi.

·Per impostare i livelli tramite la finestra Proprietà:

1. Selezionare (vedi capitolo Selezione) gli oggetti e aprire la finestra Properties. Impostare il layer per tutti gli oggetti creati con un certo gruppo di strumenti, fare clic con il tasto destro su una delle icone degli strumenti e aprire la finestra Proprietà.

2. A questo punto, nella pagina generale, selezionare il livello dall’elenco. Se il livello è impostato per oggetti selezionati, questi ultimi saranno trasferiti a quel livello.

·Per modificare rapidamente il layer di oggetti selezionati:

1. Selezionare gli oggetti.

2. Selezionare il livello dalla casella di riepilogo Livelli nel Livelli DoubleCAD barra degli strumenti.

Gli oggetti che verranno creati in futuro, tuttavia, compariranno ancora nel layer di default: se però il layer è impostato per un gruppo di strumenti, tutti gli oggetti creati con uno qualsiasi di quegli strumenti saranno automaticamente immessi sul livello selezionato. Per esempio, l'impostazione del livello per lo strumento Linea colpisce anche Rettangolo e Poligono.


MODIFICA DELLA VISIBILITA' E DEL COLORE

È possibile modificare la visibilità di un livello facendo clic sull'icona occhio accanto al livello selezionato. È allo stesso modo possibile cambiarne il colore facendo clic sull'icona del colore adiacente al layer.

ASSEGNAZIONA DELLE PROPRIETA' LAYER DI OGGETTI

Assegnare proprietà diverse a gruppi di oggetti o di strumenti all’interno dei layer è importante per poterli distinguere all’interno del disegno. Quelle che possono essere modificate a questo scopo sono il colore, il tipo di linea e il suo spessore. Il colore permette di distinguere in maniera rapida gli oggetti presenti nel disegno, per esempio si possono colorare di uno stesso colore tutte le entità di un componente. Il tipo di linea identifica i vari componenti del disegno: per esempio le linee degli assi hanno un tipo di linea (di solito tratto-punto), le linee nascoste un altro, le linee di costruzione un altro ancora. Gli spessori delle linee, infine, consentono di visualizzare le dimensioni del tratto: si può per esempio dare alle linee di disegno uno spessore più marcato rispetto alle linee di quotatura.

Per modificare tutte queste proprietà:

1. Aprire la finestra Properties.

2. Selezionare lo strumento Pen.

3. Le proprietà che possono essere impostate sono il colore, lo stile di linea e lo spessore. Impostare una o tutte queste proprietà come desiderato.

STRATI DI GRUPPI E BLOCCHI

Se si crea un gruppo composto da oggetti su uno stesso livello del disegno, il gruppo risiederà su tale layer. Per oggetti su livelli diversi, il gruppo sarà sul layer 0, ovvero il layer di default. Se successivamente si farà esplodere il gruppo, essi torneranno al loro livello originale. Gli oggetti devono essere spostati al layer 0 prima di essere utilizzati per creare un blocco. Il blocco stesso, quando inserito nel disegno, può essere riassegnato al livello corretto. Tutti gli oggetti all'interno del blocco che hanno una proprietà assegnata dopo assumeranno gli attributi del layer assegnato. Quando un blocco viene fatto esplodere, tutti gli oggetti originariamente assegnati a Livello 0 rimarranno sul layer su cui erano.


I SET DI LIVELLI

Un set di livello è un gruppo di layer che può essere visualizzato come gruppo. Ciò è utile per visualizzare certi aspetti di un disegno senza modificare le impostazioni di visibilità di ogni strato singolarmente. Il set di livelli predefinito è "tutti i livelli", che compare nel Menu Format. Essi possono essere modificati:

1. Nella finestra Livelli (Format > Layers), fare clic su Edit Layer Sets.

edit layer set

2. Quando la finestra di set di livelli si apre selezionare New.

3. Assegnare un nome al gruppo, o accettare il nome predefinito. Il nome viene visualizzato sul set dei livelli.

4. Sulla lista dei layer, controllare la visibilità di ogni livello che si desidera includere nel layer set.

5. Per visualizzare un set di livelli, aprire il Menu Format.

Per eliminare un set di livelli, selezionarlo dall'elenco Layer Set e fare clic su Delete. Per modificare i livelli visualizzati in un set di livelli, selezionarlo dal il set di livelli elenco e modificare le impostazioni di visibilità.