DoubleCAD XT/L'editing delle polilinee

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
Copertina

L'editing delle polilinee

EDIT TOOL

Per utilizzare questo strumento di modifica bisogna conoscere la funzione dei nodi; essi sono elementi che identificano le parti di cui sono composti gli oggetti geometrici (segmenti, archi..). L'Edit Tool ti consente di modellare la forma degli oggetti modificando proprio i loro nodi. E' possibile modificare un solo nodo alla volta oppure più nodi contemporaneamente (anche gruppi di nodi che appartengono ad oggetti diversi). I nodi possono essere di due tipi, che si differenziano grazie al colore: blu e verde. Se il nodo è blu significa che i due oggetti sono connessi tra loro (hanno quindi un nodo in comune), al contrario, se il nodo è verde, significa che i due oggetti non sono connessi tra loro (quindi vi sono due nodi sovrapposti).

Per attivare l'Edit Tool basta cliccare sull'icona dedicata nella barra degli strumenti sulla sinistra oppure nella toolbar in alto (Edit > Edit Tool) e selezionare l'oggetto da modificare; in alternativa si può selezionare tramite il tasto rapido Ctrl + Space.

Una volta in questa modalità si può accedere alle funzioni dello strumento cliccando col tasto destro sull'oggetto selezionato. Le funzioni principali dell'Edit Tool sono:

Edit Nodes: selezionare con andamento da sinistra a destra uno o più nodi dell'oggetto precedentemente selezionato. Ora è possibile spostare solo quei nodi dando una diversa forma all'oggetto. Nel caso ci siano due nodi sovrapposti: per modificarli entrambi basterà selezionarli insieme e poi col puntatore spostarli, per modificare solo uno dei due nodi sovrapposti basterà semplicemente cliccare su di essi e spostare nella posizione desiderata il nodo selezionato.

Add Node: cliccare col tasto destro sul punto dell'oggetto in cui si vuole aggiungere un nodo e selezionare il comando Add Node.

Edit Widths: questo strumento serve per modificare la larghezza degli oggetti. Sempre con l'intero oggetto selezionato e in modalità Edit Tool, selezionare i nodi che interessano la parte di oggetto che si vuole modificare, cliccare col tasto destro sull'oggetto selezionato e scegliere dal menu a tendina Edit Widths; ora trascinando col mouse i nodi si può modificare la larghezza dell'oggetto.


JOIN POLYLINE

Questo strumento permette di creare un'unica polilinea (quindi un unico oggetto), unendo tra loro più oggetti connessi tra loro alle estremità.

NB. gli oggetti che si sovrappongono non possono creare un unico oggetto.

Il procedimento è molto semplice; bisogna selezionare tutti gli oggetti che si vogliono includere nella polilinea, anche non seguendo un ordine preciso. Ora tutti gli oggetti sono compresi in un oggetto unico, come si può verificare con la modalità Selezione. In alternativa si possono selezionare gli oggetti e attivare la modalità Join Polyline.


STRETCH

Lo strumento Stretch permette di muovere un gruppo di nodi di uno o più oggetti, tramite un vettore di movimento. Si può attivare lo strumento Stretch nella barra degli strumenti a destra oppure dal menu a tendina nella toolbar in alto ( Modify > Stretch).

Una volta in modalità Stretch, trascinare una finestra di selezione da destra a sinistra attorno agli elementi da allungare, facendo attenzione a selezionare solo i nodi che si desidera modificare; se si seleziona un oggetto intero questo non si allunga, ma si sposta soltanto, dato che è stato applicato un vettore con uguale direzione, modulo e verso per ogni nodo. Una volta selezionati i nodi da modificare va creato il vettore movimento. Per farlo occorre creare un segmento cliccando in due punti differenti (che corrispondono alle estremità del vettore di movimento) oppure inserire la lunghezza e l'angolo negli appositi box in basso a sinistra (Lenght e Angle); così facendo i nodi selezionati si muoveranno rispetto alla direzione, al verso e alla lunghezza del vettore.

2D BOOLEAN

Le operazioni Boolean servono per creare un nuovo oggetto da altri due oggetti già esistenti. Questi oggetti possono essere combinati, sottratti o intersecati. Per compiere questa operazione si deve andare nella barra degli strumenti in alto, cliccare Modify > 2D Boolean Operation > Add o > Intersect o > Subtract.

L’ oggetto che viene a crearsi con questa operazione viene considerato una regione e quindi è possibile usare le Palettes per poterlo modificare. Le Palettes si trovano nella barra degli strumenti, dopo aver cliccato Tools.

2D ADD Questa operazione riunisce due o più oggetti chiusi in un’unica regione, eliminando le sovrapposizioni che vengono a crearsi tra gli oggetti.

1.Disegno due oggetti chiusi qualsiasi che si intersecano tra di loro.

Doublecad XT 2D ADD (1)

2.Li seleziono con l’operazione 2D Add e notiamo che l’oggetto è diventato una regione, e l’intersezione degli oggetti è sparita.

Doublecad XT 2D ADD (2)

2D INTERSECT Questa operazione evidenzia l’intersezione di due o più oggetti chiusi per formare una regione. È il contrario della precedente (2D Add) che ci eliminava l’intersezione. Qui viene tenuta solo l’intersezione tra gli oggetti. 1.Disegno due oggetti chiusi che formano un’intersezione.

Doublecad XT 2D INTERSECT (1)

2.Li seleziono con l’operazione 2D Intersect e notiamo che è rimasto solo il “contorno” dell’intersezione.

Doublecad XT 2D INTERSECT (2)

2D SUBTRACT Questa operazione sottrae uno o più oggetti da altri oggetti sovrapposti, creando così una regione.

1.Disegno due oggetti chiusi sovrapposti.

Doublecad XT 2D SUBTRACT (1)

2.Li seleziono con l’operazione 2D Subtract e notiamo che l’ultimo oggetto selezionato scompare, lasciando come un vuoto all’interno dell’altro oggetto, dove c’era l’intersezione.

Doublecad XT 2D SUBTRACT (2)


CHAIN POLYLINE

L’operazione Chain Polyline serve per intersecare gli oggetti o alcune sue parti in un’unica polilinea. Questa catena si crea selezionando gli oggetti che si vogliono inserire seguendo una specifica direzione scelta da noi ma indicata dallo stesso DoubleCad. Per compiere questa operazione si può andare sulla barra degli strumenti in alto, cliccare su Modify > Chain Polyline.

1.Disegno degli oggetti per fare l’esempio.

Doublecad XT CHAIN POLYLINE (1)

2.Seleziono la parte dell’oggetto in cui voglio che inizi la catena.

Doublecad XT CHAIN POLYLINE (2)


3.Sempre cliccando col tasto sinistro, imposto la direzione per far procedere la catena. DoubleCad quando ha davanti a se una intersezione, fa comparire delle freccette blu . Clicco su una di queste per scegliere la direzione.

Doublecad XT CHAIN POLYLINE (3)


4.La catena prosegue fino a che l’oggetto non è completo e così si crea la polilinea.

Doublecad XT CHAIN POLYLINE (4)