LibreOffice Writer/Campi, riferimenti incrociati e affini

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

In questo capitolo parleremo degli strumenti disponibili nel menù Inserisci → Comando di campo → Altri campi o dalla voce corrispondente del menù a tendina che offre il bottone Inserisci campo nella barra degli strumenti standard.

Quello che qui troveremo ci aiuterà ad automatizzare la creazione di certi contenuti che altrimenti sarebbero molto difficili da gestire.

I numeri di pagina, i riferimenti incrociati, i numeri che compaiono nelle didascalie delle immagini, il nome del capitolo che compare nelle intestazioni di pagina di questo libro e tante altre cose che vedremo di seguito sono gestite tramite «campi».

Un campo è pertanto una piccola porzione di testo il cui contenuto è determinato automaticamente seguendo certi parametri scelti in anticipo, essendo a sua volta «sensibile» all'intorno nel quale si trova.

Possiamo per esempio creare un tipo di campo particolare chiamato «variabile» che immagazzini il nome di un prodotto sul quale stiamo scrivendo un manuale. Oppure inserire la data nella quale si è modificato il documento senza nemmeno guardare il calendario. Oppure stabilire una condizione per far si che un determinato paragrafo venga «nascosto» quando quella condizione accade…

La lista è lunga e veramente interessante.

Scheda Documento[modifica]

Da qui possiamo inserire tante informazioni sul documento che si sta creando.

Queste informazioni possono essere statiche, per esempio il nome del file oppure la data, il nome dell'utente… o dinamiche come il testo che nelle intestazioni delle pagine di questo libro indica il nome di ogni capitolo.

Le opzioni qui sono piuttosto chiare e perciò non mi fermerò su di loro. Risulta soltanto importante rimarcare che l'inserimento del campo Capitolo, Livello si riferisce al livello di struttura configurato per gli stili di paragrafo utilizzati per i titoli, sia tramite Strumenti → Numerazione struttura oppure nella scheda Struttura e numerazione dello stile di paragrafo considerato.

Riferimenti incrociati[modifica]

Figura 46: Inserire riferimenti incrociati

Lo strumento per i riferimenti incrociati in Writer è sommamente potente. Permette di realizzare senza sforzo riferimenti a titoli, note a piè di pagina, liste numerate, didascalie, variabili (ne parleremo più in giù) utilizzate per numerare equazioni… Come si può vedere nella Figura 46, ognuna di queste opzioni si trova sotto una categoria propria nella lista di Tipo.

Nella Figura 46 risulta anche visibile una novità della versione 5.2: la Selezione. Questo funziona come un «filtro» che permette di ridurre la lista di elementi tra i quali dobbiamo scegliere, il che ci permette di trovare il riferimento giusto molto velocemente.

Risulta anche possibile «marcare» qualsiasi parte del testo oppure di un oggetto utilizzando Imposta riferimento: è sufficiente selezionare il testo o l'elemento, assegnarli un nome e fare clic su Inserisci. Dopo, tutti i riferimenti segnalati manualmente saranno disponibili in Inserisci riferimento.

Per ogni elemento sul quale vogliamo fare il riferimento si può scegliere, nel quadro Inserisci riferimento quello che vogliamo vedere: il numero della pagina dove si trova il testo o l'oggetto, il numero del capitolo (se si è configurato la numerazione in Strumenti → Numerazione struttura), il testo in se del riferimento, il suo numero… lascio al lettore esplorare le possibilità.

Funzioni[modifica]

Forse di grande utilità per documenti «da ufficio», le opzioni di questa scheda non servono tanto al momento di scrivere un libro, una tesi o un manuale… argomenti dei quali parliamo qui.

In questa scheda è possibile definire testi che si presentano soltanto quando una condizione logica s'avvera oppure si può introdurre una condizione per nascondere un paragrafo… non approfondirò questo argomento.

Info documento[modifica]

Permette di inserire l'informazione configurata preventivamente nel menù File → Proprietà → scheda Descrizione e Proprietà personalizzate.

Come la scheda precedente, risulta utile maggiormente in documenti «da ufficio» che in un libro e perciò non approfondirò sull'argomento.

Variabili, sequenze e altri campi particolari[modifica]

Nella scheda Variabili è possibile creare diversi tipi di variabili le quali possono essere fisse o dinamiche.

Per creare una variabile fissa (per esempio, un nome che deve ripetersi più volte nel documento o un numero da utilizzare ripetutamente) dobbiamo utilizzare Imposta variabile sotto Tipo. È importante selezionare il formato corretto per la variabile che viene creata, altrimenti se questa è numerica e inseriamo del testo non funzionerà.

Se ci sono diverse variabili numeriche già definite possiamo crearne una nuova (anch'essa numerica) che sia il risultato di una espressione algebrica del valore delle altre variabili. Per esempio, se definiamo Var1 come 2 e Var2 come 4 possiamo definire una variabile Foo che sia Var1 + Var2 oppure Var1^Var2.

Con un doppio clic sulla variabile già inserita nel documento potremo modificare il suo valore.

In Mostra variabile ci sarà una lista delle variabili da noi create che possiamo inserire ancora in qualsiasi parte del documento.

Il Campo DDE (Dynamic Data Exchange, o interscambio di dati dinamico) non risulta di tanta utilità in questo contesto perché esistono altri metodi molto più semplici per utilizzare oggetti DDE (per esempio, copiando una tabella in Calc e incollando con Incolla speciale → Collegamento DDE), perciò non parlerò di questa opzione.

Inserisci formula ci permette di creare un campo con una piccola espressione matematica.

Campo di digitazione è una specie di armadietto in attesa di contenuto: sarà sufficiente fare clic in un campo di digitazione inserito nel documento per dargli un nuovo valore.

I campi di Sequenza sono forse i più utili insieme alle variabili. A meno che non si vogliano «effetti speciali» come fare una sequenza che cresca di due in due, si può lasciare vuoto il suo Valore: Writer capirà che si vuole una sequenza che parte da 1 (o da A, o da I…) e che cresce di uno in uno.

Come esempio supponiamo di creare una sequenza nel formato A B C. Quando viene inserita per la prima volta su Writer vedremo il valore A con fondo grigio (il quale non verrà stampato e esportato in formato PDF). Se adesso facciamo un copia incolla più in giù di questa variabile vedremo una B, se incolliamo ancora una C… A questo punto, però, se muoviamo la B prima della A i valori mostrati dai campi saranno aggiornati automaticamente per mostrare la sequenza in ordine (A, B, C): la sequenza non è definita nell'ordine in cui è inserita, ma nell'ordine in cui si trova sul documento.

Per ultimo, Imposta variabile di pagina, on attiva un contatore di pagine che somma fino al punto dove viene inserito un Imposta variabile di pagina, off in modo tale che Mostra variabile di pagina ci fornirà il numero di pagine tra on e off.

Database[modifica]

Altra scheda di grande utilità per l'ufficio, ma di scarsa rilevanza per gli scrittori. L'unica banca dati di cui parleremo in questo libro sarà quella bibliografica che presenterò nel prossimo capitolo, perciò (ancora…) lascio passare l'argomento. Dirò soltanto che qui risulta possibile scegliere, e inserire, informazioni dalle diverse banche di dati registrate in LibO, permettendo di realizzare la «stampa guidata in serie» oppure utilizzare i dati più svariati su di un cliente o un prodotto, tra altre cose.

Configurare la numerazione di figure e tabelle[modifica]

Figura 47: Inserire questa didascalia
Figura 48: Scegliere i «livelli»

Con un clic destro su di un'immagine → Inserisce didascalia questa viene «rinchiusa» in una cornice insieme a un piccolo paragrafo descrittivo formato per la categoria scelta, un testo e una sequenza numerica.

Nella Figura 47 vediamo questa procedura per inserire la didascalia e nella Figura 48 il risultato. Ma come detto, questo «47» non è altro che una sequenza numerica chiamata Figura che possiamo vedere nella lista della scheda Variabili, tipo Sequenza.

Sia in questo menù oppure con un doppio clic sul numero di una didascalia possiamo configurare questa sequenza non solo per cambiare il tipo della numerazione ma anche per far vedere più «livelli» (Figura 48): con «nessuno» si ottengono dei numeri consecutivi su tutto il documento mentre con il primo livello la numerazione verrà reinizializzata dopo ogni titolo del primo livello e si presenterà come una numerazione del tipo <numero del primo livello>.<numero della figura>. Se viene selezionato il livello 2, <numero del primo livello>.<numero del secondo livello>.<numero della figura>… e così via.