LibreOffice Writer/Correzione automatica e testo automatico

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

Quando Writer sostituisce le virgolette "normali" per quelle “tipografiche”, quando trasforma automaticamente il primo carattere della parola iniziale di un periodo in maiuscolo, quando sostituisce -+> per una freccia → … in tutti questi casi sta realizzando una «correzione automatica».

È importante notare che anche se alcune delle opzioni di correzione automatica dipendono dell'idioma del testo questa funzione non ha relazione con il correttore ortografico, il quale dev'essere configurato separatamente (torneremo su questo a pagina 261).

D'altra parte, per capire cosa sono i «testi automatici» è sufficiente scrivere, in una riga vuota, «lorem» (senza virgolette) e premere F3 oppure scrivere «fn» (ancora senza virgolette) per poi premere F3. Nel primo esempio risulta introdotto un lungo testo mentre nel secondo comparirà immediatamente una tabella di una riga e due colonne con un oggetto Math e una variabile. Questi esempi dimostrano il funzionamento dei testi automatici e i loro principale obiettivo: immagazzinare frammenti di documenti che possano essere inseriti a volontà in modo semplice e veloce.

In questo capitolo parleremo di come vengono utilizzati entrambi gli strumenti.

Opzioni di correzione automatica[modifica]

Tutti i componenti principali di LibO hanno l'abilità di «correggere automaticamente», come configurato in Strumenti → Correzione automatica → Opzioni di correzione automatica.

Il menù con le opzioni di correzione automatica è simile in tutti i componenti di LibO:

  • Scheda Sostituisci: presenta una lista di testi che saranno sostituiti. Ci sono due tipi di «correzioni»:
    • Le «tradizionali» richiedono almeno uno spazio, virgola, punto, eccetera prima e un altro dopo il testo da sostituire. Per esempio, (C) sarà sostituito con © così come alcuni errori ortografici comuni («perchè» sarà sostituito da «perché»).
    • Le «immediate» che vengono attivate in qualsiasi posizione sempre che siano circondate da «:». Per esempio scrivendo :alfa: si ottiene immediatamente α.

È possibile creare le nostre sostituzioni: semplicemente si deve introdurre ciò che si vuole sostituire, ciò che si vuole ottenere e premere Nuovo.

  • Scheda Eccezioni: la lista dei casi in cui non si vuole applicare alcune regole. Utile per evitare le maiuscole dopo una abbreviazione oppure decidere quando due maiuscole consecutive non sono uno errore.
  • Scheda Opzioni: gli elementi che lì si trovano dipendono della componente di LibO utilizzata. In generale Applica tabella di sostituzione si riferisce alla lista che si trova in Sostituisci.
    Qui Writer presenta una particolarità: due punti di selezione. Quello a sinistra permette di applicare l'opzione al momento di fare Strumenti → Correzione automatica → Applica, mentre che quella a destra permette di applicare l'opzione durante la scrittura.
    È possibile che opzioni che vengono selezionare in modo predefinito in questa scheda non necessariamente siano le migliori, perciò consiglio vivamente al lettore di revisionare attentamente cosa fa ognuna di loro e lasciare soltanto quelle giudicate utili.
    Alcuni opzioni possono essere personalizzate con il bottone Modifica.
  • Scheda Opzioni localizzate: qui viene configurata la sostituzione delle virgolette "normali" per quelle “tipografiche” oltre a funzioni come inserire automaticamente uno spazio davanti ai segni ortografici nel francese o passare da 1o a 1°.
  • Completamento parole (solo in Writer): Writer raccoglie le parole lunghe che scriviamo e le suggerisce al momento di scrivere ancora i suoi primi caratteri. A tanta gente piace questa opzione mentre altri la odiano… ebbene, qui si può configurare. L'opzione, selezionata in modo predefinito nelle ultime versioni di LibO, Mostra come suggerimento la fa diventare molto più interessante.

In Writer le opzioni di correzione automatica possono essere disabilitate in forma globale togliendo la spunta su Strumenti → Correzione automatica → Durante la digitazione.

Se si desidera annullare una correzione automatica particolare è sufficiente premere Ctrl+Z immediatamente dopo che è stata introdotta da Writer.

Testi automatici[modifica]

Figura 44: Creare un testo automatico

Ho già introdotto i testi automatici a pagina 124 parlando delle diverse possibilità per creare tabelle con una formattazione definita: scrivendo «fn» (senza virgolette) e premendo F3 viene introdotta una tabella con un oggetto Math e una numerazione.

Come già detto, i testi automatici sono frammenti di documenti immagazzinati per Writer che possono essere introdotti tramite una «scorciatoia» che nell'esempio di prima sarebbe «fn».

Non esistono limiti per il contenuto del testo automatico: testo formattato, tabelle, immagini, cornici…

La procedura indicata a pagina 124 per creare un testo automatico con una tabella è anche valido per altri tipi di testi automatici: si seleziona quello che vogliamo includere nel testo automatico e poi si va a Strumenti → Testo automatico (Figura 44) per assegnargli un nome e un Tasto rapido. Finalmente, nel menù Testo automatico si avrà l'opzione Nuovo. Se il «tasto rapido» scelto fu, per esempio, «uta», sarà sufficiente scrivere uta e a continuazione premere F3 per far si che Writer inserisca il testo automatico da noi creato.

Lo spazio a destra della schermata in Figura 44 è per «vedere» quello che sarà introdotto nel documento… ma funziona soltanto con testi automatici già esistenti.

L'opzione Visualizza il resto del nome nella digitazione come suggerimento permette di inserire il testo automatico senza utilizzare il tasto F3: quando Writer riconosce che il testo che viene introdotto è simile al nome di un testo automatico, lo suggerisce in modo che premere Invio sarà sufficiente.

Per me, il tasto rapido seguito da F3 risulta più semplice. Il menù del bottone Testo automatico offre diverse opzioni, tra le quali si trova la possibilità di assegnare una macro all'evento introduzione di un testo automatico e, forse più importante, modificare un testo automatico esistente.

Quando un testo automatico viene modificato, un nuovo documento viene aperto. Sarà sufficiente, dopo modificare tutto ciò che serve, salvare il tutto come se fosse un documento qualunque. È importante ricordare che i cambiamenti saranno applicati soltanto ai testi automatici che verranno inseriti dopo la modifica.

Se si vogliono modifcare i testi automatici predefiniti è possibile che sia necessario avere privilegi d'amministratore nel sistema perché questi testi automatici sono immagazzinati nelle cartelle dove LibO è installato e nelle quali l'utente normale non ha (in realtà non dovrebbe avere) accesso.

Se il testo automatico creato contiene un vincolo sarà utile esplorare le opzioni di Salva collegamenti in modo relativo per così ottenere migliori risultati.

Finalmente il bottone Categorie ci permette di creare nuove categorie per raggruppare i nostri testi automatici, dandoci anche la possibilità di scegliere dove salvarli. È possibile creare nuovi percorsi con il bottone, di nome appropriato, Percorso.

Per quelli che preferiscano il mouse ai «tasti rapidi» è possibile utilizzare la barra degli strumenti Inserisci (Visualizza → Barra degli strumenti): uno dei suoi bottoni offre un menù a tendina con la lista completa dei testi automatici.