LibreOffice Writer/Problemi semplici

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

In questo capitolo e nei due seguenti presenterò qualche «trucco» per risolvere problemi comuni (e non) di Writer, organizzati per «difficoltà»

Cambiare velocemente l'ordine dei paragrafi[modifica]

Ctrl+Alt+ per «far salire» un paragrafo sopra quello precedente e Ctrl+Alt+ per «farlo scendere» sotto quello dopo. Questo funziona anche per più paragrafi: se vengono selezionati (anche non completamente) si muoveranno insieme.

Le tabelle purtroppo «bloccano» questo movimento, perciò se invece di muovere il paragrafo viene selezionata la tabella come forse testo (si deve prendere almeno una riga prima e una dopo) potremo muovere la tabella senza problemi utilizzando i tasti a scelta rapida appena commentati.

Si deve fare attenzione se ci sono oggetti ancorati ai paragrafi che stiamo muovendo, soprattutto se le loro posizioni sono determinate considerando l'area di testo della pagina.

Eliminare la riga sotto una tabella[modifica]

Quando viene inserita una tabella all'interno di una cornice oppure nell'intestazione (o piè di pagina), una riga vuota compare sempre sotto e nessuno dei modi «tradizionali» di eliminarla funzionerà. Portando il cursore alla fine dell'ultima cella (quella in basso a destra), sarà sufficiente premere Ctrl+ Shift+DEL.

In questo modo verrà cancellata la riga immediatamente sotto qualsiasi tabella, comprese quelle in mezzo a una pagina normale. Con Alt+ Invio la riga dopo la tabella viene ripristinata.

In realtà questo metodo elimina il periodo che segue, perciò se c'è del testo sotto la tabella verrà cancellato fino al primo punto, punto esclamativo o fine paragrafo, perciò si consiglia di fare attenzione…

Titoli in due linee[modifica]

L'idea è costruire qualcosa come questo:

Capitolo 1
Titolo del capitolo

Testo normale

oppure

Capitolo 1
Titolo del capitolo
Testo normale

oppure

Capitolo 1
Titolo del capitolo
Testo normale

Fino a poco tempo fa riuscire a fare questo era un vero problema, ma nelle ultime versioni di LibO tutto è diventato molto semplice grazie al fatto che adesso l'indice ignora le interruzione di riga, perciò sarà sufficiente compiere i seguenti passi:

  1. In Strumenti → Numerazione struttura → scheda Posizione → Numerazione seguita da → selezionare Nulla
  1. Nel titolo, tra la numerazione e il testo principale premere Shift+ Invio.

Risolto. Evviva!

Trucchi usando font Graphite[modifica]

Numerare con i «nomi» dei numeri[modifica]

Se invece di «Capitolo 1», «Capitolo 2», eccetera noi vogliamo che Writer ci dia automaticamente «Capitolo uno», «Capitolo due», eccetera, cosa si fa?

Per il momento esiste un unico metodo per ottenere questo ed è utilizzando uno dei font Graphite commentati nel capitolo D.11 a pagina 247: Linux Libertine G o Linux Biolinum G.

Se viene definito uno stile di carattere che usi questi font con il parametro «name=1»,

Linux Libertine G:name=1

qualsiasi numero sul quale questo stile di carattere venga applicato sarà «tradotto» con il suo nome («1» diventerà «uno», «2» diventerà «due», «28» diventerà «ventotto»…) automaticamente, perciò sarà necessario soltanto utilizzare questo stile di carattere in Strumenti → Numerazione struttura → scheda Numerazione → Stile di carattere.

Allineare la numerazione delle note al piè di pagina[modifica]

I numeri che indicano le note a piè di pagina sono sempre allineate a sinistra:

9

10

per creare un allineamento «a destra»

 19

110

sarà sufficiente utilizzare i font Linux Libertine G oppure Linux Biolinum G nello stile di carattere chiamato Carattere nota a piè di pagina scrivendo (idem con Biolinum invece di Libertine):

Linux Libertine G:algn=2

(oppure 3…). Questo trucco si può utilizzare con i numeri dei capitoli nell'indice generale.

Ancore per le note al piè di pagina tra parentesi[modifica]

Per avere automaticamente le ancore delle note a piè di pagina tra parentesi tonde, cioè 1, 2, 3… è sufficiente modificare lo stile di carattere Richiamo alla nota a piè di pagina per utilizzare sia Linux Libertine G che Linux Biolinum G con il parametro «circ=2»

Linux Libertine G:circ=2

Simboli invece di numeri[modifica]

Particolarmente utile quando ci sono poche note a piè di pagina, se vogliamo utilizzare simboli anziché numeri dobbiamo utilizzare

Linux Libertine G:foot=1

come nome del font negli stili di carattere Carattere nota a piè di pagina e Richiamo alla nota a piè di pagina, non dimenticando di configurare le note a piè di pagina per essere conteggiate «per pagina» (ne abbiamo già parlato di come farlo…).

Parentesi dritte in testo in corsivo[modifica]

Non so cosa ne pensa il lettore, ma a me le parentesi tonde in corsivo non piacciono più di tanto. Proprio per questo ho utilizzato per lo stile di paragrafo delle «note» un trucchetto Graphite per ottenere questo effetto:

Testo fuori (e dentro) parentesi tonde.

Semplicemente, con Linux Libertine G e Linux Biolinum G è sufficiente utilizzare il parametro «para»:

Linux Libertine G:para=1

Inserire dati bibliografici fuori dall'indice bibliografico[modifica]

È possibile che, oltre a quello descritto a pagina 169 (e che troverà esempio nell'appendice A.1 a pagina 297) sia necessario inserire dati bibliografici direttamente nel corpo del testo. Writer permette di inserire qualsiasi dato, da qualsiasi banca dati registrata. Per quello ci sono due opzioni: utilizzare la finestra de la banca dati bibliografica (Strumenti → Database bibliografica) oppure aprire il pannello Sorgenti dati (Visualizza → Sorgenti dati, oppure F4 nelle versioni fino alla 5.1, Ctrl+ Shift+F4 a partire della 5.2) e scegliere il database bibliografica della lista.

Selezionando la riga che ci interessa in modo tale che tutta venga segnalata e prendendo con il mouse il triangolino verde a sinistra (Figura 86) potremo «trascinare» la riga sul documento: comparirà un menù che ci permetterà di scegliere i campi desiderati e la formattazione, come si può vedere nella Figura 87.

Figura 86: «Trascinare» una voce bibliografca
Figura 87: Inserire dati bibliografci nel corpo del documento

Per maggiore flessibilità nel formato consiglio di scegliere, per Inserisci dati come l'opzione Campi. A questo punto sarà sufficiente scegliere i campi desiderati dalla lista a sinistra.

È importante notare che fino a 5.2.2 c'è un errore che fa sì che trascinare direttamente dal database bibliografica non funzioni

Bug 101164 - Drag and drop from bibliography database does not insert any data

Questo si risolve in 5.2.3, ma comunque è possibile inserire i dati dal pannello Sorgenti dati come si può vedere nella Figura 88.

Figura 88: Lo strumento Sorgente dati con il risultato sul documento