LibreOffice Writer/Commenti e controllo delle versioni

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

Quando si prepara un lungo documento risulta sempre utile associare dei commenti a determinate parti del testo, sia per ricordarsi di revisionare un paragrafo che non ci è venuto molto bene che per indicare che manca qualcosa per scrivere o annotare un'idea che non si vuole dimenticare.

Soprattutto quando si lavora in collaborazione (anche se alcune persone potrebbero trovarlo utile per uso personale) potrebbe anche essere importante il mantenere la traccia delle modifiche e delle versioni per riuscire a tornare indietro davanti a una modifica non del tutto felice.

In questo capitolo parleremo brevemente delle opzioni offerte da Writer per entrambi i compiti.

Commenti[modifica]

Figura 6: Commenti in un documento Writer

Inserisci → Commento, oppure Ctrl+Alt+C, aggiungerà alla destra della pagina una barra grigia, la quale può chiudersi o aprirsi con il tasto Commenti nella sua parte superiore, con un riquadro ancorato al punto di inserimento e in attesa di testo. Nella parte inferiore di questo riquadro si trova l'informazione sull'utente che ha introdotto il commento, il giorno e l'ora della sua creazione e un menù che non solo ci permette di eliminare eventualmente il commento ma anche di rispondere se l'utente che modifica il documento è diverso da quello che lo ha commentato, come si può vedere nella Figura 6.

È anche possibile assegnare i commenti a un'area di testo e non solo a un punto particolare: è sufciente selezionare il testo «d'ancoraggio» prima di introdurre il commento.

Il botone Commenti per aprire o chiudere la barra dei commenti sarà visibile soltanto se il «righello» è ativo: Visualizza → Righelli → Righelli o Ctrl+ Shift+R.

Come si vede nella schermata, commenti introdotti da diversi utenti si presentano in diversi colori.

A pagina 22 si indica come confgurare l'informazione dell'utente in LibO.

Figura 7: Stampare i commenti

Al momento non esiste un'opzione grafica che permetta di personalizzare i colori dei commenti, i quali sono scelti automaticamente, però è possibile configurare il font utilizzato tramite il menù menzionato sopra con l'opzione Formatta tutti i commenti.

È possibile stampare i commenti (Figura 7) sia in forma individuale che insieme al documento, tanto ai margini della pagina nella quale si trovano (la pagina verrà automaticamente ridotta), che in una pagina indipendente o alla fine, semplicemente selezionando l'opzione appropriata nella parte inferiore della scheda «Generale» del menù di stampa (Ctrl+P oppure File → Stampa).

Registro delle modifiche[modifica]

Tanto con il menù Modifica → Traccia le modifiche → Registra le modifiche come utilizzando il bottone corrispondente nella barra degli strumenti standard o semplicemente premendo Ctrl+ Shift+E verrà attivata l'opzione di registrazione delle modifiche del documento.

Figura 8: Vedendo chi fece cosa e quando

Con il registro delle modifiche attivo vedremo che il testo nuovo avrà un colore diverso e sarà sottolineato. Nel margine sinistro si indicano le linee modificate. Con il mouse sul testo si presenterà un piccolo messaggio indicante chi ha modificato cosa e quando, come si vede nella Figura 8.

Facendo clic destro sul testo marcato risulta possibile accettare o rifiutare un cambio. Se adesso sul testo accettato (che si vede normalmente) realizziamo una modifica questa verrà nuovamente indicata in un colore diverso e con un formato differente: per esempio, il testo che viene cancellato rimarrà lì barrato fino a quando non verrà accettata in forma esplicita la modifica.

Figura 9o: Gestire le modifiche di vari utenti. Nella schermata si vede anche la barra degli strumenti delle modifiche.

In Modifica → Traccia le modifiche → Gestisci le modifiche → Elenco si trova un elenco completo delle modifiche non ancora accettate: selezionando una delle modifiche della lista la modifica corrispondente sarà indicata nel documento. Se ci sono più autori nel documento ognuno verrà indicato chiaramente, come si vede nella Figura 9.

Con un clic destro su di una modifica dell'elenco è possibile aggiungere un «commento» il quale sarà mostrato nella colonna, appunto, «Commento». Questi commenti non hanno relazione con quelli trattati all'inizio del presente capitolo.

Nella scheda Filtro è possibile filtrare le modifiche per autore, data di creazione, tipo di azione (inserimento, eliminazione...), eccetera.

Nel menù Strumenti → Opzioni → LibreOffice Writer → Modifiche è possibile personalizzare i colori utilizzati per segnalare le modifiche o il modo in cui si indicano le linee modificate.

Risulta possibile far sì che le modifiche non si visualizzino (ma vengano comunque registrate) togliendo la spunta a Modifica → Traccia le modifiche → Mostra le modifiche: in questo modo il documento risulterà più «leggibile» durante il lavoro di modifica.

È importante notare che tutto ciò che viene modificato dallo stesso autore sul documento verrà considerato come un'unica modifica. Effettivamente, se in un documento con il controllo delle modifiche attivo vengono scritte dieci pagine tutto ciò che è scritto in quelle dieci pagine farà parte di un'unica modifica.

Confronto di documenti[modifica]

Il menù Modifica → Traccia le modifiche → Confronta documento ci permette di prendere due documenti (per esempio, quello originale e una sua modifica) e confrontarli per capire le loro differenze: è sufficiente, da uno dei documenti, andare a questo menù e scegliere l'altro perché Writer marchi automaticamente le differenze, permettendo di accettarle o rifiutarle.

Questo risulta particolarmente utile quando diversi collaboratori lavorano simultaneamente in più copie dello stesso documento: aprendo il documento di riferimento e da lì chiamando la funzione di confronto ci permetterà di controllare le modifiche senza paura di dimenticare nulla.

La finestra che si presenta funziona esattamente come quella discussa nella sezione precedente per confrontare le modifica in un documento con la registrazione delle modifiche attiva.

Versioni[modifica]

Una forma alternativa per controllare le modifiche è utilizzare le Versioni.

Se invece di fare «salva con nome» periodicamente e utilizzare un altro nome per creare un file diverso per ogni versione usiamo la funzione File → Versioni sarà possibile salvare diverse versioni del documento all'interno dello stesso file.

Il menù che si presenta ci permette non solo si salvare una versione nuova ogni volta che vogliamo ma anche di forzare Writer a creare una nuova versione ogni volta che il documento viene salvato (l'opzione Guarda sempre la versione quando chiudi).

Figura 10: Creare la quarta versione del documento, questa volta per un terzo utente

Come si vede nella Figura 10, quando una versione viene salvata manualmente si ha la possibilità di scrivere un piccolo commento il quale potrà essere modificato a posteriori selezionando la versione della lista e premendo Mostra.

Il bottone Apri ci fa vedere la versione scelta della lista come un nuovo documento di solo lettura mentre Elimina cancellerà completamente quella versione senza toccare le altre.

Il bottone Confronta funziona nello stesso modo della funzione di confronto discussa in precedenza nel presente capitolo.

È importante notare che il sistema di controllo di versioni darà chiaramente dei file più «pesanti»: una copia completa del contenuto viene salvata nel file ogni volta si crea una versione. Questo può risultare un problema se si lavora in sistemi limitati, perciò sarà meglio lavorare con versioni come file indipendenti che dopo potremo confrontare utilizzando l'opzione discussa nella sezione precedente.