LibreOffice Writer/Draw

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

Anche se Writer offre strumenti per realizzare disegni il mio consiglio è di non usarle: è sempre meglio usare lo strumento giusto per il lavoro e in molti casi questo strumento sarà Draw, la componente di disegno vettoriale di LibO.

Mantenere i nostri disegni in un documenti Draw e copiare/incollare quello che risulta necessario ci salverà di molti problemi e farà si che il risultato del nostro lavoro sia più affidabile.

Ed è per questo che nel presente capitolo parlerò su Draw. Ma siccome il libro è su di Writer e non su come fare bei disegni, toccherò soltanto le questioni base qui, mettendo l'enfasi in quei punti che ci permetteranno di lavorare correttamente in Draw e che l'utente che si avvicina per la prima volta al programma potrebbe passare per altro.

L'interfaccia grafica di Draw[modifica]

Figura 60: L'interfaccia grafca di Draw

Proprio qui è dove la barra laterale brilla senza dubbi, mettendo a portata di mouse strumenti potenti e semplici da utilizzare e che ci permettono di modificare le proprietà degli oggetti in tempo reale.

Le opzioni predefinite di LibO sono migliorate enormemente nelle ultime versioni e perciò nella schermata che è visibile nella Figura 60 non si vedono personalizzazioni dell'interfaccia grafica, ma nel caso sia necessario cambiare qualcosa, ne abbiamo parlato già di come si fa a pagina 25, perciò andiamo avanti.

A destra vediamo la barra laterale con le sue quattro schede che corrispondono ai pannelli: Proprietà, Stili e formattazione, Galleria e Navigatore.

Il pannello Proprietà ci offre tanti strumenti per modificare gli oggetti grafici e il testo associato a loro velocemente e senza dover aprire menù speciali. Però soprattutto ci permette di fare queste modifiche in tempo reale.

Questo pannello ha diverse sezioni che si presentano secondo sia il contesto.

Se viene selezionato qualche oggetto, per esempio un rettangolo oppure una linea, si presentano degli strumenti per gestire le proprietà del testo chiamate Carattere e Paragrafo. Questo è così perché ogni oggetto Draw può avere associato un testo: un doppio clic risulta sufficiente per iniziare a scrivere.

Ci sono anche strumenti che ci permettono di modificare linee e riempimento degli oggetti, i loro colori, la trasparenza…

Nel pannello Posizione e dimensione possiamo muovere, ingrandire, ridurre o pure rispecchiare un oggetto con grande precisione.

Dall'altra parte dell'area di lavoro c'è il pannello chiamato Pagine che presenta miniature di tutte le pagine esistenti nel documento e sul bordo sinistro della finestra una barra degli strumenti con diversi bottoni (alcuni sono in realtà menù a tendina) che ci permettono di inserire le forme base, modificare il colore di una linea o il riempimento di un oggetto, eccetera.

Le curve Bézier[modifica]

Gli strumenti di disegno di LibO permettono di creare diversi tipi di linee, come poligonali, curve a mano libera o curve Bézier. Quest'ultimo tipo di curva, molto comune in programmi di disegno vettoriale, si costruisce dando una serie di punti per i quali questa curva passa e indicando l'inclinazione a entrambi lati di questi punti e «quanto piatta» sia la curva lì. Il modo in cui queste curve si costruiscono in LibO è un po' diverso degli altri programmi come Inkscape, però non risulta difficile da imparare. Vediamo la procedura in dettaglio.

Figura 61: La curva da costruire

La curva nella Figura 61 viene definita da tre punti, quello centrale indicando i controlli di inclinazione e «appiattimento»: più lunga la linea tratteggiata è, più «piatta» risulterà la curva in quel punto (la lunghezza e l'inclinazione della barretta tratteggiata si regola con i suoi punti estremi). Se la curva viene costruita nel senso della freccia, possiamo chiamare la barretta «a» «controllo d'inclinazione anteriore» mentre la «b» sarà il «controllo d'inclinazione posteriore».

Figura 62: Costruire la curva

Prima di tutto, dobbiamo selezionare lo strumento giusto (l'icona potrebbe essere diverso a seconda dello stile scelto in Strumenti → Opzioni → LibreOffice → Vista) e tracciamo la curva nell'ordine indicato nella seguente lista dove ognuno dei suoi punti è rappresentato nella Figura 62. La freccia nell'estremo della curva nera —quella «vera»— indica la direzione nella quale viene costruita mentre i numeri indicano il movimento del mouse:

  1. Un clic, senza rilasciare il bottone del mouse, dove si vuole il primo punto della curva.
  2. Muovere il mouse verso la direzione del «controllo posteriore» di quel primo punto e rilasciare il bottone.
  3. Clic, ancora un volta senza rilasciare il bottone del mouse, nel successivo punto della curva.
  4. Muovere il mouse indietro nella direzione del «controllo anteriore» di questo secondo punto e rilasciare il bottone.
  5. Ripetere i punti 3 e 4 fino a completare la curva.
  6. Un doppio clic nell'ultimo punto della curva, o sul punto iniziale, darà termine al processo (in quest'ultimo caso la curva sarà chiusa).

A partire dal secondo punto non viene specifcato il «controllo posteriore». Questo viene automaticamente creato per Draw nella direzione opposta del «controllo anteriore».

Giocando con la barra degli strumenti Modifica punti (si attiva e si toglie con F8 oppure con il corrispondente bottone della barra degli strumenti Standard) è possibile aggiungere, togliere, muovere punti, tagliare e «spezzare» la curva, separando il comportamento dei controlli d'inclinazione anteriore e posteriore e riuscendo così a creare degli angoli.

La barra degli strumenti Modifica punti è contestuale, perciò si ativa e sarà visibile soltanto se viene selezionato un oggeto sul quale possa essere utilizzata.

Organizzazione e allineamento degli oggetti[modifica]

Figura 63: Organizzare disegni

Quando ci sono due o più oggetti sovrapposti possiamo decidere quale sarà sopra l'altro, in modo tale che l'ordine tra loro risulti chiaro.

Con un clic destro sul oggetto → Disponi potremo scegliere di far «salire» o scendere» l'oggetto in questione in confronto con altri oggetti nel disegno, oppure inviarlo direttamente in primo piano o in fondo.

Le opzioni di allineamento sono anche loro molto semplici da utilizzare: centrare nella direzione orizzontale o verticale, allineare a sinistra o a destra, sopra o sotto…

Un'opzione anch'essa interessante compare quando si selezionano tre o più oggetti: Distribuzione. Questa opzione distribuisce gli oggetti selezionati considerando la posizione di quelli più esterni. Questo strumento è più semplice da utilizzare che da spiegare e perciò lascio al lettore il compito di esplorarlo.

Lavorare con «Livelli»[modifica]

Figura 64: Il seletore di livelli

Sicuramente avrete notato in basso all'area di lavoro di Draw quello mostrato dalla Figura 64.

Ognuna di queste schede (ne possiamo aggiungere di più con un clic destro → Inserisce livello) serve a «classificare» gli oggetti inseriti nel documento in diversi «categorie», il che permetterà di modificare velocemente alcune delle loro caratteristiche.

Per far si che un elemento appartenga a un livello è sufficiente scegliere quel livello prima di inserire l'oggetto oppure «tagliare» un oggetto inserito prima in un livello per poi incollarlo in quello che ci serve.

I vantaggi di utilizzare i livelli sono tanti. Da una parte, con un clic destro sul livello → Modifica livello possiamo scegliere se gli elementi di quel livello sono visibili oppure no (per esempio, per nascondere alcune parte del disegno) o addirittura se gli elementi di quel livello devono essere stampati o meno. Questo risulta utile, per esempio, se vengono utilizzate alcune figure semplici per guidare il disegno generale ma non vogliamo che questi elementi di guida finiscano sull'immagine finale: raggruppando queste figure guida in un livello determinato possiamo dopo modificarne le sue proprietà per far si che quel livello non venga stampato. Anche dal menù di scelta Modifica livello risulta possibile «proteggere» quel livello per evitare che gli oggetti appartenenti vengano modificati mentre si lavora con gli altri.

Figura 65: Identifcare i livelli

Dal punto di vista dell'area di lavoro e a meno che uno non sia protetto da modifiche, non importa in quale livello si trova l'oggetto o quale livello sia attivo mentre si lavora: è possibile muovere e modificare gli oggetti indipendentemente del livello in cui si trovano e da quale livello li stiamo guardando.

E certamente, a questo punto potremmo chiederci, dopo una lunga giornata di lavoro, a quale livello corrisponde ogni oggetto particolare.

La risposta risulta semplice… ma non così evidente: come possiamo vedere nella Figura 65 se l'oggetto viene selezionato vedremo in quale livello si trova scritto… tra parentesi e a fianco del numero della diapositiva!

Gruppi di oggetti e operazioni tra oggetti[modifica]

Figura 66: Operazioni tra grafci usando il menù Forme. A: coppia originale; B: Combina; C: Collega, fgura di destra sopra; D: Collega, fgura di sinistra sopra E: Unisci; F: Sottrai, fgura di destra sopra; G: Sottrai fgura di sinistra sopra; H: Interseca.

Selezionando più oggetti risulta possibile «raggrupparli» con un clic destro sulla selezione → Raggruppa: in questo modo gli oggetti rimangono insieme evitando modifiche indesiderate.

Proprio sotto l'opzione Raggruppa si trovano altre opzioni interessanti nel menù Forme.

L'effetto di queste opzioni si può vedere nella Figura 66.

Come si vede nell'esempio, il risultato delle operazioni dipende dell'ordine in cui si trovano gli oggetti… e lasciamo perdere i risultati «particolari» ottenuti in C e D.

Il menù Forme offre anche la possibilità di uguagliare la altezza e la larghezza delle figure selezionate.

Sostituzione di colori in immagini e altri effetti speciali[modifica]

Draw non è uno strumento per modificare immagini «bitmap», e di disegno vettoriale, ma offre comunque la possibilità di applicare filtri e maschere sulle immagini inserite per ottenere effetti semplici.

Nella sezione Immagine della scheda Proprietà della barra laterale possiamo cambiare la luminosità, il contrasto, il bilancio dei colori, la trasparenza oppure passare l'immagine a scala di grigi, bianco e nero, eccetera. Tutto questo può essere anche realizzato dalla barra degli strumenti Immagine, la quale ci permette anche di applicare dei «filtri» per ottenere «effetti speciali» (a qualcuno potrebbe piacere) come invertire i colori, creare un «mosaico», eccetera.

Figura 67: Lo strumento di sostituzione di colori

Altro strumento interessante è quello di sostituzione di colori il quale «maschera» un determinato colore applicandone sopra un altro di nostra scelta. Si può attivare da Strumenti → Sostituzione colore (Figura 67).

È importante non dimenticare che questi strumenti non modificano le immagini originali ma applicano delle semplice «maschere» sopra e perciò i risultati potrebbero non essere perfetti.

Programmi come gimp, krita, mypaint[1] eccetera sono più adeguati per lavorare sulle immagini, perciò se le modifiche necessarie sono importanti sarà sempre meglio utilizzare gli strumenti appropriati.

Un altro strumento utile è quello per «ritagliare» un'immagine: nella barra degli strumenti standard (e anche in quella chiamata Immagine) si trova un bottone che attiva lo strumento per ritagliare l'immagine velocemente (si può anche attivare con un clic destro → Ritaglia). Ancora, questo strumento non ritaglia veramente l'immagine ma «nasconde» la parte non desiderata. Infatti, possiamo ricuperare la parte «tolta» semplicemente selezionando ancora lo strumento di ritaglio e stendendo la selezione.

La galleria[modifica]

Figura 68: La Galleria

Anche se lo strumento esiste da tanto, la donazione da parte di IBM di Lotus Synphony al progetto AOO portò anche il dono di una galleria completa di immagini e tavolozze di colori che furono ampiamente sfruttate sia AOO che da LibO.

Questo strumento serve a catalogare immagini e suoni, permettendo di inserirli velocemente in qualsiasi documento. Come si può vedere nella Figura 68 risulta sufficiente scegliere una categoria della lista superiore e trascinare una delle immagini della lista inferiore al documento.

È anche possibile aggiungere nuove immagini alla galleria realizzando il procedimento inverso, cioè, trascinando verso la galleria un'immagine, sia dal documento stesso oppure dal navigatore di file del sistema operativo.

Come si vede nella schermata della Figura 68 è presente il bottone Nuova categoria che ci permette di creare una categoria nuova nella quale immagazzinare le immagini da noi aggiunte al sistema.

Consigli vari[modifica]

  • Strumenti → Opzioni → LibreOffice Draw → Griglia: cambiare il valore della risoluzione, sia quella verticale che quella orizzontale, a 0,1 cm.
  • Formato → Proprietà della pagina: utilizzare lo stesso formato di pagina e i medesimi margini che verranno utilizzati nel documento Writer, così ci eviteremo i problemi legati a dover cambiare le dimensioni del grafico risultante.
  • Raggruppare sempre gli oggetti quando il disegno è pronto in modo tale di evitare modifiche casuali.
  • Quando si raggruppano gli oggetti assicurarsi che tutti gli elementi siano selezionati: soprattutto se si utilizza il mouse l'oggetto non verrà selezionato a meno che tutto si trovi all'interno dell'area di selezione.
  • Non modificare i disegni in Writer: anche se possa sembrare più semplice è sempre meglio lavorare sul documento Draw originale e copiare e incollare il nuovo risultato.
  • Gli oggetti in Draw usano anche degli stili: modificando lo stile «Predefinito» risulta perciò possibile scegliere i valori predefiniti per le linee, i colori, eccetera. Il procedimento per creare un nuovo modello predefinito in Draw è identico a quello già discusso per Writer.
  • Quando il disegno creato in Draw viene incollato in Writer conviene considerare la possibilità di fare un «Incolla speciale» (Modifica → Incolla speciale oppure Ctrl+ Shift+V) per utilizzare un formato di immagine invece di inserire un «oggetto Draw»: se il disegno è molto complesso potremmo avere problemi di lentezza in Writer. Utilizzare «metafile GDI» mi ha dato sempre ottimi risultati perché è un formato vettoriale di alta qualità
  • È anche possibile utilizzare il Navigatore per localizzare oggetti in un documento Draw, però soltanto se l'oggetto ha ricevuto un nome:

Bug 62851 - UI: Shapes without name cannot be selected via Navigator.

Draw possiede tantissimi strumenti in più di quelli descritti in questo capitolo, però parlare di tutti è al di fuori lo scopo di questo libro. Dopotutto, noi stiamo parlando di Writer.

Comunque mi auguro che queste poche pagine servano al lettore come una piccola spinta iniziale che gli permetta di introdursi senza troppi problemi in tutto il resto.

Note[modifica]

  1. http://www.gimp.org/, http://krita.org/, http://mypaint.intilinux.com/, tutti sofware libero.