LibreOffice Writer/Usare le tabelle in Writer

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

Quando si crea un documento esteso risulta importante avere strumenti che permettano di mantenere la «consistenza» della formattazione. Writer ci dà degli strumenti molto potenti per questo scopo quando parliamo della formattazione del testo, delle pagine e degli oggetti: gli stili. Ma per le tabelle… un po' meno[1] (e per gli oggetti Math non ne parliamo… però quella è un'altra storia).

Cosa fare se si vuole che il nostro documento presenti tante tabelle con formattazione complessa, ma simili tra di loro?

In questo capitolo presenteremo le diverse risposte a questa domanda.

Formattazione automatica di tabelle[modifica]

Figura 36: Il menù per inserire tabelle

Se invece di inserire una tabella con il classico bottone «Inserisci tabella» della barra degli strumenti standard andiamo su Tabella → Inserisci Tabella (oppure Ctrl+F12) ci troveremo con un menù come quello mostrato nella Figura 36.

Questo menù ci permette un controllo maggiore per creare una tabella, permettendoci pure di dargli un «nome» che sarà d'utilità per trovarla nel navigatore (parleremo sul navigatore nel capitolo D.1 a pagina 153).

Delle opzioni di questo menù, quella sulla quale parlerò in questo capitolo, si ottiene quando si preme Formattazione automatica (Figura 37) perché sarà questa a permetterci di formattare le nostre tabelle molto semplicemente.

Come si vede nella schermata esistono diversi «formati automatici» predefiniti che si possono utilizzare e per ognuno di loro si ha una serie di opzioni di configurazione nella parte bassa della finestra che ci permettono di attivare oppure disattivare un dettaglio particolare del disegno.

Per tabelle già esistenti è sufficiente collocare il cursore in una loro cella e usare il menù Tabella → Stili di formattazione automatica e scegliere il formato desiderato.

Creare un formato automatico di tabelle[modifica]

Inserendo una tabella qualsiasi e applicando manualmente la formattazione desiderata, con il cursore dentro della tabella si fa Tabella → Stili di formattazione automatica → Aggiungi. Sarà sufficiente dare un nome e il nuovo formato di tabella sarà disponibile nella lista per la prossima occasione.

Figura 37: Il menù «Formatazione automatica»

Un'altra possibilità: Testo automatico[modifica]

Se si scrive «fn» (senza le virgolette) e immediatamente si preme F3 una tabella di una riga e due colonne sarà inserita nel documento con un oggetto Math nella prima cella e una «variabile» nella seconda. Abbiamo davanti a noi un «testo automatico».

Anche se parleremo di più su questo argomento a partire della pagina 145, diremo qui che i testi automatici possono avere qualsiasi tipo di contenuto e si possono utilizzare perciò per inserire tabelle identiche tra loro: formattando una tabella secondo i nostri bisogni, la scegliamo come si fosse testo (dobbiamo prendere almeno una riga vuota prima e una dopo la tabella, altrimenti non funzionerà) e andiamo a Strumenti → Testo automatico (oppure Ctrl+F3) per assegnarle un nome e un «tasto rapido». Finalmente, con il menù del bottone Testo automatico troveremo l'opzione Nuovo. Se il «tasto rapido» era, per esempio, «tb» sarà sufficiente scrivere in qualsiasi documento tb e successivamente premere F3 per far si che Writer inserisca il testo automatico contenente la nostra tabella.

Tabulazioni e allineamento dei numeri al separatore decimale[modifica]

Abbiamo già commentato parlando dei tabulatori (pagine 19 e 62) le possibilità che offrono, tra le quali si trova l'allineamento dei numeri al separatore decimale.

Se il lettore ha tentato di inserire dei tabulatori all'interno di una tabella avrà sicuramente notato che il tasto Tab in realtà ci fa saltare da una cella a quella seguente, come si fa a inserire una tabulazione all'interno di una tabella?

Ctrl+Tab è sufficiente.

Ma è importante notare qui una incongruenza dei tabulatori all'interno delle tabelle: se nello stile di paragrafo utilizzato per il contenuto della tabella viene definito un separatore con allineamento al separatore decimale, non sarà necessario inserire il tabulatore per avere i numeri allineati, è sufficiente la definizione.

Solo una cosa: il testo nella cella non dev'essere «centrato»…

La larghezza delle tabelle[modifica]

Le tabelle in Writer occupano in modo predefinito tutta la larghezza dell'area di testo. Per cambiare questo in modo controllato è necessario fare un clic destro sulla tabella → Proprietà tabella, oppure (con il cursore in una delle sue celle) selezionare il menù Tabella → Proprietà. Nella scheda Tabella (Figura 38) troviamo le opzioni per controllare la larghezza… in grigio. Questo si deve al fatto che la larghezza della tabella è in certo modo controllata dall'opzione Allineamento: se si cambia l'allineamento da Automatico a una qualsiasi delle altre opzioni avremo un maggiore controllo.

Un dettaglio importante è che i valori della Larghezza e quelli sotto Distanza sono strettamente relazionati tra loro: quando il primo viene modificato, cambiano anche gli altri. In questo menù, l'opzione Relativo si riferisce alla modifica della larghezza della tabella «relativamente alla larghezza dell'area di testo» ed è per questo che con la spunta i valori diventano percentuali.

In questo menù la scheda Colonne ci permette di controllare la larghezza di ogni colonna individuale.

La scheda Flusso di testo ci permette di far si che la tabella inizi in una pagina o colonna propria (mettendo la spunta su Suddividi), tra altre opzioni che lascio al lettore.

Su come inserire tabelle che siano circondate da testo, parleremo nel prossimo capitolo sulle cornici, a pagina 129.

Riconoscimento del numero[modifica]

Figura 38: Configurare la larghezza della tabella

Con Tabella → Riconoscimento del numero possiamo attivare o disattivare questa proprietà. Quando questa opzione viene attivata se viene inserito nella tabella un numero che presenti tanti decimali sicuramente verrà «arrotondato» al secondo mentre se viene inserito per esempio «10 febbraio» sarà automaticamente sostituito da 10/02/16.

La formattazione della cella (se è numerica, una data, solo testo…) può essere configurata nel menù Tabella → Formato numero.

Inserire uno spazio prima di una tabella[modifica]

Premere Invio all'inizio della prima cella (quella in alto a sinistra) di una tabella darà risultati diversi a seconda di dove si trova la tabella. Se la tabella si trova in mezzo alla pagina con testo prima e dopo, Invio semplicemente aggiungerà una linea in bianco in quella cella, che dopotutto quello è il comportamento «normale» di quel tasto.

Ma se la tabella si trova nella prima linea della prima pagina oppure proprio all'inizio di una nuova sezione o immediatamente dopo un'interruzione di pagina, il tasto Invio si comporterà in un modo completamente diverso, introducendo una linea vuota prima della tabella così da riuscire a muoverla liberamente.

Avere almeno una linea vuota prima di una tabella è importante perché altrimenti non sarebbe possibile selezionarla completamente e «muoverla» da una parte a un'altra del documento: selezionando dalla linea vuota anteriore fino alla linea vuota posteriore della tabella potremo tagliarla e incollarla come qualsiasi altro contenuto del documento oppure «trascinarla» con il mouse in una nuova posizione.

Note[modifica]

  1. Almeno per il momento. Gli stili per tabelle in Writer si stanno implementando in LibO, però manca un po' per il loro arrivo (forse in 5.3).