LibreOffice Writer/Presentare dati graficamente: Chart

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

È già stato introdotto a pagina 121 come inserire tabelle e formattarle. Ma non sempre è sufficiente presentare i dati come liste di numeri, a volte bisogna dargli formato grafico.

In questo capitolo parleremo su come riuscire a fare questo, sia con gli strumenti propri di LibO sia con programmi esterni.

Creare un grafico direttamente da Writer[modifica]

Figura 69: Modificare i dati predefniti del grafco d'esempio

Inserisci → Grafico creerà, tramite la componente Chart di LibO, un colorito grafico a colonne nel punto dove si trovava il cursore. Questo grafico può essere modificato senza problemi tanto per cambiare i dati che presenta come per modificare le sue proprietà. Inserito in questo modo, il grafico dovrebbe essere in «modalità edizione», ma se si fa clic fuori diventerà un semplice oggetto all'interno del nostro documento Writer: un doppio clic ci permetterà di tornare agli strumenti per modificarlo.

Con Visualizza → Tabella di dati (o il corrispondente bottone della barra degli strumenti Formattazione) si presenterà una semplice finestra dove potremo modificare i valori utilizzati per costruire il grafico appena inserito.

Come si può vedere è possibile avere voci di testo per classificare i dati, si possono aggiungere nuove righe e colonne, eccetera. I bottoni della parte superiore della finestra sono:

  1. Inserisci riga
  2. Inserisci serie (colonne di dati)
  3. Inserisci colonna di testo (per classificare i dati)
  4. Eliminare riga
  5. Eliminare serie
  6. Sposta la serie a destra
  7. Sposta la riga in basso
Figura 70: Lavorare con le categorie dei dati

Lasciando alcuni voci di testo vuote potremo «raggruppare» colonne di dati come si vede nella Figura 70.

Figura 71: Scegliere il tipo di grafico

Ma potremo certamente non essere interessati al classico istogramma. Per avere altri tipi di grafici, prima di modificare la tabella dei dati dobbiamo andare a Formato → Tipo di grafico dove vedremo quello presentato dalla Figura 71.

Non c'è molto da dire su questo dialogo: scegliendo il tipo di grafico a sinistra avremo diversi opzioni da scegliere a destra, la possibilità di effetti «3D», eccetera.

Praticamente l'unico punto importante da tener presente è che, a meno che non venga scelto il tipo XY (Dispersione), le «categorie» saranno considerate come testo anche se ci sono numeri lì. Infatti: se vogliamo un tradizionale grafico dove i valori di X rappresentano veri numeri e non semplici etichette di larghezza uniforme dobbiamo scegliere «XY (dispersione)».

Dopo aver scelto il tipo di grafco dispersione, sarà necessario fare doppio clic sull'asse X del grafco e nella scheda Numeri scegliere il formato numerico.

Con un clic sui diversi elementi del grafico come i suoi assi, i punti, eccetera risulta possibile modificare le loro proprietà utilizzando le opzioni presenti nella barra laterale.

Sia dalla barra laterale che dal menù Inserisci o dal corrispondente bottone della barra degli strumenti di formattazione è possibile aggiungere un titolo al grafico, decidere dove va collocato il quadro con la legenda (oppure se non risulta necessario), eccetera.

Figura 72: Aggiungere barre di errore al grafico

Per aggiungere barre di errore ai nostri grafici di dispersione dobbiamo andare a Inserisci → Barre errore Y. Se lì viene scelto, come mostrato nella Figura 72, Dalla tabella dati, ritornando sulla tabella ci troveremo con nuove colonne per ogni serie, aspettando gli errori in su e in giù di ogni punto.

Creare un grafico da una tabella esistente in Writer[modifica]

È anche possibile creare un grafico a partire da una tabella già esistente in un documento Writer.

Selezionando la parte della tabella che ci interessa (soltanto qualche colonne oppure tutta) usiamo Inserisci → Grafico e vedremo comparire un primo grafico con i nostri dati insieme a un «assistente» che ci farà da guida per configurarlo.

Figura 73: Creare un grafico da una tabella in Writer

Nel secondo passo, Area dati, si trovano le opzioni, spuntate in modo predefinito, Prima riga come didascalia e Prima colonna come didascalia. Queste opzioni faranno si che la prima riga e la prima colonna della tabella siano prese come «etichette» e perciò vengano ignorate nella realizzazione del grafico. Se invece la prima riga e la prima colonna contengono dei dati che vogliamo rappresentare dobbiamo togliere la spunta a quelle opzioni.

Le altre opzioni sono chiare e perciò non andremo in più dettagli.

Risulta importante notare che il grafico così creato sarà associato in modo dinamico ai dati della tabella, perciò qualsiasi modifica di questi dati sarà presentata automaticamente nel grafico corrispondente.

Creare il grafico in Calc[modifica]

Il principale vantaggio di lavorare in Calc è che risulta più semplice gestire i dati che vogliamo rappresentare: le tabelle in Writer sono utili per presentare i dati, non per lavorare su di loro.

Non parlerò (non potrei farlo) sul funzionamento di Calc qui, soltanto dirò che nel selezionare i dati e scegliere di rappresentarli si presenta lo stesso assistente presentato nella parte precedente.

Completato il grafico in Calc, potremo selezionarlo con un clic, copiarlo e incollarlo in Writer.

Risulta conveniente non scartare il documento Calc per riuscire così a fare qualsiasi modifica che possa essere necessaria, copiando e incollando nuovamente il risultato.

Grafici generati in programmi esterni[modifica]

Il modo più sicuro di includere grafici realizzati in programmi esterni è creare da questi un'immagine, preferibilmente in formato SVG, e salvarla in disco prima di inserirla in Writer con Inserisci → Immagine.

Non consiglio di copiare e incollare direttamente dagli altri programmi perché posteriormente potrebbe essere necessaria la presenza di quei programmi per visualizzare l'immagine, il che porta problemi nel momento di muovere il documento ad altri sistemi.

Nella Figura 74 si vede un esempio di un grafico realizzato anni fa in un programma chiamato SciDAVis[1] (adesso utilizzo LabPlot[2] per questi lavori).

Punti extra per chi riconosce la fisica dietro il grafico…

Figura 74: Un vecchio grafco in formato SVG creato in SciDAVis

Note[modifica]

  1. http://scidavis.sourceforge.net/
  2. https://labplot.kde.org/