LibreOffice Writer/Configurare la correzione ortografica

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

In questo capitolo vedremo i principali problemi che possono presentarsi riguardo la correzione ortografica (e grammaticale) e come possiamo affrontarli.

Dove guardare se ci sono problemi[modifica]

La prima cosa da guardare è la barra di stato nella parte bassa della finestra di Writer dove si vedono, da sinistra verso destra, la pagina, il conteggio delle parole e i caratteri, lo stile di pagina nella posizione del cursore e la lingua impostata sul testo: se la lingua è sbagliata o, peggio ancora, dice «nessuno» risulterà chiaro perché il correttore ortografico non sta funzionando.

Se la lingua è quella giusta si dovrà controllare che il «controllo ortografico automatico» sia attivo. Per questo risulta sufficiente guardare sul menù Strumenti.

Se ancora non funziona, bisogna verificare che il dizionario sia presente! A partire da Strumenti → Opzioni → Impostazione della lingua → Lingue, dobbiamo controllare la lista delle «lingue predefinite per i documenti»: se il dizionario risulta correttamente installato a sinistra del nome della lingua dovremo vedere un «ABC ». Se questa icona non è presente il dizionario ✓ non è disponibile: di seguito vedremo il modo di risolvere questo problema. Se la lingua non è quella giusta si deve guardare nella definizione degli stili utilizzati, sia quelli di paragrafo che quelli di carattere e verificare che non ci sia formattazione diretta sul testo.

Come già commentato nel capitolo sugli stili e i modelli, sia gli stili di paragrafo che quelli di carattere permettono di definire la lingua del testo (scheda Carattere). Lo stile di paragrafo chiamato «Predefinito» è il primo da controllare perché tanti stili dipendono da lui. Se la configurazione di questo stile è giusta, si dovranno controllare gli altri (sia di paragrafo che di carattere) utilizzati sul documento.

Consiglio vivamente di NON utilizzare il menù Strumenti → Lingua, oppure Formato → Carattere → scheda Carattere per cambiare la lingua del testo: la formattazione diretta porta sempre dei problemi.

Figura 83: Voce del menù della lingua per ripristinare il valore predefinito

Infatti, se la lingua viene impostata come formattazione diretta, quando si sceglie di tornare alla «formattazione predefinita» (Ctrl+M) l'impostazione della lingua non viene modificata. Se per qualsiasi motivo la lingua di una porzione del testo viene modificata come formattazione diretta, il metodo più semplice per ripristinare il valore predefinito è selezionare il testo e fare clic sul nome della lingua utilizzata che si vede nella barra di stato (vi ricordate che era il primo posto da controllare?): tra le opzioni disponibili si trova proprio quella di ripristinare la lingua predefinita, come mostrano nella Figura 83.

Come vedete, utilizzare formattazione diretta risulta sempre una cattiva idea…

Il dizionario non risulta installato![modifica]

In LibreOffice i dizionari vengono installati come estensioni, le quali si trovano elencate nella pagina delle estensioni della quale abbiamo parlato nel capitolo precedente. Alcune di queste estensioni vengono installate automaticamente con il programma, mentre per gli utenti Linux sarà molto più semplice l'utilizzo dei repository del software.

IMPORTANTE: Il dizionario deve coincidere con la lingua del testo completamente: se viene installato il dizionario di «spagnolo di España» ma la lingua del testo è configurata come «spagnolo del Venezuela» la correzione non funzionerà.

Perché il sistema è così?[modifica]

Il sistema è molto potente e filessibile perché ci permette di:

  1. Avere una lingua predeterminata, per esempio l'italiano, semplicemente indicata nel modello predefinito
  2. Scrivere paragrafi in una seconda lingua, per esempio lo spagnolo, velocemente con gli stili di paragrafo
  3. Inserire citazioni in una terza lingua, diciamo l'inglese, grazie agli stili di carattere

il tutto automaticamente riconosciuto dal correttore ortografico…

Dizionario di sinonimi[modifica]

Figura 84: Sinonimi sul clic destro

Come si può vedere nella Figura 84, Writer ci offre la possibilità di utilizzare il dizionario di sinonimi dal menù contestuale (clic destro sulla parola).

Risulta possibile arrivare alla versione completa del dizionario dei sinonimi sia con un clic nell'ultima voce mostrata nella Figura 84 oppure dal menù Strumenti → Sinonimi (Ctrl+F7).

Correttore grammaticale?[modifica]

Writer offre la possibilità di utilizzare correttori grammaticali esterni. In questo momento l'estensione più completa è Language- Tool.

È importante notare che qualsiasi correttore grammaticale avrà limitazioni e che al momento nulla può sostituire un umano che conosca la lingua, ma per quegli errori semplici che sfuggono al correttore ortografico (parole duplicate, mancanza di un parentesi di apertura o chiusura, le maiuscole all'inizio di un periodo…) può risultare di utilità.

La sillabazione ha sbagliato![modifica]

Creare un dizionario è molto di più che dare una lista di parole ed è proprio per questo che risulta un lavoro difficile: declinazioni, coniugazioni dei verbi, parole composte… una lista semplice sarebbe infinita, generando un file di proporzioni epiche e pertanto inutilizzabile.

Stabilire delle regole per costruire o dividere parole risulta dunque fondamentale per avere un dizionario efficiente, ma siccome le lingue umane sono complesse, lo saranno anche queste regole e perciò sicuramente ci saranno, ogni tanto, degli errori. Per esempio, nella separazione sillabica.

Se una parola viene automaticamente divisa dove non deve l'unica cosa da fare sarà indicare a Writer il punto dove vogliamo la divisione. Per questo, collocando il cursore nel punto giusto, Inserisci → Marcatore di formattazione → Trattino morbido, oppure premendo Ctrl+-. Questo trattino morbido si vedrà in Writer con uno sfondo grigio per indicare che è un trattino «speciale» ma sarà visualizzato nel documento stampato (o esportato in PDF) solo quando sia necessario.

Nota bene[modifica]

  • Dopo aver installato, eliminato oppure aggiornato un dizionario è necessario riavviare completamente LibO. Questo implica chiudere tutte le applicazioni (Writer, Calc, Draw… tutto), compreso, se fosse attivo, il Quick- Start nell'area di notifica del sistema.
  • Come già detto, per gli utenti Linux è più semplice installare i dizionari dai repository di sofware della nostra «distro».
  • Controllate le opzioni che si trovano sotto Strumenti → Opzioni → Impostazione della lingua → Linguistica: ci sono alcuni dettagli interessanti…