LibreOffice Writer/Configurare l'interfaccia di LibreOffice

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

Se dobbiamo lavorare per tante ore davanti allo schermo meglio far sì che tutto ci risulti bello, ma soprattutto comodo.

Ed è proprio per questo che il presente manuale inizia parlando su come personalizzare l'interfaccia grafica di Writer, sapendo pure che solo quando il lettore avrà un dominio del programma saprà qual è la forma più conveniente di configurarlo.

Chiedo perciò al lettore di non avere paura di sperimentare cambiando la configurazione più volte man mano che avanza in questo libro.

Anche se per anni l'interfaccia grafica, e questo è un problema ereditato dal vecchio progetto OOo, non è stata proprio l'aspetto più curato del programma si deve dire che soprattutto nelle versioni 5.x LibO ha iniziato una importante campagna per migliorare le opzioni predefinite e gli strumenti offerti.

Ma al di là di questo l'interfaccia grafica attuale di LibO può essere configurata fino a livelli di dettaglio che pochi programmi si possono permettere.

Infatti, anni prima che altri programmi iniziassero a offrire barre degli strumenti che cambiano da sole (tante volte generando disperazione tra gli utenti), OOo, il «nonno» di LibO offriva già barre degli strumenti contestuali che si presentano solo quando sono necessarie, pannelli che possono occultarsi persino automaticamente, dava la possibilità di modificare quasi ogni elemento dell'interfaccia grafica... insomma, offriva e offre una tra le interfacce grafiche più flessibili e adattabili che ci siano.

Forse con opzioni predefinite un po' brutte, bisogna dirlo, ma flessibile.

In sintesi, il problema dell'interfaccia grafica di Writer e LibO in generale non è la mancanza o l'eccesso di caratteristiche. Quello che stava male non era la «faccia» di Writer ma il suo «trucco».

In questo capitolo ci occuperemo precisamente di questa configurazione: essere a nostro agio nell'ambiente di lavoro ci aiuterà a lavorare.

Tasti di scelta rapida[modifica]

Figura 2: Confgurare i tasti di scelta rapida in LibO 5.2

È possibile accedere a quasi tutte le funzioni di Writer (e di LibO in generale) tramite i tasti di scelta rapida, i quali si possono configurare molto semplicemente.

In Strumenti → Personalizza → scheda Tastiera (Figura 2) è possibile configurare i tasti di scelta rapida a nostro piacere o semplicemente vedere quali sono definiti.

Il processo è il seguente: dopo aver selezionato la Funzione che si vuole configurare (filtrando preventivamente per Categoria) si cerca una combinazione di tasti libera che ci convenga, la si sceglie e si preme Cambia.

È importante notare che se la funzione scelta ha già una combinazione di tasti assegnata, quando viene selezionata il menù «farà un salto» alla combinazione esistente. In questi casi risulta più conveniente selezionare prima la funzione e dopo la nuova combinazione.

Come può confermare il lettore quasi tutto è disponibile per ricevere una combinazione di tasti e questo include non solo le funzioni standard ma anche qualsiasi stile, macro... quasi tutto.

I tasti di scelta rapida usati dal sistema operativo hanno precedenza su quelli usati da Writer. Per esempio, in sistemi Linux la combinazione Ctrl+F2 generalmente viene utilizzata dal sistema per muoversi alla seconda «scrivania virtuale», perciò la funzione assegnata da Writer per questa combinazione (Altri campi) non verrà attivata: sarà necessario dunque scegliere un'altra combinazione.


Barre degli strumenti[modifica]

Figura 3: Ancorare una barra degli strumenti

Oltre alle barre degli strumenti «normali» (dove ci sono le icone per salvare o aprire documenti, annullare o ripristinare azioni, inserire tabelle...) c'è una lunga lista di altre barre in Visualizza → Barre degli strumenti.

Alcune di queste barre sono «contestuali»: compaiono soltanto quando necessarie. Esempi di questo tipo di barre contestuali sono: quella per configurare le tabelle, gli elenchi numerati o puntati, quelle relative alle immagini, agli oggetti... Queste barre saranno visibili soltanto quando verrà selezionato un elemento sul quale si può applicare il suo contenuto.

Il sistema è molto utile perché non ricarica l'interfaccia grafica mostrandosi solo quando necessario. Inoltre, nelle ultime versioni di LibO molte di queste barre compaiono ancorate nella parte bassa della finestra di scrittura e perciò non disturbano. Questo non è stato sempre così e infatti ce ne sono ancora di barre non contestuali che una volta attivate compaiono nel bel mezzo della finestra sulla quale stiamo lavorando, il che non risulta il massimo della comodità.

Quest'ultimo problema si risolve molto semplicemente: prendendo la barra con il puntatore del mouse e semplicemente spostandola in uno dei bordi della finestra. Non appena compare un rettangolo tratteggiato (Figura 3) possiamo rilasciarla e rimarrà «ancorata» lì.

Si deve tener presente che se la barra degli strumenti contiene dei menù a tendina con testo (per esempio, il seletore di font) non funzionerà bene quando si trova in posizione verticale.


Se si vuole non vedere più una barra contestuale particolare, quando compare è sufficiente andare a Visualizza → Barre degli strumenti per disabilitarla.

Si può modificare il contenuto delle barre degli strumenti per aggiungere o togliere icone, o addirittura si possono creare nuove barre a volontà dal menù Strumenti → Personalizza → scheda Barra degli strumenti. Lì si può selezionare la barra degli strumenti che deve essere modificata, attivare, disattivare, cambiare l'ordine o persino modificare le icone. Siccome tutto questo è molto semplice da utilizzare parlerò soltanto di una opzione molto interessante, il menù Salva in: con quest'opzione è possibile creare delle barre degli strumenti che appartengano soltanto a un documento.

Queste barre «locali» saranno disponibili soltanto nel documento nel quale sono state salvate. Questo potrebbe essere utile per creare modelli speciali che richiedano accesso rapido a determinati strumenti o macro, oltre a permettere di portare il documento o il modello in questione in altri sistemi senza perdere questi elementi dell'interfaccia grafica da noi creati.

Barra laterale[modifica]

La barra laterale è un elemento grafico molto interessante che mette a portata di mano gli strumenti più comunemente utilizzati.

Figura 4: La barra laterale in Writer inserite, per attivare gli elenchi numerati o puntati, gli oggetti grafici, eccetera.

Come si vede nella schermata della Figura 4 la barra laterale ci propone una sorta di «contenitore verticale» che offre diversi pannelli, tutti accessibili tramite i bottoni alla destra della barra stessa. Ognuno di questi pannelli risulta a sua volta diviso in una o più «sezioni», ognuna offre diversi strumenti classificati per «temi» (paragrafo, carattere, immagine...).

In Writer e per la versione 5.2 si dispone (alcuni estensioni potrebbero aggiungerne altri) di quattro pannelli che corrispondono ai quattro bottoni, iniziando dal secondo e andando verso il basso, si vedono a destra della barra laterale:

  1. Proprietà: (mostrato nella schermata) qui troviamo raggruppati gli strumenti per modificare il testo o le immagini
  2. Stili e formattazione: lo strumento per gestire gli stili in Writer. Torneremo su questo a partire della pagina 49.
  3. La Galleria: LibO offre un gran numero di immagini pronte da inserire in qualsiasi documento. Parleremo di questo a pagina 216.
  4. Il Navigatore: Uno strumento fondamentale che ci permette non solo di muoverci velocemente per tutto il documento, ma anche di amministrare il suo contenuto cambiando l'ordine dei capitoli o il loro livello. Parleremo di questo strumento a partire della pagina 153.

Il primo tasto (in realtà, un menù a tendina) che abbiamo saltato serve per configurare la barra laterale, scegliendo quali pannelli mostrare (mettendo o togliendo la spunta corrispondente sotto «personalizzazione»), per «sganciare» la barra per farla diventare una finestra flottante, eccetera.

Le «sezioni» a disposizione in ogni pannello dipendono del contenuto selezionato. Nella Figura 4 si vedono gli strumenti per il testo, però se si seleziona un'immagine ci saranno altri strumenti per modificare la sua posizione, l'ancoraggio, la trasparenza, il bilanciamento dei colori e molto di più, come si può intravedere nella Figura 5.

La barra laterale può essere ancorata soltanto a destra o sinistra della fnestra di LibO, non può andare nei bordi superiore o inferiore: la barra laterale è, appunto, laterale...


Oltre a utilizzare il menù di configurazione, per sganciare la barra laterale è sufficiente prenderla con il puntatore del mouse nella parte superiore (dove si può leggere il titolo del pannello in uso) e semplicemente trascinarla allontanandola dalla sua posizione. Per ancorarla nuovamente è sufficiente trascinarla in uno dei lati della finestra del programma in modo simile a quello già visto per ancorare una barra degli strumenti qualsiasi. Una terza opzione per sganciare o ancorare è fare Ctrl più doppio clic su una parte libera della barra.

Figura 5: Proprietà d'una immagine dalla barra laterale

Per disattivare (o attivare, se si prova nostalgia) la barra laterale: Visualizza → Barra laterale.

Quando la barra laterale è ancorata a uno dei lati della finestra attiva, in mezzo al bordo libero c'è un sottile bottone più scuro visibile nelle figure 4 e 5: con un clic lì tutta la «scatola» contenente la barra laterale si nasconderà, chiudendosi su di sé. L'unico che rimarrà visibile sarà una stretta barra con quel bottone, questa volta invertito, che ci permetterà di riaprirla.

E adesso un bel segreto incredibilmente utile: se invece di fare clic sul bottone per aprire si fa clic in qualsiasi altro punto della stretta barretta, la barra laterale si aprirà comunque, però si chiuderà automaticamente non appena il cursore ritorna al documento. Cioè, la barra laterale può nascondersi automaticamente quando non risulta più necessaria.

Questa capacità di nascondersi automaticamente è di una comodità incredibile: gli strumenti offerti dalla barra laterale sono veramente utili e conviene tenerli sempre a portata di mano, ma non si usano sempre.

Un altro modo di nascondere e mostrare la barra laterale è fare clic sul bottone del pannello attivo. Per esempio, se è attivo l'editore degli stili e formattazione e facciamo clic sul bottone che lo rappresenta, la barra si chiuderà su di sé lasciando in vista soltanto i bottoni che rappresentano i pannelli. Con un clic su qualsiasi bottone, si aprirà nuovamente.

Altri pannelli e barre[modifica]

Salvo che per il pannello Proprietà che è nuovo, gli altri pannelli esistevano già come quadri indipendenti. Con il passare delle versioni tutti questi quadri, eccezione fatta (almeno per il momento) per il Navigatore (del quale parleremo nel capitolo D.1), sono stati eliminati per privilegiare la barra laterale.

Ci sono però altri pannelli: il pannello con le miniature di pagina in Draw del quale parleremo nel capitolo D.6, per esempio, o la sorgente di dati che sarà brevemente discussa a pagina 280.

Altri strumenti si presentano come finestre uniche che non possono ancorarsi, per esempio lo strumento per cercare e sostituire testo del quale parleremo a partire della pagina 227, ma verosimilmente anche questi strumenti saranno alla fine incorporati alla barra laterale.

Una barra di grande importanza è la «barra di stato», la quale può attivarsi o disattivarsi da Visualizza → Barra di stato.

Questa barra di stato si trova sempre nella parte inferiore della finestra di lavoro in tutte le componenti di LibO e presenta informazioni importanti. Per esempio, in Writer si presenta, in questo ordine:

  1. il numero di pagina
  2. il numero di parole e caratteri nel documento o nella selezione
  3. lo stile di pagina utilizzato nella posizione del cursore: un clic sul nome ci permetterà di modificare lo stile
  4. la lingua del testo sul quale si trova il cursore: un clic darà diverse opzioni che vedremo più avanti
  5. un bottone (non molto visibile) per cambiare il metodo d'inserimento (normale o sovrascrittura)
  6. un bottone con un menù a tendina per selezionare il modo in cui si seleziona il testo: standard (quello di tutta la vita), selezione estesa (dalla posizione del cursore fino a dove si fa clic), selezione con aggiunta (se dopo aver scelto qualcosa in selezione standard si fa una aggiunta, la seconda selezione si aggiungerà alla prima) e selezione a blocchi (un blocco rettangolare di testo)
  7. un'icona che indica se il documento è stato salvato o no
  8. un piccolo spazio quasi invisibile che indica se il documento è stato firmato digitalmente o meno e che con un doppio clic ci permette di accedere all'opzione di firma digitale (non parleremo di questo nel presente libro)
  9. uno spazio che ci darà diversi tipi di informazioni quali il livello della numerazione se il cursore si trova su di un elenco numerato o titolo di capitolo, dando accesso alle proprietà di questa numerazione
  10. lo strumento per controllare il livello dello zoom, se si presentano due pagine o solo una, eccetera.

Colori e icone[modifica]

Su Strumenti → Opzioni → LibreOffice → Colori applicazione si possono modificare i colori dell'interfaccia grafica. Per esempio risulta possibile modificare il colore utilizzato da Writer per mostrare le interruzione di pagina, i limiti del testo, i bordi degli oggetti, il colore del bordo delle sezioni... tutti i colori del programma, non del documento.

Per un aspetto più... come definirlo personalizzato da tempo LibO offre la possibilità di utilizzare i temi di Firefox. È possibile configurare quest'opzione in Strumenti → Opzioni → LibreOffice → Personalizzazione, ma non chiedermi come funziona perché mi tengo sempre lontano da queste cose.

In Strumenti → Opzioni → LibreOffice → Vista è possibile selezionare i diversi temi delle icone disponibili e la dimensione nella quale devono mostrarsi. C'è la possibilità di aumentare la scala dell'interfaccia utente e modificare la trasparenza della selezione di testo.

Vi lascerò giocare con le opzioni presenti.

Per ultimo, in Visualizza → Margini del testo si può scegliere se vedere o meno i quattro angolini che tentano d'incorniciare l'area di testo durante la modifica del documento mentre Visualizza → Contorni tabella permette di fare lo stesso con i bordi delle tabelle.

Qui mi fermerò un momento per segnalare uno di quei cambiamenti in LibO che non mi piacciono per nulla. Chiedo scusa anticipatamente per la piccola diatriba e autorizzo il lettore a saltare questi paragrafi e passare direttamente alla prossima sezione.

Nelle versioni di LibO anteriori alla 4 (e questo risulta ancora così in AOO), invece di quei, diciamo inutili angolini veniva mostrata una magnifica linea grigia continua che separava senza dubbi l'area del testo dai margini della pagina, linea che era d'enorme aiuto per collocare oggetti senza paura di «sforare i margini». Per qualche motivo che mi sfugge uno sviluppatore pensò che quella linea era «vecchia» e la cambiò con gli angolini oggetto di questa diatriba dando luogo a un tormentone epico (lascio al lettore il dubbio piacere di cercare nelle mailinglist del progetto la discussione). Lo sviluppatore non voleva fare marcia indietro, però dopo lunga battaglia accettò di reintrodurre la linea continua attivandola con l'icona... dei caratteri non stampabili! Qual è la relazione tra i caratteri non stampabili e i limiti dell'area di testo è qualcosa che mi sfugge, specialmente considerando che con un uso appropriato degli stili (giustamente di quello che si parla in questo libro) i caratteri non stampabili risultano praticamente inutili.

Bug 74386 - UI: Provide obvious way to turn full-page text boundaries on/of, independent from Show non printing characters


Insomma, almeno i caratteri non stampabili risultano, nelle ultime versioni del programma, più gradevoli e non disturbano tanto l'attenzione... andiamo avanti.

Finestre e più finestre[modifica]

Per tutti coloro che preferiscono i programmi di videoscrittura che permettono di lavorare «senza distrazioni», LibO offre una modalità «a schermo intero» dove si vede soltanto il bottone per uscirne. Per attivare questa modalità, Visualizza → Schermo intero oppure Ctrl+ Shift+J. In questa modalità è possibile attivare la barra degli strumenti «Trova» con Ctrl+F.

Writer lavora con «un documento per finestra»: aprire due documenti significa avere due finestre diverse per Writer.

La lista di tutte le finestre aperte si trova nel menù Finestra, e potremo usarla per passare da un documento all'altro. Lì si trova anche un'opzione dal criptico nome Nuova finestra: scegliendola si aprirà una seconda finestra con lo stesso documento sul quale stiamo lavorando, così potremo vedere ed anche lavorare su due parti diverse in forma simultanea.

Nuovo in 5.2: configurare i menù di contesto[modifica]

A partire di LibO 5.2 è disponibile una nuova opzione: Strumenti → Personalizza → scheda Menu di contesto. Questo nuovo strumento ci permette di modificare il contenuto dei menù che si ottengono facendo clic destro su qualcosa all'interno di LibO.

Fatte le presentazioni, mi auguro che il lettore avrà già tutto configurato a suo piacere, perché a partire del prossimo capitolo inizia la vera avventura di questo libro.

E sì, lo so che non ho parlato della possibilità di modificare i menù principali del programma, però a questo punto il lettore dovrebbe riuscire a farlo da solo... forza!