LibreOffice Writer/Organizzare e numerare i capitoli

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

Prima di iniziare è importante sottolineare che questo capitolo non sarà soltanto sulla numerazione ma principalmente sulla struttura: se si lascia l'opzione di numerazione in «nessuna» i capitoli non saranno numerati ma risulteranno comunque «organizzati».

Quello che segue ci permette di avere un indice generale automatico, realizzare riferimenti incrociati... e, certamente, di avere una numerazione, questo però è soltanto una parte della storia.

Mano all'opera, dunque, che gli strumenti presentati in questo capitolo sono veramente interessanti.

Dare un «livello» agli stili[modifica]

Abituati ad altri programmi tanti utenti nuovi di Writer utilizzano elenchi numerati per numerare i capitoli, azione che porta ad avere tantissimi problemi di consistenza nella formattazione.[1]

Il metodo utilizzato da Writer può sembrare all'inizio un tanto strano e infatti è lontano della perfezione, però risulta così semplice che abituarsi non è un problema.

Tutto (o quasi tutto, più in giù torneremo su questo «quasi») quello che serve si trova sotto Strumenti → Numerazione struttura. Nella scheda Numerazione si trova una lista di dieci «livelli» che costituiranno la struttura del nostro documento. Selezionando ogni livello è possibile assegnare uno stile di paragrafo, una numerazione (se ci serve) e uno stile di carattere da applicare su quella numerazione. Per i livelli più bassi (dal 2 in avanti) si possono scegliere i livelli da mostrare nella numerazione (l'opzione chiamata Mostra sottolivelli), ottenendo per esempio una numerazione come segue:

1 1.1

1.2

1.2.1

2 2.1

2.2

...

I punti o altri caratteri utilizzati per separare i numeri si possono gestire in Separatore, Davanti/Dietro.

Figura 19: Configurare il livello di uno stile

Ecco fatto. Gli stili assegnati a ogni livello in questo dialogo saranno utilizzati automaticamente per generare l'indice generale del documento (Inserisci → Indice generale e indice analitico → Indice generale, indice analitico o bibliografia).

Una nota importante: nella scheda Posizione di questo dialogo si può definire come sarà la separazione tra il numero e il testo del titolo. Dato che il modo di configurare questa numerazione è identico a quella utilizzata per gli elenchi numerati/puntati non dirò di più qui, invitando il lettore a leggere il capitolo C.2, Elenchi numerati e puntati, a pagina 101.

È importante notare che risulta possibile avere un numero arbitrario di stili di paragrafo per ogni livello, il che ci permette di costruire strutture più ricche e complesse. Un uso possibile sarebbe la definizione di appendici che copino la struttura dei capitoli mantenendo pertanto lo stesso schema di livello ma con una numerazione indipendente.

Questi «stili addizionali» per ogni livello non si configurano però in Strumenti → Numerazione struttura ma direttamente sulla definizione dello stile di paragrafo in considerazione sulla scheda Struttura e numerazione. La Figura 19 indica come si sceglie il livello desiderato.

E qui arriviamo al «quasi tutto» di sopra: configurando i livelli in questo modo non sarà possibile definire uno schema di numerazione come quello degli stili «di base» per ogni livello. Se ci serve numerare anche questi stili aggiuntivi, nella stessa scheda dove si definisce il «livello» si dovrà scegliere di applicare uno stile di lista... proprio quello che abbiamo detto al principio del capitolo che conveniva evitare.

E sì, la vita è crudele.

Nella sezione B.3.1.5, Stili di elenco a pagina 68 si parla su come utilizzare gli stili di elenco.

Numerazione «continua»[modifica]

Writer non permette di realizzare in forma diretta uno schema di numerazione come il seguente:

1 1.1

1.2

2 2.3

...cioè, uno schema nel quale al cambiare del valore di un «livello» NON viene reinizializzata la numerazione di quello successivo. Fortunatamente si può «simulare» questa disposizione.

Semplicemente si numerano i paragrafi del livello superiore (per esempio, la «Parte») con Strumenti → Numerazione struttura mentre lo stile di secondo livello (il «Capitolo») viene numerato con uno stile di lista nella scheda Struttura e numerazione.

Note[modifica]

  1. Molti dei quali sono pure presenti in quei programmi.