LibreOffice Writer/Configurare l'indice generale

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

Come già riferito parlando della numerazione capitoli (Organizzare e numerare i capitoli), tanto gli stili di paragrafo configurati nel dialogo Strumenti → Numerazione e struttura che quelli con un «livello» assegnato nella scheda Struttura e numerazione saranno inclusi automaticamente nell'indice (Inserisci → Indice generale e indice analitico → Indice generale, indice analitico o bibliografia): in questo capitolo vedremo il modo di configurare questo indice.

Precauzione iniziale[modifica]

Risulta importante notare che se un indice viene inserito nella prima riga di un documento, o nella prima riga di una sezione, o proprio dopo di un'interruzione di pagina non sarà possibile muoverlo o inserire testo prima. È conveniente lasciare almeno una riga in bianco prima dell'indice.

Se l'indice è stato introdotto in quelle regioni e vogliamo spostarlo, ci sono due opzioni, o viene cancellato e ricostruito più «in giù» o si fa quello che viene descritto di seguito:

  1. clic destro sull'indice → Modifica l'indice analitico o indice generale → togliere la spunta su Protetto contro modifiche manuali → OK
  2. Con il cursore al principio dell'indice premere Alt+ Invio due volte: una riga in bianco comparirà prima dell'indice
  3. Adesso è possibile ripristinare l'opzione tolta nel punto 1: ci sarà un paragrafo vuoto prima dell'indice.

Inserire un indice[modifica]

Figura 21: Creare un indice

Quando viene inserito un indice si presenta un quadro come quello presentato nella Figura 21.

A sinistra si trova uno schema di come si vedrà l'indice con quello che viene scelto a destra.

In questo capitolo parlerò maggiormente sugli indici generali, anche se molto di quello che qui si commenta si applica pure agli altri tipi di indici. Perciò anche se farò un breve commento alla fine e ci sarà un capitolo dedicato all'indice bibliografico (a pagina 169), lascerò al lettore «giocare» con gli altri tipi di indici possibili, i quali possono essere scelti con il menù a tendina Tipo (indice delle illustrazioni, tabelle, oggetti…).

Scheda Indice analitico o indice generale[modifica]

Nella prima scheda, chiamata Indice analitico o indice generale, si può cambiare il nome dell'indice, scegliere il suo tipo,[1] permettere o no che il suo contenuto sia manualmente modificato e su quale parte del documento questo indice prende l'informazione (tutto il documento o solo il presente capitolo).

Writer considera come «capitolo» il livello 1 della numerazione dei capitoli, non è possibile decidere che inizi da un altro livello: se la struttura del documento fa si che i nostri «capitoli» siano il livello 2 e vogliamo indici parziali per ogni capitolo, ci saranno dei problemi.

L'unica «soluzione» per questo è infati cambiare la struttura del documento par far si che i capitoli siano nel livello 1.

Bug 94218 - footnote numbering per chapter: defne outline level that resets numbering

L'ultima parte di questa prima scheda dice all'indice da dove prendere l'informazione:

Struttura
Si riferisce ai livelli configurati in Strumenti → Numerazione struttura o nella scheda Struttura e numerazione dello stile di paragrafo (più informazioni a pagina 81).

Come già indicato, è possibile assegnare un numero arbitrario di stili di paragrafo a ogni livello semplicemente modificando lo stile di paragrafo corrispondente nella scheda Struttura e numerazione e scegliendo il livello in Livelli di struttura. L'indice incorporerà anche questi stili di paragrafo.

Figura 22: Scegliere stili aggiuntivi per l'indice
Stili aggiuntivi
Ci permette di includere nell'indice stili di paragrafo senza un livello assegnato. Attivando questa opzione e aprendo il corrispondente quadro (con il bottone Assegna stili), ci troviamo con quello illustrato nella Figura 22: scegliendo uno stile di paragrafo qualsiasi possiamo utilizzare i bottoni in basso a sinistra per farli corrispondere al «livello» desiderato
Contrassegni e indice
Include il testo contrassegnato dall'utente con Inserisci → Indice generale e indice analitico → Voce di indice.

Scheda Voci[modifica]

Figura 23: Configurare la struttura dell'indice

Nella scheda Voci (Figura 23) viene definita la struttura di ogni linea dell'indice.

Scegliendo un livello si può definire quale contenuto ci sarà modificando quello che offre la riga Struttura. Ogni «bottone» nella riga rappresenta una parte dell'informazione che sarà inclusa nell'indice in modo automatico.

Per cancellare un elemento presente è sufficiente selezionarlo e premere DEL oppure si può aggiungere contenuto facendo clic in uno degli spazi vuoti e premendo qualcuno dei bottoni che si trovano sotto (numero di capitolo, testo —il titolo—, una tabulazione, il numero della pagina). È anche possibile scrivere dei testi semplici (per anteporre la parola «Capitolo», per esempio, o creare uno spazio tra il numero del capitolo e il suo nome) in qualsiasi di questi spazi.

Il significato dei bottoni disponibili è il seguente:

E#
Rappresenta il numero del capitolo
E
Rappresenta il testo del titolo
T
Rappresenta un «tabulatore». Per questi tabulatori è possibile scegliere un carattere di riempimento (in modo predefnito, i punti). È importante notare che questi tabulatori sono limitati in confronto a quelli normali per il testo e che non conviene utilizzarne più di uno per ogni riga:

Bug 32360 - tabstops on TOC are no fully functional (do not support right and middle alignment)

#
Rappresenta il numero della pagina

Il bottone «collegamento ipertestuale» permette che l'indice diventi «interattivo»: con un Ctrl + clic su una voce dell'indice (o un semplice clic nel PDF risultante) il cursore «farà un salto» alla pagina corrispondente. Nelle ultime versioni di LibO questa opzione è attiva in modo predefinito e si presenta come i due bottoni, uno all'inizio chiamato «LS» e l'altro alla fine chiamato «LE» che si vedono nella Figura 23.

Se ci troviamo di fronte a un documento vecchio e vogliamo attivare questa opzione sarà sufficiente collocare il cursore in uno spazio vuoto dove si vuole che inizi il collegamento e premere il bottone Collegamento ipertestuale (compare il bottone LE), poi collocare il cursore alla fine e fare clic ancora su Collegamento ipertestuale (compare il bottone LE).

È importante notare che selezionando ognuna delle voci nella struttura dell'indice è possibile applicare uno stile di carattere particolare per quella voce. Questo include i frammenti di testo inseriti manualmente e i bottoni del collegamento ipertestuale.

È poco probabile che succeda, però aggiungendo più contenuto a Struttura potrebbe capitare che sia necessario utilizzare le frecce agli stremi della linea per accedere a tute le sue parti.

In modo predefnito sui collegamenti ipertestuali viene applicato lo stile di carattere chiamato «Salto a indice» che non ofre nessun formato particolare. Se si vuole che i collegamenti si presentino, per esempio, in un altro colore è sufciente modifcare quello stile di carattere. Più informazioni sugli stili a pagina 49.

Per aggiungere uno spazio tra il numero del capitolo e il testo si deve aggiungere per ogni livello uno spazio tra le voci E# y E. Cioè, si deve fare clic nello spazio vuoto tra i botoni E# e E e aggiungere uno o più spazi.

Questa confgurazione della struttura mostrata dall'indice si deve realizzare per ogni livello.

Scheda Stili[modifica]

Quasi tutto in Writer è governato dagli stili (più informazioni nel capitolo B.3 a pagina 49) e l'indice non poteva essere un'eccezione. In questa scheda (Figura 24) si può scegliere quali stili saranno utilizzati da ogni livello dell'indice: è sufficiente selezionare un livello a sinistra, uno stile a destra e fare clic sulla freccia in mezzo per l'assegnazione.

Il bottone Predefinito permette di ritornare alla configurazione predefinita mentre che con il bottone Modifica si può accedere velocemente per modificare lo stile considerato, senza dover chiamare l'editore di stili e formattazione.

Schede Colonne e Sfondo[modifica]

Figura 24: Scegliere gli stili per l'indice

Non c'è tanto da dire su queste schede, tranne, forse, che il colore grigio che si vede come sfondo dell'indice durante la scrittura del documento anche se si lascia lo sfondo in «trasparente» non è un colore vero: si trova lì soltanto per dire che l'indice è stato generato automaticamente e pertanto non sarà stampato ne esportato in PDF. È possibile disabilitare questo sfondo (oppure cambiare il suo colore) in Strumenti → Opzioni → LibreOffice → Colori applicazione: è sufficiente togliere la spunta di Documento di testo, Sfondo indici e tabelle.

Qualche parola sui diversi tipi di indici[modifica]

Come già commentato, è possibile creare altre tipologie di indici. Gli indici di figure e tabelle funzionano soltanto se su queste viene applicata la didascalia, la quale si aggiunge con un clic destro sull'immagine e scegliendo Inserisci didascalia.

Il menù contestuale delle tabelle non ofre l'opzione di inserire la didascalia, però la barra degli strumenti contestuale che compare quando il cursore si trova su una cella della tabella sì: clic nel botone Didascalia e saremo pronti per scrivere.

Risulta anche possibile creare indici analitici: selezionando la parola da indicizzare facciamo Inserisci → Indice generale e indice analitico → Voce di indice (Figura 25) dove è possibile aggiungere il testo scelto sia in un indice analitico sia in un indice personalizzato (da lì è anche possibile aggiungerla all'indice generale: dovremo anche indicare a quale livello associare il testo).

Si deve tener conto del fatto che anche se è possibile «marcare» una voce per l'indice analitico dicendo che tutti i testi simili siano anche loro inclusi nell'indice, se viene aggiunto nuovo testo dopo la creazione della voce questo non sarà automaticamente marcato e perciò risulta conveniente lasciare la creazione degli indici analitici per la fine del processo di scrittura.

Bug 48684 - Index is not indexing new versions of already indexed words

I «criteri» (per attivare il secondo bisogna utilizzare il primo) servono a classificare le voci. In questo modo si può fare che le voci «pentola» e «tegame» siano classificati sotto «strumenti da cucina» mentre «spazzolino» e «shampoo» siano classificati sotto «bagno», anche se «strumenti da cucina» e «bagno» non si trovano sul testo.

Figura 25: Marcare voci dell'indice analitico

Un tipo particolare di indice con non poche differenze nei dettagli della sua costruzione con quello qui commentato è l'indice bibliografico del quale parleremo nel capitolo D.3, Il database bibliografico, a pagina 169.

«Salvare» un indice personalizzato[modifica]

Se dopo di aver personalizzato al massimo un indice lo cancelliamo, tutto il lavoro fatto sarà perso definitivamente. E non ne parliamo di riutilizzare questo lavoro in un nuovo documento.

Dunque?

Resta solo di creare un modello che includa l'indice personalizzato, in modo tale che creando un nuovo documento a partire da questo modello l'indice sia già pronto.

Note[modifica]

  1. Soltanto quando lo si crea. Non è possibile cambiare il «tipo» di un indice già inserito.