LibreOffice Writer/Introduzione ai documenti master

Wikibooks, manuali e libri di testo liberi.
Jump to navigation Jump to search
A. Introduzione
PrefazioneLibreOffice Writer/Prefazione
Nozioni GeneraliLibreOffice Writer/Nozioni Generali
B. Gli strumenti base
  1. Configurare l'interfaccia di LibreOfficeLibreOffice Writer/Configurare l'interfaccia di LibreOffice
  2. Commenti e controllo delle versioniLibreOffice Writer/Commenti e controllo delle versioni
  3. Stili e modelli in WriterLibreOffice Writer/Stili e modelli in Writer
  4. Numerare le pagine: gli stili di paginaLibreOffice Writer/Numerare le pagine: gli stili di pagina
  5. Organizzare e numerare i capitoliLibreOffice Writer/Organizzare e numerare i capitoli
  6. Immagini incorporate e collegateLibreOffice Writer/Immagini incorporate e collegate
C. Dare forma al contenuto
  1. Configurare l'indice generaleLibreOffice Writer/Configurare l'indice generale
  2. Elenchi numerati e puntatiLibreOffice Writer/Elenchi numerati e puntati
  3. Note a piè di pagina e note di chiusuraLibreOffice Writer/Note a piè di pagina e note di chiusura
  4. Le sezioniLibreOffice Writer/Le sezioni
  5. Testo in colonneLibreOffice Writer/Testo in colonne
  6. Usare le tabelle in WriterLibreOffice Writer/Usare le tabelle in Writer
  7. Le corniciLibreOffice Writer/Le cornici
  8. Correzione automatica e testo automaticoLibreOffice Writer/Correzione automatica e testo automatico
D. Strumenti avanzati
  1. Il navigatoreLibreOffice Writer/Il navigatore
  2. Campi, riferimenti incrociati e affiniLibreOffice Writer/Campi, riferimenti incrociati e affini
  3. Il database bibliograficoLibreOffice Writer/Il database bibliografico
  4. Introduzione ai documenti masterLibreOffice Writer/Introduzione ai documenti master
  5. MathLibreOffice Writer/Math
  6. DrawLibreOffice Writer/Draw
  7. Presentare dati graficamente: ChartLibreOffice Writer/Presentare dati graficamente: Chart
  8. Trovare e sostituire: le espressioni regolariLibreOffice Writer/Trovare e sostituire: le espressioni regolari
  9. Automatizzare processi: il registratore di macroLibreOffice Writer/Automatizzare processi: il registratore di macro
  10. Conformità registroLibreOffice Writer/Conformità registro
  11. Proprietà tipografiche avanzateLibreOffice Writer/Proprietà tipografiche avanzate
  12. EstensioniLibreOffice Writer/Estensioni
  13. Configurare la correzione ortograficaLibreOffice Writer/Configurare la correzione ortografica
  14. Writer, PDF e le immagini vettorialiLibreOffice Writer/Writer, PDF e le immagini vettoriali
E. Problemi e soluzioni
  1. Problemi sempliciLibreOffice Writer/Problemi semplici
  2. Problemi mediLibreOffice Writer/Problemi medi
  3. Problemi difficiliLibreOffice Writer/Problemi difficili
F. Appendice
Esempi e temi variLibreOffice Writer/Esempi e temi vari

Quando si crea un documento esteso, specialmente se contiene un gran numero di figure/tabelle/oggetti potrebbe non essere conveniente affidare il tutto a un unico file: da una parte lavorare con diversi file più piccoli invece che con uno gigantesco migliora il rendimento del programma mentre dall'altra parte riduce il rischio di perdita d'informazione quando qualcosa «esce male» (cadute del sistema, eccetera).

Potremmo anche stare lavorando in collaborazione con altri autori, ognuno portando avanti un capitolo particolare, perciò utilizzare un unico file non sarebbe pratico.

Dunque?

I documenti master sono uno strumento potente che permettono di lavorare in un unico progetto dividendolo in diversi file, mantenendo contemporaneamente la coerenza tra le sue parti.

Iniziare dalla stesa base[modifica]

Prima di tutto dobbiamo definire un modello con tutti gli stili di paragrafo/carattere/pagina/eccetera necessari per il nostro documento seguendo i passi commentati sia nell'introduzione agli stili e modelli a pagina 49 sia nell'introduzione alla numerazione pagine e agli stili di pagina a pagina 73.

Per evitare conflitti e possibili problemi sia il documento master sia i sub documenti saranno creati dallo stesso modello.

Dobbiamo dunque creare un nuovo documento a partire del modello. Senza scrivere niente in questo nuovo documento ce ne andiamo a File → Invia → Crea documento master: si aprirà una finestra di dialogo chiedendo dove salvare il documento master.

Per riuscire a vedere quello che segue potrebbe essere necessario il dire a LibO di utilizzare le sue proprie fnestre di dialogo per caricare/salvare i file e non quelle fornite dal sistema, altrimenti alcune opzioni potrebbero non essere disponibili. Per questo andiamo in Strumenti → Opzioni → LibreOffice → Generale e metiamo la spunta sull'opzione Usa finestre di dialogo di LibreOffice.

Figura 53: Creare un documento master

Come si può vedere nella Figura 53, nel dialogo per salvare il documento master troviamo l'opzione «separato da». Questa opzione risulta utile quando il documento master viene creato a partire da un documento esistente con diversi capitoli e parti: scegliendo un livello di struttura come separatore, verranno create anche i sub documenti contenendo i titoli di separazione e tutto ciò che si trova sotto.

Una volta salvato il documento .odm ora possiamo chiudere il documento vuoto utilizzato per creare il tutto senza salvarlo: non sarà più necessario.

Il passo seguente è creare, a partire dello stesso modello, uno o più sub documenti con il contenuto del progetto. È possibile per esempio creare un file per ogni capitolo.

I sub documenti non si possono modifcare dal documento master, bisogna lavorare su di loro in modo indipendente come documenti normali. Il documento master è soltanto un «contenitore» che serve a organizzare e stampare il tuto.

Aprendo Writer in modalità «documento master» è possibile che la barra laterale sia chiusa e che il navigatore compaia come una fnestra fotante. Credo che a questo punto il letore sa già come lavorare con questo. È sufciente vedere i capitoli B.1 (per la configurazione delle barre degli strumenti) e D.1 (per il navigatore).

Figura 54: Detaglio del Navigatore nella barra laterale in «modalità documento master»

Aprendo il documento master e, se non lo vediamo, il navigatore, troveremo quest'ultimo nella «modalità documento master», tale e come si può vedere nella Figura 54.

Il primo bottone a sinistra ci permette di alternare tra il navigatore per documenti master e quello «tradizionale».

I due bottoni seguenti li vedremo man mano che saranno necessari.

Il quarto bottone è un menù a tendina per inserire elementi: con un clic sopra troveremo tre opzioni, che sono:

  • Indice
  • File
  • Nuovo documento

La prima opzione risulta chiara (inserisce un indice che presenterà il contenuto di tutto il documento).

Non raccomando l'uso della terza opzione, soprattutto per i nuovi utenti di questo strumento perché può risultare confuso.

La seconda opzione ci permette di inserire i sub documenti creati in modo indipendente. Si deve tener presente che i sub documenti vengono inseriti sopra l'oggetto scelto nella lista e perciò sarà sempre necessario utilizzare i bottoni sesto e settimo del navigatore per far salire o scendere il sub documento nella lista.

Dopo aver inserito un paio di documenti nel menù Inserisce del navigatore compare una nuova opzione chiamata Testo. Quest'opzione ci permette di inserire del testo tra due sub documenti: questo testo sarà contenuto nel documento master e può essere utilizzato, per esempio, per separare gruppi di capitoli, creare la pagina del copyright…

Con un doppio clic nel nome del documento mostrato nel navigatore, questo documento verrà aperto per poter modificarlo.

Un'altra forma è selezionare il documento della lista e fare clic nel secondo botone del navigatore.

Riferimenti incrociati[modifica]

I riferimenti incrociati all'interno di un documento non sono un problema (vedere il capitolo D.2.2 a pagina 160), ma se dobbiamo fare in un sub documento un riferimento incrociato a un altro documento, come si fa?

Nel documento che vogliamo «chiamare» dobbiamo selezionare il testo al quale vogliamo fare riferimento e andare a Inserisci → Comando di campo → Altri campi → scheda Riferimenti incrociati, scegliamo Imposta riferimento e li diamo un Nome prima di fare clic in Inserisci. Adesso andiamo al documento dal quale vogliamo chiamare il riferimento e ancora Inserisce → Comando di campo → Altri campi → scheda Riferimenti incrociati, però questa volta si deve scegliere Inserisci riferimento: nel campo Nome dobbiamo scrivere il nome stabilito nell'altro documento e non fare attenzione al messaggio d'errore che compare al fare clic in Inserisci (Errore: sorgente del riferimento non trovata) perché nel documento master tutto si vedrà correttamente.

Quello sul quale vogliamo fare riferimento può essere non solo il testo del titolo del capitolo, ma anche una variabile come il numero di una fgura, un testo qualsiasi come un paragrafo particolare o una nota a piè di pagina.

Risulta conveniente creare un documento (per esempio, in Calc) con la lista di tuti i riferimenti incrociati da noi definiti in modo tale che il nostro lavoro risulterà più semplice.

Per aggiornare il documento master possiamo utilizzare il terzo bottone del navigatore, anche questo un menù (Aggiornare), scegliendo l'opzione Tutto e accettando l'opzione di aggiornare tutti i vincoli.

Ogni volta che si apre il documento master comparirà la domanda se si vogliamo aggiornare tuti i vincoli: dobbiamo dire di sì, altrimenti non vedremo il contenuto dei sub documenti.

Possibile problemi[modifica]

Come già commentato, anche se i campi di riferimento incrociato danno errore nel documento master tutto sarà giusto. Ma questo non vuol dire che non ci siano problemi: infatti, dato che il messaggio d'errore occupa più spazio che il vero riferimento non possiamo affidarci alla distribuzione del contenuto vista nel sub documento perché passando al master sicuramente risulterà diversa.

Altri campi influenzano pure la distribuzione del contenuto: se per esempio le figure vengono numerate correlativamente in tutto il documento ci sarà il problema che quello che è certamente la figura 1 nel sub documento 25 sarà forse la figura 114 del documento completo, e certamente 114 si prende più spazio che 1, il che modificherà la distribuzione del contenuto.

Ho pure visto qualche problema con immagini grandi che occupano più della metà della pagina: ogni tanto, nel documento master potrebbero comparire pagine in bianco prima delle immagini che non dovrebbero essere lì. Normalmente questo si risolve aggiornando il documento master un paio di volte, oppure salvando, chiudendo e aprendo ancora.

Non chiedete…

Si deve tenere presente che le definizioni degli stili nel documento master hanno la precedenza su quelle dei sub documenti: se si cambia uno stile in un sub documento questo cambio non si vedrà nello stile con lo stesso nome nel master a meno che quest'ultimo venga pure aggiornato.

D'altra parte, se viene creato un nuovo stile in un sub documento questo verrà importato nel master… ma non sarà disponibile negli altri sub documenti.

È per questo conveniente modificare lo stile nel modello corrispondente e accettare le modifiche quando un documento basato su quel modello viene aperto.

ATTENZIONE!

Non ancorare mai immagini o altri oggeti «alla pagina» nei sub documenti: dato che il documento maestro ha la precedenza potrebbero presentarsi problemi (quello che risulta una chiara pagina 3 nel sub documento potrebbe essere la pagina 150 nel master.). È sempre meglio ancorare gli oggeti «al paragrafo», «al carattere» oppure «come carattere».

Riunificare tutto[modifica]

Per diversi motivi potrebbe essere necessario unificare tutti i sub documenti in un unico documento «reale». Il modo più semplice è il seguente:

  1. Dal documento master con tutti i vincoli aggiornati, Formato → Sezioni.
  2. Una per una, selezionare le sezioni e premere Rimuovi.
  3. File → esporta e in Formato file scegliere Documento di testo ODF (.odt), dare un nuovo nome e premere Esporta.
  4. Se si desidera conservare anche il documento master originale, chiuderlo SENZA salvare le modifiche.

Il documento odt così creato avrà tutto il contenuto dei sub documenti. Alcuni aggiustamenti minori (o no) potrebbero essere necessari.

Attivando il quinto botone del navigatore si salverà una copia dei sub documenti all'interno del master, però questo non è lo stesso che unifcare il tuto, creando un documento indipendente dell'originale.

Quando utilizzare documenti master[modifica]

I documenti master risultano indispensabili quando si lavora in collaborazione: ognuno dei collaboratori lavora nella sua parte e dopo si crea un unico documento che riunisce il tutto.

Dunque, la domanda è: sono i documenti master utili anche quando si ha un unico autore?

La risposta a questa domanda non è semplice. Come visto, il documento master implica un po' più di lavoro con i riferimenti incrociati e può dare problemi quando si hanno tanti oggetti o immagini.

Se il documento è di testo puro, Writer può gestire centinaia dopo centinaia di pagine senza problemi e perciò il documento master non offre qui nessun vantaggio. Infatti, anche se si hanno tante immagini forse vincolarle (vedere pagina 85) potrebbe dare maggiore agilità.

Un altro motivo per separare un documento in diversi sub documenti potrebbe essere avere tanti oggetti Math inseriti, perché questo potrebbe agire negativamente sul rendimento del programma. Per il resto… ognuno dovrà valutarlo per vedere se ne vale la pena o meno.